Avidemux Forum

Avidemux => Windows => Topic started by: fish on January 20, 2019, 06:51:18 AM

Title: Drag and drop append appears to be broken.
Post by: fish on January 20, 2019, 06:51:18 AM
I have just tried appending 3 mp4 files with 'avidemux_r190108_win64Qt5_13' and 'avidemux_r190118_win64Qt5_18' both fail to append the files. The last old 'major' release appends them successfully. Does anyone else see this, I'm on Win7 Pro 64bit.

edit. I tried again using 'avidemux_r190118_win64Qt5_18' but this time using File>Append in the drop down menu and that works ok, so the solution I suppose is use that. I remember a while back someone was grumbling about drag and drop append for some reason I can't recall. Has this drag and drop function been removed?
Title: Re: Drag and drop append appears to be broken.
Post by: eumagga0x2a on January 20, 2019, 11:19:27 AM
No changes for drag-n-drop-to-append intended, WFM with a build containing a fix for the issue mentioned in https://avidemux.org/smif/index.php/topic,18574.0.html (https://avidemux.org/smif/index.php/topic,18574.0.html). Any non-ASCII characters in file names?
Title: Re: Drag and drop append appears to be broken.
Post by: fish on January 20, 2019, 11:35:34 AM
No, all the names were very ordinary English and short. When dragging and dropping, the first file loads, the following two don't and the export is just the first file. The avidemux zip file is simply unzipped to a folder using 'checkout' and launched from the 'avidemux.exe' file. Could that be causing a problem? Can you reproduce what I see with 3 small mp4's?
Title: Re: Drag and drop append appears to be broken.
Post by: eumagga0x2a on January 20, 2019, 11:40:10 AM
I didn't try with more than two files yet (the first one loaded using File --> Open and the second one drag-n-dropped onto Avidemux window), which worked fine exporting both in a single video. I'll recheck with multiple source videos.
Title: Re: Drag and drop append appears to be broken.
Post by: fish on January 20, 2019, 12:00:07 PM
I also tried what you did ie loaded the first file using  File>Open and dragged/dropped the other two. Only the first one loaded and saved. I also tried with just two files, with the same result. Dragging/dropping all three does work fine with the last main release version.
Title: Re: Drag and drop append appears to be broken.
Post by: eumagga0x2a on January 20, 2019, 01:11:37 PM
I can't reproduce it with my local mingw builds off the ffmpeg4x branch, drag-n-dropping 4 files loads the first one and appends the remaining 3, saving the video exports all 4 in a single video. Tested also with file names containing CJK and cyrillic characters.

Please recheck once new official nightlies become available.
Title: Re: Drag and drop append appears to be broken.
Post by: fish on March 29, 2019, 09:32:01 PM
Just returning to this because I have noticed that drag and drop append works most of the time, sometimes it will work with 5 out of six files or maybe 4 out of six and sometimes it doesn't work at all. I usually edit files individually before using append, so they should all at least start with an I-Frame. Of course the drop down menu append works so it's no show stopper, just an observation.
Title: Re: Drag and drop append appears to be broken.
Post by: eumagga0x2a on March 29, 2019, 09:47:52 PM
Are there any clues from admlog.txt when appending multiple files using drag and drop partially or completely fails?
Title: Re: Drag and drop append appears to be broken.
Post by: fish on March 29, 2019, 11:07:47 PM
Are there any clues from admlog.txt when appending multiple files using drag and drop partially or completely fails?

...There might be...if I knew what to look for...
Next time I see the problem I will have a look at admlog.txt and who knows, maybe it will make sense to me. Could you give me a clue as to what I should be looking for or is it a case of, 'if you knew that, you would have tried to fix it already'?
Title: Re: Drag and drop append appears to be broken.
Post by: eumagga0x2a on March 29, 2019, 11:15:42 PM
It would be already immensly useful if you just preserve log files from sessions when you experienced problems with drag and drop for later examenation. I would like to check whether Avidemux registers at all that something is inbound, maybe the append fails somewhere in Qt so that the application doesn't get a clue. 
Title: Re: Drag and drop append appears to be broken.
Post by: fish on March 30, 2019, 03:02:06 AM
Saving the log files would not be a problem, although I have a feeling that I could be staring at the problem without realising. I will look in file, who knows, it might make some sense to me but ultimately you or someone else knowledgeable would need to see it, along with details of which file/files failed etc. I've been using the function quite often lately so the problem should show itself soon.
Title: Re: Drag and drop append appears to be broken.
Post by: fish on March 31, 2019, 12:24:09 PM
I have just tried to use drag and drop append on 4 files, it failed using drag and drop but succeeded using append in the drop down menu. I saved the log files from both attempts and will compare them and have attached the files on this post because ultimately someone with more knowledge than me will need to see them. Log 1 is the fail, log 2 was the success.

edit. I should add that when I drag the 2nd 3rd and 4th file in, I get the arrow and plus sign in the viewer but when I release the mouse button nothing happens. I don't know whether comparing the two logs can help as nothing appears to happen when I release the mouse button to drop the file in.
Title: Re: Drag and drop append appears to be broken.
Post by: fish on March 31, 2019, 12:54:22 PM
I will try a few tests later with different types of file. I think chopping up a small file into 4 pieces and trying to put it back together, using both append methods, would be a good test. The files in the logs I attached were parts of a live stream
Title: Re: Drag and drop append appears to be broken.
Post by: eumagga0x2a on March 31, 2019, 03:19:36 PM
Thank you, the first log lets me think that the issue is purely within Qt / Windows Explorer and out of our control. Nevertheless, would it be thinkable for you to test a patched (the patch is attached to the post) private MinGW win64 build off the current ffmpeg4x git branch? I've uploaded it to WeTransfer (https://we.tl/t-QX7IRa74U0).

The idea is to try out whether basically reverting https://github.com/mean00/avidemux2/commit/35843f11fddd83a8b985c459439bea2945ca5d71 (https://github.com/mean00/avidemux2/commit/35843f11fddd83a8b985c459439bea2945ca5d71) and using the stock QDropEvent directly in the event filter instead of constructing an intermediate user defined event makes a difference (I would not expect it, but I might miss something).
Title: Re: Drag and drop append appears to be broken.
Post by: eumagga0x2a on March 31, 2019, 03:25:33 PM
Another possibility would be to test drag and drop from a different file manager, e.g. Total Commander.

By the way, why didn't you upgrade to 2.7.3? BMP image loading and WMAPRO decoding were fixed in the two days which separate the nightly build you use from the release.
Title: Re: Drag and drop append appears to be broken.
Post by: eumagga0x2a on March 31, 2019, 03:29:47 PM
I forgot to publish checksums for the private build:

Code: [Select]
sha256sum avidemux_r190331-162845_win64Qt5.zip
e1433f11474570da0be391f70fe0f097020e225bdde019bc1a329b00381dea0b  avidemux_r190331-162845_win64Qt5.zip

md5sum avidemux_r190331-162845_win64Qt5.zip
a6bdadc149cda6728be655f26799c0a7  avidemux_r190331-162845_win64Qt5.zip

File size: 42772103 bytes.
Title: Re: Drag and drop append appears to be broken.
Post by: fish on March 31, 2019, 06:22:22 PM
Thank you, I will give this version a try. Something changed between v2.7.1 and v2.7.2 which is causing the problem. I first noticed when I tried one of the nightly versions that was current around the start of this thread, so between v2.71 and then.
I didn't update to version v2.7.3  because I didn't notice but I will update to that version now. I tend to stick with a version for a while, the reasoning  being that in frequent updates, eventually something may change that produces junk files. You then end up with a lot of defective files before realising and no way back. At least keeping the same version, I know what works and if I really need an update then I will. I guess it depends on the paranoia level of each person.
Title: Re: Drag and drop append appears to be broken.
Post by: eumagga0x2a on March 31, 2019, 06:48:03 PM
My personal experience shows that known good versions of anything may have unknown catastrophic issues so that the only virture which matters is a solid failure management.

If your are sure that 2.7.1 was not prone to file URLs lost on drag and drop operations (something I could not yet reproduce with any version), then the most likely delta is a more up-to-date Qt version in 2.7.2 and on. You could try if legacy-compat (Windows XP compatible) 32 bit builds perform better in this respect. These builds are generated using a very old MXE snapshot with a correspondingly old Qt.

There is also an unknown variable of on-access virus scanners which may interfere with virtually any operation.
Title: Re: Drag and drop append appears to be broken.
Post by: fish on March 31, 2019, 08:43:03 PM
I tested v2.7.3 and avidemux_r190331-162845_win64Qt5 (the file from github), both failed in drag and drop using files that failed with v2.7.2. I then installed v2.7.1 that succeeded. I also tried a v2.5.6 that I keep installed for certain operations, that also succeeded in appending the files by drag and drop. So v2.7.2 and v2.7.3 failed, while v2.7.1 and v2.5.6 succeeded. It may not be 100% proof but it does point a very large finger at some change between v2.7.1 and 20th Jan. It's not a critical fault or 'catastrophic'  :) but just an observation.
Title: Re: Drag and drop append appears to be broken.
Post by: eumagga0x2a on March 31, 2019, 08:47:22 PM
Please test the win32 2.7.2 release. This is needed to attribute the failure straight away to Qt (or not).

edit: 2.7.1 and earlier is synonymous for unknown catastrophic failure :-D
Title: Re: Drag and drop append appears to be broken.
Post by: eumagga0x2a on March 31, 2019, 09:12:37 PM
The official 2.7.1 win64 release build (1) uses Qt 5.8.0, the official 2.7.2 win32 one (2) uses Qt 5.7.1 and 2.7.2 win64 (3) as well as my private build Qt 5.12.0.

2 and 3 share +/- the same GUI codebase.
Title: Re: Drag and drop append appears to be broken.
Post by: fish on March 31, 2019, 09:40:30 PM
I'll give that a go later.

Also here is a test example I tried that failed in v2.7.3 but succeeded in v2.7.1. I would like to hear what results you get using v2.7.3 just in case I have entered the twilight zone without realising. It's just a file that was cut into 4 pieces using v2.7.3.

https://we.tl/t-GoE0nAXZDP

P.S. I got on very well with v2.7.1 blissfully unaware of any catastrophe.
Title: Re: Drag and drop append appears to be broken.
Post by: eumagga0x2a on March 31, 2019, 09:46:46 PM
Drag' and dropping all four fragments works fine on Linux, will reboot to test on Windows 7 64 bit Home.
Title: Re: Drag and drop append appears to be broken.
Post by: eumagga0x2a on March 31, 2019, 10:01:25 PM
I'm sorry, but the official 2.7.3 VC++ loads 1.mp4 and appends 2.mp4, 3.mp4 and 4.mp4 per drag-and-drop of a multiple selection from Windows Explorer impeccably on my Windows 7 64 bit Home. I doubt that the detail that you run Avidemux on the Business Edition may matter, so it must be something different what causes the problem.

Can you rule out an on-access virus scanner?
Title: Re: Drag and drop append appears to be broken.
Post by: fish on March 31, 2019, 10:31:30 PM
I was half expecting that, I would also not be surprised if I get the same results as you if I repeat the tests tomorrow. It's partly the reason for the long gap between the first post in this thread and revisiting it now. It mostly worked in between then and now, today it doesn't appear to work at all. I'll have another stab at it tomorrow, it not as if append doesn't work at all.
Title: Re: Drag and drop append appears to be broken.
Post by: fish on April 02, 2019, 09:17:38 AM
I have tested several versions using the four test files and assuming the problem doesn't originate from between my desk and chair, here  are the results.

v2.7.1 64 bit - drag and drop append and drop down menu append succeeds.

v2.7.2 32 bit - drag and drop append and drop down menu append succeeds

v2.7.3 & v2.7.2 64 bit - drag and drop append fails and drop down menu append succeeds.

Is there a version of v2.7.3 64 bit that doesn't use VC++.  It would be interesting to try that. As no one else is seeing this the obvious solution for me is to use v2.72 32 bit, so it is just curiosity on my part.

Title: Re: Drag and drop append appears to be broken.
Post by: eumagga0x2a on April 02, 2019, 09:26:43 AM
v2.7.2 32 bit - drag and drop append and drop down menu append succeeds

This points to Qt > 5.8.x then. Still, I can't reproduce the issue, no matter how hard I try.

Quote
Is there a version of v2.7.3 64 bit that doesn't use VC++.  It would be interesting to try that.


This was my private build you tried.
Title: Re: Drag and drop append appears to be broken.
Post by: fish on April 02, 2019, 09:35:22 AM
Ah, I didn't try that, I will try that again just to be sure.

edit. No, that also failed, I will simply use v2.72 32 bit or the v2.7.3 menu append if I need that function.

Thanks for your help.

edit I forgot to answer your virus scanner query, I use only Windows Defender and run Malwarebytes every month or two.
Title: Re: Drag and drop append appears to be broken.
Post by: fish on April 02, 2019, 10:41:07 AM
Just one more query and I'm done with this, the version you uploaded to WeTransfer, was it a patched version or does that still require the patch to be added? You guessed it, I didn't add it nor do I have a clue which folder it should be added to.
Title: Re: Drag and drop append appears to be broken.
Post by: eumagga0x2a on April 02, 2019, 11:16:26 AM
It is a patched version (the patch was attached for reference) as I was unsure whether the present two-stage solution to handle drop events might be related to the issue.

Anyway, the topic helped me to understand Avidemux' drag and drop code better, even if we could not identify the nature of the problem as a virus scanner seems to be not involved either.
Title: Re: Drag and drop append appears to be broken.
Post by: jimmyrave on July 07, 2019, 03:11:07 PM
Quote
When dragging and dropping, the first file loads, the following two don't and the export is just the first file.

Just encountered this problem with 2.7.3 64bit main release and the latest 190630 Nightly, upgrading from 2.7.0
Uninstalled 2.7.3 and installed 2.7.1 and drag & drop is working again. On Window 7 64bit
Title: Re: Drag and drop append appears to be broken.
Post by: eumagga0x2a on July 07, 2019, 10:00:19 PM
Just encountered this problem with 2.7.3 64bit main release and the latest 190630 Nightly

Which one? vsWin64 (native builds compiled using Microsoft Visual Studio C++), win64 (MinGW builds cross-built on Linux) or both equally?

Quote
Uninstalled 2.7.3 and installed 2.7.1 and drag & drop is working again.

Does this apply to the latest Windows 32 bits nightly (190702 at the moment) too? https://avidemux.org/nightly/win32/

Quote
On Window 7 64bit

Any ideas what should I do to be able to reproduce this issue?
Title: Re: Drag and drop append appears to be broken.
Post by: CakeMountain on August 06, 2019, 06:12:44 PM
Experienced same issue on Windows 10 64 bit.

2.7.1 64 bit Avidemux drag and drop WORKS.

2.7.2 64 bit and 2.7.3 64 bit drag and drop append does not work. HOWEVER using File>Append will work and also multiple selected videos dragged and dropped seems to work.

As suggested by eumagga0x2a, I just tried nightly build 32 bit Avidemux 2.7.4 190804_a9f8b0a64b6-fflibs 3.3.9 and drag and drop append DOES work.

Possibly a difference between the 64 and 32 bit versions?
Title: Re: Drag and drop append appears to be broken.
Post by: CakeMountain on August 06, 2019, 06:21:40 PM
Confirmed by downloading latest 64 bit nightly version 2.7.4 190804_f5d6dc9342e-fflibs 4.1.4 Drag and drop append does NOT work.

so yes it seems to be the 64 bit version that is having this problem.... at least for me.
Title: Re: Drag and drop append appears to be broken.
Post by: eumagga0x2a on August 06, 2019, 11:14:24 PM
2.7.2 64 bit and 2.7.3 64 bit drag and drop append does not work. HOWEVER using File>Append will work and also multiple selected videos dragged and dropped seems to work.

Other users in this topic report it exactly other way round: drag'n'drop of a single video works, drag'n'drop of multiple videos fails. All that remains useless unless someone gets a clue what might be the trigger for the failures as drag'n'drop consistently works for me on Windows.

Quote
As suggested by eumagga0x2a, I just tried nightly build 32 bit Avidemux 2.7.4 190804_a9f8b0a64b6-fflibs 3.3.9 and drag and drop append DOES work.

Possibly a difference between the 64 and 32 bit versions?

A different Qt version.

The 32bit version is built off the legacy-compat branch, not from the git master in a very old snapshot of MXE with an old Qt version (5.7.x vs 5.12.0 if I am not mistaken). There are two different 64bit versions, one natively built with Microsoft Visual Studio C++ on Windows and the other one cross-built with MinGW on Linux. Both use currently the same Qt version (5.12.0 if I remember correctly).
Title: Re: Drag and drop append appears to be broken.
Post by: eumagga0x2a on August 14, 2019, 08:08:09 AM
@all who reported drag'n'drop not working: does it work for you when you drop NOT onto the video display of the previously loaded video but onto a different part of Avidemux GUI?

It looks like I was able to reproduce it on Windows 10 in HiDPI conditions and with Qt autoscaling enabled only. The frame holding the video display accepts drops, but then nothing happens. Dropping e.g. onto codec widget or menu bar works. Looking into it.

edit: No, HiDPI scaling is not a factor here. Drag and drop consistently works when file manager window (the drag source) has focus and Avidemux is in background. If the Avidemux window is in foreground, drops onto video display as target fail, drops onto any other part of the GUI work.
Title: Re: Drag and drop append appears to be broken.
Post by: eumagga0x2a on August 14, 2019, 10:26:48 AM
Should be fixed now (https://github.com/mean00/avidemux2/commit/eb62234908fdf9d2ced5af4f0d8ab0f06c376a12).
Title: Re: Drag and drop append appears to be broken.
Post by: CakeMountain on August 16, 2019, 07:20:05 PM
Should be fixed now (https://github.com/mean00/avidemux2/commit/eb62234908fdf9d2ced5af4f0d8ab0f06c376a12).

Outstanding work! Much thanks!
Confirmed good fix on drag and drop append single file 64 Bit nightly build avidemux_r190814_win64Qt5_56 from 14 Aug 2019.

Thanks Thanks Thanks!