[SOLVED] Help using Avidemux 2.5.4 please.

Started by Fleabag, February 25, 2012, 01:53:53 AM

Previous topic - Next topic


Good.  The output tells me that you have:  "avidemux-2.5.4-i586-1vl70 [inst=yes]: avidemux (a video editor)"

Let's see if there are any newer Avidemux versions available from Vector Linux..  Please run this and paste the output into a gist:

slapt-get --search avidemux



I think that I know what the problem is...so the question that I have now is - How do I go about fixing it?


With your last gist and the updated list of software you just downloaded, we now find that 2.5.4 is the most recent version that Vector Linux wants to provide for you.

If 2.5.4 is the most recent version, then we can only try to reinstall it.  Here is the command:

slapt-get --reinstall --install avidemux

Good luck.


The output is as follows:


but the end result is EXACTLY the same.

So what do you suggest that I try next?


We now look to see what happened during the install by reading the log.
Put this url into Firefox or Opera or Safari or whatever and go to it:


Please select all the text that appears and paste it into a gist.


I won't have to, because all of the resulting text is as follows:

doctor:$ file:///var/log/packages/avidemux-2.5.4-i586-1vl70
bash: file:///var/log/packages/avidemux-2.5.4-i586-1vl70: No such file or directory




It will work.  Sorry sometimes they rename things.  Click the avidemux link that shows up after that page loads.  Give us a gist.



You don't paste that into a command prompt, you paste that into Firefox or some other web browser.
I am asking you to:

1) Put file:///var/log/packages  into your browser URL bar and make it go there. (Firefox, Opera, Safari, whatever you use)

2) Then press the Return Key:

3) Click the avidemux link.
4) gist.


Sorry about that. Here is the information that you asked for (I hope): https://gist.github.com/1988913


Yes that confirms the problem.  I can see your /usr/lib/ADM_plugins directory is empty.  Vector Linux did not build you any plugins, and those are mandatory.   The only way to get the plugins is to build avidemux from source like most people.  You have a Debian like Operating System.  Avidemux will build on that.

slapt-get --remove avidemux
slapt-get --install build-essential
slapt-get --install cmake
slapt-get --install fakeroot
slapt-get --install make
slapt-get --install subversion
slapt-get --install gcc
slapt-get --install g++
slapt-get --install gettext
slapt-get --install liba52
slapt-get --install libasound2
slapt-get --install libarts1
slapt-get --install libfaac
slapt-get --install libfaad
slapt-get --install libgtk
slapt-get --install libglibv
slapt-get --install libmad
slapt-get --install libvorbis
slapt-get --install libx264
slapt-get --install libxv
slapt-get --install libxml2
slapt-get --install libxvidcore
slapt-get --install yasm

Some of those probably won't work because I have the name wrong.
Make a list of the ones that worked.  Make a list of the ones that didn't.
Please give me the lists.


The files that I have (according to the Gslapt Package Manager are:


and yasm

The ones that I don't have are: build-essential , and all of the lib files. And while I'm on the subject, should I then download and build the Debian Version of Avidemux, and if so, which of those files will I need?


This is the file you will eventually build from:  http://downloads.sourceforge.net/avidemux/avidemux_2.5.6.tar.gz

These are some more commands to get the deps installed.
Let me know how it goes:

slapt-get --install a52
slapt-get --install asound
slapt-get --install arts
slapt-get --install faac
slapt-get --install faad
slapt-get --install gtk
slapt-get --install glib
slapt-get --install mad
slapt-get --install vorbis
slapt-get --install x264
slapt-get --install xv
slapt-get --install xml2
slapt-get --install xvid

If it doesn't have anything for faad, then do: slapt-get --search faad
Good luck.


Of the recent list of commands that you mentioned, the ones that I do NOT have are:

asound (I have alsa)
(I have vorbis-tools, and libvorbis)
and xvid (I have xvidcap)

I do have all the other files mentioned.


slapt-get --search asound
slapt-get --search arts
slapt-get --search xml2
slapt-get --search xvid

that is an XML2, not XM12.  please.