Author Topic: Multi-threading and HDV, doesn't work  (Read 9078 times)

cord-factor

  • Newbie
  • *
  • Posts: 17
Multi-threading and HDV, doesn't work
« on: March 08, 2012, 09:32:36 AM »
Hello all,
I have Canon HV40 video camera, which makes HDV (1440x1080i, MPEG2) files. Here is example
http://dl.dropbox.com/u/59413997/Birds_HD.m2t (~76mb)
This file is retarding during avidemux play, and the CPU load is about 50% (two core processor). I have tried to change multi-threading option, but no luck :(
Or it is normal for HDV? System Windows XP, SP3.


ps Can anybody check this file for subj? Thanks.
« Last Edit: March 08, 2012, 09:54:45 AM by cord-factor »

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 6060
Re: Multi-threading and HDV, doesn't work
« Reply #1 on: March 08, 2012, 10:20:38 AM »
There might be some issues with this .m2t. Can't open it with 2.6.
2.5.6 Opens it with Info window:
Quote
No audio decoder found for this file

Code: [Select]
Editor :Audio streamer initialized
 Unknown codec : 80[RDR] Resizing to 1440 x 1088
[RDR] Resizing to 720 x 544
[lavc] Warning: data is not aligned! This can lead to a speedloss
gist.github Avidemux v2.5.5 r7742 terminal output for Birds_HD.m2t


cord-factor

  • Newbie
  • *
  • Posts: 17
Re: Multi-threading and HDV, doesn't work
« Reply #2 on: March 08, 2012, 10:49:04 AM »
It's so strange, I have no problems with it on any computer (version 2.5.6, and ffdshow is installed). There is usual mpeg layer 2 audio stream.

Anyway, try this:
http://dl.dropbox.com/u/59413997/Birds.m2v
The same video, but without sound.

Is multi-threading working during avidemux play?
« Last Edit: March 08, 2012, 10:52:21 AM by cord-factor »

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 6060
Re: Multi-threading and HDV, doesn't work
« Reply #3 on: March 08, 2012, 12:38:52 PM »
On ubuntu 11.10 64-bit avidemux is using 4 cores of an Intel core i5. cpu usage 25%
Mostly multiprocessor would be noticed on encoding. Could be the video clip/ codec is causing this? Avidemux tells no accelleration is used?
Processor usage can be checked with this tool Process Explorer <- click
Some movieclips that should be playing alright: Tekzilla Daily Tip: Download this episode in MP4 HD and large <- click. See if these play ok in avidemux, if not could be hard disc/ memory/ video card (driver) problem?

same for 2.5.6
Quote
*** NO AUDIO ***
[RDR] Resizing to 1440 x 1088
[RDR] Resizing to 720 x 544
[lavc] Warning: data is not aligned! This can lead to a speedloss


** conf updated **
One frame : 40, err=0 ms
No accel used for rendering
Same for Birds.m2v not opening on 2.6
Quote
[HandleAction]  ************ OPEN_VIDEO **************
  [paintGL]  Painting dummy openGl widget
 [TS Demuxer] Probing...
 [checkMarker]  [Ts Demuxer] Sync ok :16 Sync ko :3869
  [checkMarker]  [Ts Demuxer] Sync ok :11 Sync ko :3869
  [detectTs]  [TS Demuxer] Not a TS file
  [TS Demuxer] Not a ts file
 [MP4] Cannot open that...
 [avsProxy] Cannot open that
 [asfHeader] Cannot open that
 [openDML] Cannot open that
 [flvHeader] Cannot open that
 [mxfHeader] Cannot open that (b3010000)
 [mkvHeader] Cannot open that
 [picHeader] Cannot open that
 match :0 / 455 (probeSize:1048576)
 [PS Demuxer] Not a ps file

cord-factor

  • Newbie
  • *
  • Posts: 17
Re: Multi-threading and HDV, doesn't work
« Reply #4 on: March 08, 2012, 03:12:17 PM »
On ubuntu 11.10 64-bit avidemux is using
Can you check it under 'windows'?

Processor usage can be checked with this tool Process Explorer <- click
Some movieclips that should be playing alright: Tekzilla Daily Tip: Download this episode in MP4 HD and large <- click. See if these play ok in avidemux, if not could be hard disc/ memory/ video card (driver) problem?
No, it is same here. Your clip in 720p, in 'safe mode' is retarding too. CPU usage is 50%. So, multi-threading is not working for me.
Why? What can I do?



Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 6060
Re: Multi-threading and HDV, doesn't work
« Reply #5 on: March 08, 2012, 05:52:19 PM »
Can you check it under 'windows'?
Sorry don't have dual core cpu with windows.
Quote
No, it is same here. Your clip in 720p, in 'safe mode' is retarding too. CPU usage is 50%. So, multi-threading is not working for me.
Why? What can I do?
Close all none essential programs, saving memory. Use ccleaner to clean hard disk of redundant files and freeing up space. Defrag hard disk with disk defrag free for efficient file placement. Check if there is update for video card driver?

nibbles

  • Sr. Member
  • ****
  • Posts: 292
Re: Multi-threading and HDV, doesn't work
« Reply #6 on: March 08, 2012, 05:54:10 PM »
I will look into your links in a bit, but the mantra around here is that "avidemux is not a video player."  Do not expect it to play things efficiently, nor to include sound in sync during such playback.  Encodes and copies will be synced, and that is its job.  Seems reasonable?

cord-factor

  • Newbie
  • *
  • Posts: 17
Re: Multi-threading and HDV, doesn't work
« Reply #7 on: March 09, 2012, 08:05:20 AM »
the mantra around here is that "avidemux is not a video player."
I am agree with you in 100%. But it's retarding almost to half speed, ie to see one hour of video I need two real-time ones. It's so uncomfortable :(

Check if there is update for video card driver?
I have laptop with CPU - Mobile DualCore AMD Athlon 64 X2 TK-55, 1800 MHz; motherboard - MCP67M nVIDIA nForce 610M, with integrated NVIDIA GeForce 7000M (it does't support any hw accel., and it's so old).
So, there is not (and will be not) any driver updates to my videocard. However, the conversation is about CPU, and it's cores. Video card is not to blame.

ps Seems like I have to change my laptop to something modern...

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 6060
Re: Multi-threading and HDV, doesn't work
« Reply #8 on: March 09, 2012, 02:22:04 PM »
If your CPU works at 50%, it still has 50% left to work with and is not using it. The bottleneck can have several causes. Avidemux multithreading <- click

cord-factor

  • Newbie
  • *
  • Posts: 17
Re: Multi-threading and HDV, doesn't work
« Reply #9 on: March 09, 2012, 04:23:14 PM »
If your CPU works at 50%, it still has 50% left to work with and is not using it. The bottleneck can have several causes. Avidemux multithreading <- click
Yes. According to that multi-threading must work (MPEG-2 codec), but it's not.