Author Topic: Audio too fast when saved...  (Read 10522 times)

Theother12345

  • Newbie
  • *
  • Posts: 4
Audio too fast when saved...
« on: April 18, 2012, 05:24:26 AM »
This is my first time using any video editing software, and I was wondering how to split a video into two different vids.

What I did was use the "set maker A" and "set maker B" to split one half of the video; then save. The only problem was, the saved video's audio was way too fast. It's normal in the editing; but when saved, it becomes faster than the actual video, and ends way too early. It's basically not in sync. Anyone experience anything like this and have suggestions on how to fix it? Thanks.

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 6060
Re: Audio too fast when saved...
« Reply #1 on: April 18, 2012, 10:03:01 AM »
When you split video with Video: Copy and Audio: Copy and keep the same container in Output Format that should not happen what you report. Audio and video content are not changed. If video behavior persists: please give more details: Used version avidemux and 32-bit or 64-bit? What OS: XP, Vista or Windows 7, 32-bit or 64-bit?
Info on video you want to split: coantainer: avi, mp4, ... used codecs for video and audio.
What settings do you use in avidemux? Perhaps someone can figure out what is going on and if there is a possible solution.

Theother12345

  • Newbie
  • *
  • Posts: 4
Re: Audio too fast when saved...
« Reply #2 on: April 18, 2012, 03:07:26 PM »
Hi Jan, thanks.

I found out what the problem was. This is the first time I ever used a video editor. It turns out that under "Format" I choose "AVI" and I saved the video to "VLC" format. When I changed the Format to mp4 and saved it as ".mp4" the audio went in sync. Fixed.  :)

Do you know if there's an option available to format it in VLC?

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 6060
Re: Audio too fast when saved...
« Reply #3 on: April 18, 2012, 04:04:00 PM »
Glad it works in mp4.
Sorry you got me all confused now? VLC for me is a media player found here: http://www.videolan.org/vlc/. Are you not referring to FLV (Flash Video)? And sorry no experience with flv.

Theother12345

  • Newbie
  • *
  • Posts: 4
Re: Audio too fast when saved...
« Reply #4 on: April 20, 2012, 11:45:04 AM »
Yup, I think I meant FLV (sorry, I'm not that tech-savvy). I was referring to the one that plays through that media player with the orange and white cone logo.

Odd thing is, though, when I choose "FLV" format and save ".flv" (and even in AVI), the video is still out of sync. Do you by any chance experience this too?



« Last Edit: April 20, 2012, 01:49:18 PM by Theother12345 »

styrol

  • Hero Member
  • *****
  • Posts: 533
Re: Audio too fast when saved...
« Reply #5 on: April 20, 2012, 01:08:38 PM »
Quote
please give more details: Info on video you want to split: container: avi, mp4, ... used codecs for video and audio.
There is still all relevant info missing. Press the i button to get info on your source video.

To create FLV Video, you have to be compliant to standards and have to select:
container format: FLV
video codec: FLV1 (VP6 in copy mode is also possible)
audio codec: MP3

Today there is nearly no reason to use FLV format since FlashPlayer also supports MP4.

Theother12345

  • Newbie
  • *
  • Posts: 4
Re: Audio too fast when saved...
« Reply #6 on: April 20, 2012, 01:46:53 PM »
Quote
please give more details: Info on video you want to split: container: avi, mp4, ... used codecs for video and audio.
There is still all relevant info missing. Press the i button to get info on your source video.

To create FLV Video, you have to be compliant to standards and have to select:
container format: FLV
video codec: FLV1 (VP6 in copy mode is also possible)
audio codec: MP3

Today there is nearly no reason to use FLV format since FlashPlayer also supports MP4.

Here's the relevant info,



EDIT: video codec: FLV1/VP6 and audio codec: MP3, are not available options. I'll try to convert the file to mp4, and see what happens. I appreciate your help.
« Last Edit: April 20, 2012, 01:54:18 PM by Theother12345 »

styrol

  • Hero Member
  • *****
  • Posts: 533
Re: Audio too fast when saved...
« Reply #7 on: April 20, 2012, 08:02:19 PM »
Please only cut at keyframes (use >> and << button to navigate from keyframe to keyframe).

Your file is FLV (VP6/MP3), so Copy mode should work.

Container format: FLV
Video codec: Copy
Audio codec: Copy

You may try Avidemux 2.6, if you still encounter AV sync issues after cutting in copy mode (you don't have to uninstall Avidemux 2.5.x).