Author Topic: h.264 avi trimming with stuttering and out of sync audio  (Read 5923 times)

TrimminVids

  • Newbie
  • *
  • Posts: 2
h.264 avi trimming with stuttering and out of sync audio
« on: April 11, 2012, 10:25:46 AM »
Hello,

First of all, thanks for creating an overall great program and making it free. It's saved me literally hundreds of gigs of hard drive space being able to trim videos down (editing out commercials, only keeping funny clips, etc.). Recently though, a huge batch of the videos I was going through have given me trouble. When I load them into the program (AVI's) I get the standard h.264 detected and do you want to rebuild the index messages (I have the same problems regardless of a yes/yes, no/no, yes/no, no/yes response). Using keyframes, I am able to do a straight copy/copy/avi trim and save just fine. However, there are issues with the trimmed video file.

First of all, the trimmed video will only run in VLC and will open just fine again in avidemux, but will only show a black screen in any other video player (the source video works fine in all video players, and this is with codec packs installed). Secondly, about half of the time the trimmed video stutters noticeably (not bad enough that it's unwatchable, but it's not great), even though the source video is very smooth. And finally, the audio is out of sync on these trims, which I've read a lot of people have trouble with.

So, here are my questions:

Are the audio sync and video stuttering issues related or two separate problems?

Is there any way to correct this issue? If so, can I correct using the already trimmed files or do I have to go back to the source file?

I did some searching around on these forums and the 'net before coming on here, but I couldn't really find anything about the video stuttering - really only the audio sync issues. So, I apologize in advance if this is something that's been covered before but I couldn't find any info on it. Also, I'm using 2.5.6 on win7 64bit, and like I said I wasn't doing any encoding just copy video, copy audio, and avi output (same as source files).

Thanks in advance for your time.

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 6051
Re: h.264 avi trimming with stuttering and out of sync audio
« Reply #1 on: April 11, 2012, 01:35:03 PM »
Try with 2.6 experimental for h.264, perhaps another container (MP4 or MKV) would also be helpful all depending where you want to use the video's.
avidemux 2.6 windows 64-bit can be found @ http://avidemux.razorbyte.com.au/ or http://avidemux.org/nightly/win64/

TrimminVids

  • Newbie
  • *
  • Posts: 2
Re: h.264 avi trimming with stuttering and out of sync audio
« Reply #2 on: April 11, 2012, 10:40:38 PM »
Hey, thanks for the response.

Alright, so I tried out your suggestions and here's what I can tell so far:

Going back to 2.5.6, trying other containers does not solve the problem. And, using avi in 2.6 has the same problem, only slightly worse. However, using mp4 instead of avi in 2.6 produces a smooth output video, but at a noticeable loss in quality. MKV does not work, the video is distorted and unwatchable.

Ironically, using the mp4 container in 2.6 allows the videos to work in other video players, but doesn't work in VLC (my primary video player)! Funny stuff!

And it looks like I have to go back to the source videos to correct the problem (some of which I unfortunately already deleted). Trying to do a copy/copy/mp4 of the trimmed files results in an unwatchably stuttering video.

Appreciate the help so far, and any further advice would be greatly appreciated. I'd like it if I could get the video to work in mp4 without a noticeable loss in quality, and I'd especially like it if anyone had any suggestions on fixing the already trimmed files I have without having to go back to the source videos, since some of those are already gone.

Thanks again!

styrol

  • Hero Member
  • *****
  • Posts: 533
Re: h.264 avi trimming with stuttering and out of sync audio
« Reply #3 on: April 12, 2012, 01:28:58 AM »
Quote
any further advice would be greatly appreciated

You can try to remux your MP4 files using MKVToolnix (MP4-->MKV) or CLI based ffmpeg (MP4-->MP4).

Erhy

  • Newbie
  • *
  • Posts: 1
Re: h.264 avi trimming with stuttering and out of sync audio
« Reply #4 on: April 04, 2013, 09:24:13 PM »
I succeeded:

I converted
a .MOV file to MPEG4 25 fps
with MPEG Streamclip

http://www.squared5.com/svideo/mpeg-streamclip-win.html

(in Audio I set minus 1 dB)

After Avidemux doesn't stutter.

Erhy