August 12, 2020, 02:32:32 pm



Why can't I save 3gp files after editing them?

Started by Graham, September 15, 2012, 01:53:05 am

Previous topic - Next topic


Hello.  Thank you all for donating your time and expertise to this project and for helping people on this forum.

The thing I am trying to do seems to me to be very simple, but I can't get Avidemux to do it, and despite trawling though the posts in this forum and reading the wiki, I have been unable to find out where I am going wrong.  I'd be grateful for some assistance.

I have a number of short video clips that I have taken on my Nokia mobile phone.  The files have a ".3gp" extension, and are not recognised by the versions of Media Player and Movie Editor that were supplied with this seven-year-old PC.  They do however play in VLC Media Player and Media Player Classic, without any problems.

I would like to edit some of these files, to remove a few seconds from the beginning and/or the end.

I recognise the benefits of open source software, and Avidemux has been very well reviewed on the web, so although I am not very technically-minded, I thought I would try it.

I have version 2.5.6 of Avidemux, running on Windows XP.

I can load a file and perform the necessary edits quite easily (Avidemux is admirably straightforward to use in this respect), but I can't save the resulting edited file.

What I am doing is this, and perhaps somebody could tell me where I'm going wrong:

Having completed the edits without touching any of the settings (video and audio settings are both left at "copy" - fiddling with these doesn't seem to help), I select File > Save > Save Video... , then browse to the location where I want to save the file.  I then type the file name into the "file name" box, for example "editedvid.3gp" [oddly the file name box always comes up empty - all other applications I have ever used would have put a suggested file name in there, complete with the appropriate file suffix].  Then I click on "Save", and a message appears saying "You may need smart copy. Enable it?"  I click on "Yes"  (I've tried both yes and no, but it makes no difference to what follows).  A box comes up asking for a "Q factor", which I set to the default of 4 (again, I've tried different settings but it doesn't seem to make any difference).  Then a box flashes up and disappears too quickly to read, and a message says "Done. File editedvid.3gp has been successfully saved".  This seems good, but when I try to open and view the edited file in either VLC media player or Media Player Classic, I get an error message and the player either displays a single frozen frame from the video, or a distorted and unrecognisable moving image, or nothing at all.  The file evidently hasn't been "successfully saved" after all.

With VLC media player, the error message is always

No suitable decoder module:  VLC does not support the audio or video format "undf". Unfortunately there is no way for you to fix this.

Media Player Classic's error message is

Media Player Classic - Home Cinema could not render some of the pins in the graph, you may not have the needed codecs or filters installed on the system.  The following pin(s) failed to find a connectable filter:  MPC AVI Source::Audio 1

And then underneath, in a box it says:

MPC AVI Source::Audio 1

Media Type 0:
Audio: 0x0038 8000Hz mono 12kbps

majortype: MEDIATYPE_Audio {73647561-0000-0010-8000-00AA00389B71}
subtype: Unknown GUID Name {00000038-0000-0010-8000-00AA00389B71}
formattype: FORMAT_WaveFormatEx {05589F81-C356-11CE-BF01-00AA0055595A}
bFixedSizeSamples: 1
bTemporalCompression: 0
lSampleSize: 12000
cbFormat: 18

wFormatTag: 0x0038
nChannels: 1
nSamplesPerSec: 8000
nAvgBytesPerSec: 1500
nBlockAlign: 1
wBitsPerSample: 16
cbSize: 0 (extra bytes)

0000: 38 00 01 00 40 1f 00 00 dc 05 00 00 01 00 10 00 8...@...ÃÅ".......
0010: 00 00                                           ..

As I said, I'm afraid I'm not very technically minded, so none of that means anything to me.  I've copied it all here, however, in the hope that somebody reading this will understand what it is on about and will be able to tell me in simple language what I should have done differently to produce a playable edited file.

Many thanks



3gp file format is based on mp4. So just use these settings:

Video: Copy
Audio: Copy
Container format: MP4 (not AVI)

File name: my video.mp4


Thank you for the reply.

I tried what you suggest but regrettably it doesn't work.  With Video and Audio each set to "Copy", and Format set to "MP4" *, this error message comes up when I attempt to save:

Invaid audio stream detected.  The audio stream may be invalid for this container.  Continue anyway?

If I click on "yes" then a second error message appears:

Failed.  File video0001.mp4 was NOT saved correctly.

...and no file is saved.  This is even worse than before - at least then it was saving something!

Any more suggestions?



[*Literally-minded and possibly idiotic footnote:
I am assuming (maybe wrongly) that when you wrote "Container format: MP4 (not AVI)" you meant that in the "Format" box I should select an MP4 setting rather than an AVI setting.  If what you actually meant was that I should select the option "MP4 (not AVI)", then there is a problem as there is is no "MP4 (not AVI)" option in the drop down list in my version.  I just have "MP4" and "MP4 (PSP)", either of which produces the errors mentioned above.]



Video: Copy
Audio: AAC
Configure: Bitrate: 64kbps (optional step to reduce file size)
Filters: Mixer: Stereo; Resampling (Hz): 44100 (both optional step to accomplish most widely used settings)
Format (yes it's the format of the container): MP4
File name: my video.mp4


That works perfectly.  Yippee!

Thank you for providing the solution, and for expressing it so clearly.

As an aside, are any of the volunteer developers working on a system that would automatically select sensible settings to be the defaults?  If not, then perhaps somebody could suggest it.  Such a system would be really helpful for beginners like me, and would mean that experts like you wouldn't be pestered with tiresome questions like mine on this forum!

Thanks again.