How to get rid of "Malformed Header" warning when using command line

Started by JG Media, September 28, 2012, 02:38:38 pm

Previous topic - Next topic

JG Media

I'm running a conversion through Windows XP command line and I'm using a video file that I know has a bad avi header. The source is from Q-See cameras and their web-interface to record locally. I can't do anything about this since Q-See is the sloppiest/buggiest outfit I've ever come across when it comes to their native/propriety software. Nonetheless, my customer uses them and I have to work with what i have.

I am writing a script to record locally from the web-interface, convert the file to mp4 and then upload it to web automatically. Since this will all take place in command line, I was over-joyed that Avidemux could convert the files that I generate with the crappy Q-See interface that creates defective avi files. The only problem is that though all error messages and warning screens are supposed to be suppressed when using command line, I still get the error message, "Malformed Header", to which i have to click "OK" to make it go away and let the conversion take place.

Is there any way to suppress this warning as well?



Jan Gruuthuse

if using the GUI:
QuoteYou can use ââ,¬â€œnogui option in case you want to suppress all dialogs (it must be first option!)

if using cli,
would it not help if you redirect an ascii (alt 013) from a text file?
< enter.txt

mean

Also, If you have sample of such file, i could see if the warning is real or if it is a false alarm / too picky

JG Media

-nogui didn't change anything. the exact same thing (as pictured in the original screenshot) happened.

and yes the header is malformed! Q-See makes some crappy software to run their equipment.

thanks for the help so far. i hope this thing can get sorted out...

mean


JG Media

is that a linux package or is there also a version of that for windows xp?

Jan Gruuthuse

you should have the cli on both, for windows that should be avidemux_cli.exe

JG Media

I was happy to find the avidemux_cli.exe file. when i ran it however i did not like the result (see screenshot below):


where can i get libxml2-2.dll and where should i copy it to? t Re-installed the program three times and it didn't just show up.


JG Media

THANK YOU EVERYONE!!!

It worked! I downloaded and installed the latest version of 2.5 and copied libxml2-2.dll into the 2.6 folder and it worked perfectly when i called avidemux_cli.exe from the command line with the rest of my command.

BTW - I never realized that CLI had it's own application.