October 21, 2020, 09:34:22 pm



delete audio track script

Started by drago, February 09, 2013, 12:21:50 pm

Previous topic - Next topic


February 09, 2013, 12:21:50 pm Last Edit: February 09, 2013, 12:26:39 pm by drago
Hi all
I hope you can help me.
I need to create a .bat to remove audio track from .avi files I have in a particular folder.
practice in audio and video should not be encoding, but only eliminated one of the two audio tracks, and the file saved as a copy with a different part of the name in order to recognize.

on the net I found this script, but only copy the file, not deleting the audio track.
"C:\Program Files\Avidemux 2.6\avidemux.exe"
set videocodec=Copy
set audiocodec=Copy
set output-format=AVI
for %%f in (*.avi) do %avidemux% --video-codec %videocodec% --audio-codec %audiocodec% --load "%%f" --output-format AVI --save "%%f-monoaudio.avi" --quit

I hope I was clear enough.

thanks in advance for your help.

ho visto ora che ci sono risposte in italiano...
in pratica devo eliminare l'audio inglese da alcuni file, mantenendo quello italiano.
il bat dovrebbe effettuare questa operazione cercando i file nella cartella dove è posizionate, e farne nella stessa una copia monoaudio...
in italiano è piu semplice da spiegare!!!!!

grazie a tutti per l'aiuto!!!! ;D ;D ;D ;D ;D ;D ;D ;D ;D

Jan Gruuthuse

If video loads in 2.6.1 and all videos would have the to delete audio track 0/1 @ the same position you could use this method with small adaptation.
Load video, use from Menu: Audio: Select Track: Unmark the track you want to lose. press [OK].
Now from Menu: File: Tinypy Project: Save As Project: and provide name that makes sense to you: DeleteAudioTrack1. Take note where you save it. You need to edit it.
The rest can be found here: 2.6 audio track switching in job.py


thanks man... but i made a mistake..
the script i posted is for avidemux 2.5.6, and to do what i have to do this version is ok.
and the script works!
but is not fully automatic... i have to click on "ok" when avidemux tell me that i have to choose the principal language...

there is a method to delete this annunce, or to automatize the process?



have to disable the message in the preference (first tab).