Author Topic: Choppy playback in XBMC  (Read 6837 times)

aerosoul

  • Newbie
  • *
  • Posts: 4
Choppy playback in XBMC
« on: March 01, 2013, 09:07:59 AM »
Hi everyone,

I record IPTV streams with VLC. I like to save the streams as close to the original as possible, keeping things such as audio tracks, subtitles, intact. No transcoding or anything, just dump the stream to a file. I use "vlc.exe rtp://@x.x.x.x:yyyy :demux=dump :demuxdump-file=dump.ts". This results in files that play perfectly in my HTPC running XBMC Live as well as in VLC on my PC. So far so good.

Now, I followed this guide to cut off the stuff before and after the show, as well as the commercial breaks with Avidemux. The edited .TS files that come out of Avidemux play fine in VLC on my PC, but they play jerky in XBMC on my HTPC; dropped frames everywhere. When I play original, unaltered dumps, they plays flawlessly both in XBMC and VLC; smooth as butter, zero dropped frames. It's only the files I save from Avidemux that play choppy in XBMC.

I have also noticed something interesting: on XBMC, when I press O to bring up the video diagnostic info, the framerate on the original file is always at exactly 50 fps, it never moves from there. The framerate on the Avidemux file on the other hand, never stops jumping, going anywhere between 42 fps and 52 fps and would occasionally dip below 30 fps.

The problem occurs with every file I save in Avidemux, and it happens even if I don't cut anything off; opening a dump file and simply saving it "as is" results in choppy playback on XBMC.

Does anybody have a clue on what could be causing this? I have uploaded two samples; original.ts is the dump straight as it came out of VLC; avidemux.ts is the file saved from Avidemux that shows the problem in XBMC (I didn't cut anything off.)

https://www.dropbox.com/sh/m59z5pb0q8fn5k0/DF00nKC4A6

Thanks.
« Last Edit: March 01, 2013, 09:21:15 AM by aerosoul »

mean

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 10966
Re: Choppy playback in XBMC
« Reply #1 on: March 01, 2013, 01:19:16 PM »
which version of avidemux ?

aerosoul

  • Newbie
  • *
  • Posts: 4
Re: Choppy playback in XBMC
« Reply #2 on: March 01, 2013, 03:12:05 PM »
Sorry I left that out. Currently I'm using 2.6.1 (64 bit). I have also tried rev. 8494 beta with the same result.

I also tried to test 2.5.6-1 (7716) but for some reason it kept crashing, so I don't know for sure.
« Last Edit: March 01, 2013, 03:17:12 PM by aerosoul »

mean

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 10966
Re: Choppy playback in XBMC
« Reply #3 on: March 01, 2013, 03:13:01 PM »
If you save as mkv for example, do you have the same problem ?

aerosoul

  • Newbie
  • *
  • Posts: 4
Re: Choppy playback in XBMC
« Reply #4 on: March 01, 2013, 08:39:44 PM »
OK, I tried saving the sample in .mkv format.

On my PC it plays, but the aspect ratio is off. You will notice the streams I uploaded are 1440x1080, but somehow they are meant to be stretched to 1920x1080, which is what both VLC and XBMC do automatically and they look great. That's the case with .ts files at least.

With the .mkv file, VLC doesn't do this stretching, so everything ends up distorted (stretched vertically.) XBMC couldn't even play it. It plays the audio, but no video came up, and it even up crashing half way through.
« Last Edit: March 02, 2013, 05:59:30 AM by aerosoul »

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 6060
Re: Choppy playback in XBMC
« Reply #5 on: March 02, 2013, 03:11:07 PM »
Check for updates on XBMC (player, codecs, ... ) and see if problem persists?

aerosoul

  • Newbie
  • *
  • Posts: 4
Re: Choppy playback in XBMC
« Reply #6 on: March 04, 2013, 04:04:01 PM »
Jan Gruuthuse,

I haven't got around updating XBMC yet, as I have to backup everything first, but I will. Still, I'd like to be able to play the files in my current version (remember the unedited files play perfectly). I might have friends or relatives to whom I would like to give copies of my files too,  and I really wouldn't want having to force everybody to upgrade their setup just to play my files.

mean

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 10966
Re: Choppy playback in XBMC
« Reply #7 on: March 04, 2013, 04:54:50 PM »
I dont do much Ts->ts, only ts->mkv to have fast seeking, and it plays fine with xbmc