Author Topic: Copy with audio shift causes loss of audio in output  (Read 8164 times)

itm

  • Newbie
  • *
  • Posts: 6
Copy with audio shift causes loss of audio in output
« on: April 03, 2013, 05:38:16 PM »
I have used Avidemux v2.6.3 to edit some MPEG video from a Humax Foxsat HDR. The audio in the output file was slightly out of sync, so I set the audio shift option to 300ms and saved the file again. It saved OK but the resulting file has no audio track.
Can anyone suggest a way to fix this?

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 6060
Re: Copy with audio shift causes loss of audio in output
« Reply #1 on: April 03, 2013, 05:55:15 PM »
This should not be happening with .TS files?
Check main menu -> Audio -> Select Track -> Audio Tracks Configuration.
Also check from main menu -> Edit -> Preferences -> [Audio] -> AudioDevice
If this set to Dummy change to Win32 or similar. (reported by user Ray)
If the issue persists, make a 5 second recording and upload to Rapidshare.com (public viewable and down loadable folder) or similar web service  and provide a download link to it.
« Last Edit: April 03, 2013, 06:01:10 PM by Jan Gruuthuse »

itm

  • Newbie
  • *
  • Posts: 6
Re: Copy with audio shift causes loss of audio in output
« Reply #2 on: April 03, 2013, 06:53:35 PM »
Audio Tracks Configuration looked OK - Track 1 and 2 were enabled, in copy mode.
The AudioDevice was set to Dummy, so I changed it to Win32 and tried the copy again - still no audio.
I've uploaded a 6-minute sample of the output file to here:
http://www.friendhouseswap.com/sample.zip

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 6060
Re: Copy with audio shift causes loss of audio in output
« Reply #3 on: April 04, 2013, 09:18:41 AM »
Upload 5 seconds source video. Nothing much with the output we can do? Extracting audio with audacity:
stereo track mp2 bitrate 1, 2 channels duration 402 nothing here
mono track mp2 bitrate 6, 1 channels duration 402 flat line (silence)

itm

  • Newbie
  • *
  • Posts: 6
Re: Copy with audio shift causes loss of audio in output
« Reply #4 on: April 04, 2013, 06:18:00 PM »
OK I've uploaded a 5 second sample from the source:
http://www.friendhouseswap.com/5secs.avi

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 6060
Re: Copy with audio shift causes loss of audio in output
« Reply #5 on: April 05, 2013, 10:22:17 AM »
Does the Humax Foxsat HDR only record in avi? Recording should be in mpeg-ts format and not in .avi container. What choice do you have for recording format on this receiver? Tried several things and none are working.

itm

  • Newbie
  • *
  • Posts: 6
Re: Copy with audio shift causes loss of audio in output
« Reply #6 on: April 05, 2013, 12:02:39 PM »
The original recording was a .ts file - I appended a few files of these files together (all from the Humax) and edited out sections before saving it to the file that I sent you a sample of (all using Avidemux). I don't think there's a choice of formats on the Foxsat HDR

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 6060
Re: Copy with audio shift causes loss of audio in output
« Reply #7 on: April 05, 2013, 03:13:44 PM »
workflow:
.ts file editing/cutting ... stay in .ts format
edited .ts file to wanted end format.
.avi is not a good choice to end up from .ts without re-encoding.

itm

  • Newbie
  • *
  • Posts: 6
Re: Copy with audio shift causes loss of audio in output
« Reply #8 on: April 05, 2013, 03:22:33 PM »
After editing/cutting I selected the "copy" option to produce the output, with AVI muxer selected as the output format. Which output format should I have selected to preserve the .ts format?

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 6060
Re: Copy with audio shift causes loss of audio in output
« Reply #9 on: April 05, 2013, 03:27:17 PM »
Output Format: Mpeg TS Muxer (ff)

itm

  • Newbie
  • *
  • Posts: 6
Re: Copy with audio shift causes loss of audio in output
« Reply #10 on: April 07, 2013, 05:46:38 PM »
I've decided to start from scratch with this edit, but have hit a different problem. I am basically stitching together two .ts clips from the Humax (the first 5Gb, the 2nd about 700Mb). When I Save after editing (using the Mpeg TS muxer ff option)  I get a warning message saying that the video is in copy mode but the cut points are not on keyframes. It then processes the file but terminates with this message:
"Too short - the video has been saved but seems to be incomplete". This is correct, as approx. 30 mins is missing from the output file.

I'm running this on a Windows 7 x64 machine with 16Gb RAM (of which 55% is free). There's no shortage of disk space on the target drive, and the part of the file which did save looks fine.
???

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 6060
Re: Copy with audio shift causes loss of audio in output
« Reply #11 on: April 08, 2013, 09:34:13 AM »
Editing .TS
Load 1st part, if you got asked to load additional parts by avidemux: detecting sequential files: reply no.
Load additional parts: for every part use keyboard shortcut [Ctrl][A] and load following part.
Trim begin: goto approx. where video should start with navigation slider.
Select exact cutting point only with these 2: / or with keyboard up/down arrow keys only.
Mark this with marker
Now with keyboard shortcut [Ctrl][X]. The block leading up to video start should be cut now.

Trim in middle:
Now search for start of video block to remove with navigation slider.
Again select exact cutting point only with these 2: / or with keyboard up/down arrow keys only.
Mark this with marker
Now search for end of video block to remove with navigation slider.
Again select exact cutting point only with these 2: / or with keyboard up/down arrow keys only.
Mark this with marker
Now with keyboard shortcut [Ctrl][X]. The previously video block should be cut now.
Repeat as many times as required the procedure for middle trim.

For saving the final video you now have 2 options:
 1] If you intend to add @video end in future:
 Go with navigation slider to beginning of the complete video. Press a few times and mark with .
 Go with navigation slider to Ending of the complete video and select with / or with keyboard up/down arrow keys only the exact end point.
Mark this with marker

 2] you don't intend to add @video end in future:
 Go with navigation slider to Begin of the complete video. Press a few times and mark with .
 Go with navigation slider to End of the complete video and select with , , / or with keyboard arrow keys the exact end point.
 Mark this with marker


Save video with 1st from the left: