December 02, 2020, 09:33:03 am

News:

--


Audio codec missing?

Started by yami, May 02, 2013, 07:16:06 pm

Previous topic - Next topic

yami

May 02, 2013, 07:16:06 pm Last Edit: May 03, 2013, 07:07:14 am by yami
I dont know, if I have overseen anything, it would be nice if someone could answer me.
Mac OS X.8.2, 2.5 GHz i5, 8GB RAM, Macbook Pro, Avidemux 2.6.3
Somehow, by not using it for a while, Avidemux doesn't crash anymore, when I try encoding an mpeg2 stream, the Video comes out nice. Not so with the Audio track. It doesn't matter if I set it on AAC or Dummy, no Audio is saved. I can't set filters or anything (with AAC) in the Audio section and the progress window says about the Audio: No Codec
I checked in the preferences, but I dont find anything about codecs there. Do I have to specifically select the Audio trac in the menu?
But I don't need to do that for a simple mp4 reencode... When I cut an ordinary mp4 (h264/AAC) it plays the sound (I did set AudioCore in the prefs) and the cut and saved reencode has the Audio nicely synced, cut and reencoded together with the video track.
Why does it have a codec when reencoding an mp4, but not with an mpeg (the mpeg has an audio track) even though I want to use the same Audio codec for the encodes?

Is there anyone out there with a similar experience, a tip for a setting I did not find that I should change?
Edit:
Well, I added in the Audio track via the menu, trimmed, added the filters and started the encode again. First try Avidemux instantly crashed, started again, now it is sort of running with a whopping 360% CPU usage. I won't check the progress or touch Avidemux while the encode is running, else it might crash again...

A side thought: Could it be that the crashes are related to the fact, that Avidemux uses the CPU right from the start of an encode at it's limits? There does not even seem any spare ressources for bringing Avidemux to the foreground to check the progress window (which is, where it crashes most of the time, if it crashes).

mean

No codec could mean copy
What says mediainfo about your mpeg file ?
When you click info in avidemux do you see infos about the audio track?

styrol

Quote from: yami on May 02, 2013, 07:16:06 pm
When I cut an ordinary mp4 (h264/AAC) it plays the sound (I did set AudioCore in the prefs) e foreground to check the progress window

The audio device selection in the Prefs has nothing to do with the encoding.
What output format did you select? MPEG-PS Muxer? What video and audio codec? I wouldn't put AAC audio in MPEG-PS.

yami

May 03, 2013, 08:33:46 am #3 Last Edit: May 03, 2013, 10:29:42 am by yami
Encode is finished, but the audio I set turned out to be a mess. I don't have MediaInfo, I'll give you two screenshots, one during the encode, one of the properties of the file.
MPegStreamclip says:
Typ: MPEG transport stream
Duration: 0:30:15
Data: 2.99 GB
Bit Rate: 14.14 Mbps
Video tracks:
256 MPEG-2, 1440 Ãâ€" 1080, 16:9, 29.97 fps, 24.00 Mbps, upper half frame first
Audio tracks:
272 MP3 stereo, 44.1 kHz, 112 kbps
MP3 Audio not supported

I attached a textfile with the output of VideoSpecs


and

What the heck does it make out of the 'total duration' of the audio? I mean... how can that work, if it thinks, the audio takes... weeks? The ts is playing fine in VLC... Does Avidemux misinterpret the primary audio data?

Jan Gruuthuse

May 03, 2013, 10:38:55 am #4 Last Edit: May 03, 2013, 10:56:59 am by Jan Gruuthuse
what are you exactly doing in the audio?
source ac3 stereo and you go to ac3 4.1 or 5.0? don't re-encode audio use copy. See what it gives? Or use mkv container lesser strict format.
MediaInfo Mac download's

yami

Well, when I 'didn't do' anything with the audio (I did set to copy - though in that try I didnt specifically chose the audio track from the menu, so that's the next try...) Avidemux didn't do anything at all about the audio, it was not saved at all... I'll have to finish clipping a raw first, then I'll give it a try with selecting the audio track, but saving it as 'copy'. I'll try the mkv as format too.

It's just confusing, because when clipping an mp4 into shape, I don't have to specifically select the audio track. I just set the options on the left hand side of the main window and it works.

Jan Gruuthuse

Don't use Audio at left hand. Go to main menu (Textual): Audio: Select Audio Track: and make choices there what to use or not.

yami

May 03, 2013, 11:06:38 am #7 Last Edit: May 03, 2013, 02:42:11 pm by yami
Ah, OK :-) - I'll give it a try! Thanks :-)

Edit: So far, it looks much better (it uses AC3 for Audio, applies the Quantisizer and saves something in Audio). It'll take appr. 2 hours though until it's through.

Edit: No, it still minces the audio...
The point is, that Avidemux really seems to mis-interpret the kbps of the audio track. I attach the VideoSpec file for the resulting mkv

mean

Can you provide a short sample of the *original* video ?
If it is mpeg Ts, you can just cut a few megabytes with dd and upload it to rapidshare/mega/...

yami

May 03, 2013, 04:02:41 pm #9 Last Edit: May 03, 2013, 04:56:59 pm by yami
Ummm... dd?

Edit: found what you mean, I'll try that out.

https://mega.co.nz/#!6lRhkRLD!NGPI6ErSvJT4456FkYBYygav_X9aQQjWiEHxHtRB-IY

...the japanese sand-eels are cute, aren't they? XD - Well, the sample only consists some bits of the ads that will get clipped off, despite those cute little fishies.

mean

Ok, i can reproduce the problem
The audio track is not detected, looking why

mean

That video has pretty unusual audio track
Found 3 problems, fixed 2, looking into the 3rd

yami

Cool! - I've got some more streams from that box. Tbh, Avidemux gives out all sorts of interpretations about the audio from these streams. If you want, I can make a sample of another one too, if that helps.

mean

Almost ok, still one issue to fix and it s done

mean