Author Topic: Cannot load TS-file with HD video  (Read 4932 times)

xyzuvw

  • Newbie
  • *
  • Posts: 23
Cannot load TS-file with HD video
« on: July 14, 2013, 09:56:27 AM »
I try to load a TS-record of HD TV:
Video: Video - AVC (H.264), Main Profile, Level 4.0, 1920x1080, 25.000 fps
Audio: MPEG1 - Layer 2, 48.0 kHz, 2 chn, 192.0 kbit/s

Avidemux 2.6.4 write: "Cannot find a demuxer for filename.ts"
Is it normal or bug?
« Last Edit: July 14, 2013, 10:00:01 AM by xyzuvw »

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 6060
Re: Cannot load TS-file with HD video
« Reply #1 on: July 14, 2013, 11:30:18 AM »
You are using the latest avidemux 2.6.4? found here: http://avidemux.org/nightly/
Most likely this is a problem with the concerned mpeg-ts file. Is this only happening with this file or with several? If several: you're recording yourself the streams? What is it's origin: dvb-(c/c2/s/s2/t/t2), iptv, ....
Please provide a (5 second duration/ 20 MB size  recording) of the type that is causing this issue.
On daily basis I'm processing these mpeg-ts (SD/HD tv) streams. Om some occasions this goes wrong. Especially when something goes wrong in the stream: bad reception, smart card decoding, wrong info, ...
Upload the video (5 seconds/20 MB) to mega, rapidshare or similar web service and provide a publicly available down link to it (without a required registration to it)

xyzuvw

  • Newbie
  • *
  • Posts: 23
Re: Cannot load TS-file with HD video
« Reply #2 on: July 14, 2013, 01:51:41 PM »
I record IP-TV by program IP-TV Player. The problem with HD channel only (with any files from this channel). Nightly version don't open these files also, but Windows Media Player show video successfully.
Strange, but TS-video from the same channel, which I recorded by a hardware mediaplayer, Avidemux open normally. Possibly IP-TV Player writes incorrectly.

Here both videos (from software and hardware players)
https://docs.google.com/file/d/0Bw-31bgZZTNsdHdHZkRwa2FJTk0
« Last Edit: July 14, 2013, 02:39:32 PM by xyzuvw »

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 6060
Re: Cannot load TS-file with HD video
« Reply #3 on: July 14, 2013, 02:56:19 PM »
With software recorded video with with vlc audio starts 1st and after some time the video.
Avidemux: the hardware recording is flawless, software recording is not loading. Index is not created.
MediaInfo tells both are similar for used audio and video codec.
Check if you can update your recording software or apply other settings.
Perhaps the developer can make more sense of it.

mean

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 10971
Re: Cannot load TS-file with HD video
« Reply #4 on: July 14, 2013, 05:59:22 PM »
I lowered the detection threshold as a workaround, it is  a bug in the PMT parsing
Try with tomorrow nightly, should be okay

xyzuvw

  • Newbie
  • *
  • Posts: 23
Re: Cannot load TS-file with HD video
« Reply #5 on: July 15, 2013, 01:57:31 AM »
Thanks

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 6060
Re: Cannot load TS-file with HD video
« Reply #6 on: July 15, 2013, 03:07:55 AM »
works now for software recorded to.

xyzuvw

  • Newbie
  • *
  • Posts: 23
Re: Cannot load TS-file with HD video
« Reply #7 on: January 18, 2014, 11:12:26 AM »
Unfortunately, the situation repeats again. Avidemux 2.6.7 (32-bit release) doesn't load HD video. Here one of short examples.
Recorded with IpTvPlayer.

https://drive.google.com/file/d/0Bw-31bgZZTNsbFNveG5lc0Q2eVk/edit?usp=sharing

mean

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 10971
Re: Cannot load TS-file with HD video
« Reply #8 on: January 18, 2014, 03:02:24 PM »
If i lower more the threshold there will be false positive
Quick & dirty workaround

ffmpeg -i yourintputfile.ts youroutputfile.ts

and then open youroutputfile.ts
That processing is very very fast