August 13, 2020, 12:37:04 am

News:

--


Joining M2TS files from different sources

Started by TCmullet, December 04, 2013, 07:33:06 pm

Previous topic - Next topic

TCmullet

I'm making my first serious attempt to create an X264 file (m2ts) to join to a file captured by the Hauppauge Colossus.  All is 1920x1080i.  I discovered that my Virtualdub can encode X264 in an AVI.  Then I remux with AviDemux to .M2TS.

When I then use AviDemux 2.6.5 (r8897) to join them (with the soft-encoded piece first), it appears to join.  But then I load the result into AviDemux and the indexing stops at the end of the soft-encoded piece.

Without being an X264 encoder expert (I've largely left most settings at default), is there a list somewhere of x264/h264 encoding parameters that have to be the same for AviDemux to recognize them as compatible for purposes of joining them (appending them)?

I really need to be able to create H264 M2TS files that I can join with files directly encoded by the Colossus.
I've done the obvious things like pixel ratio, audio format parameters.

mean

i would check if the pid used are the same
i.e video ix 0x150 for the 1st one and 0x151 for the 2nd
Mediainfo will tell you

TCmullet

December 04, 2013, 10:24:12 pm #2 Last Edit: December 05, 2013, 12:25:15 am by TCmullet
Quote from: mean on December 04, 2013, 08:21:05 pm
i would check if the pid used are the same
i.e video ix 0x150 for the 1st one and 0x151 for the 2nd
Mediainfo will tell you

Under Video, I see:
ID: 256 (0x100)
in both of them.

I don't why they should be different, especially as all the clips I normally join are all from the Colossus and have the same values anyway, not different ones.  Can you please clarify what you mean in light of what I'm reporting here?