Author Topic: 1st audio track silent when playing on TV until switching tracks back and forth  (Read 2142 times)

douche

  • Full Member
  • ***
  • Posts: 100
Hi,

when cutting HD .ts files, in some cases the resulting mp4 does not play the first audiotrack when watched on the TV. I have to switch to the 2nd and back so I can hear track 1 (but no problem when playing in VLC).

Do you have any idea why this happens?
What can I do to find the reason of this behavior ?

more details:
Video/Audio Output: Copy, I am just deselecting some unnecessary Tracks in the Audio Tracks Configuration
Output Format: mp4v2 (just because it seems to produce the smallest files of all output formats)

Audio Tracks Configuration of original ts video:
Track 1 enabled - Track 0 from video (MP2, Stereo, 256kbps) - copy
Track 2 disabled - (Track 1 from video (MP2, Stereo, 192kbps) - copy)
Track 3 disabled - (Track 2 from video (MP2, Stereo, 192kbps) - copy)
Track 4 enabled - Track 3 from video (AC3, Stereo, 448kbps) - copy

Audio Tracks Configuration when loading the resulting output mp4v2 video:
Track 1 enabled - Track 0 from video (MP2, Stereo, 128kbps)
Track 2 enabled - Track 1 from video (AC3, 6chan, 448kbps)

mean

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 10971
If you have only one track, does it work ?

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 6060
you need to establish what is playing and what is not playing  (MP2, Stereo) on your TV (has less possibilities then vlc on computer)

possible something else is going on to:
Quote
Track 1 enabled - Track 0 from video (MP2, Stereo, 128kbps)
- you copy MP2, stereo 256kbps track 0, and end up with (MP2, Stereo, 128kbps) in track 0, this is odd when copy is used

Quote
Track 1 enabled - Track 0 from video (MP2, Stereo, 256kbps) - copy
Track 2 disabled - (Track 1 from video (MP2, Stereo, 192kbps) - copy)
Track 3 disabled - (Track 2 from video (MP2, Stereo, 192kbps) - copy)
Track 4 enabled - Track 3 from video (AC3, Stereo, 448kbps) - copy

should be:
Quote
Track 1 enabled - Track 0 from video (MP2, Stereo, 256kbps) - copy
Track 2 enabled - Track 3 from video (AC3, Stereo, 448kbps) - copy
Track 3 disabled
Track 4 disabled

- sometimes one of the audio tracks is for the visually impaired or other language and is not available on transmission. What would indicate you did not select the prime MP2 audio.

Is this from a satellite channel (FTA/ Europe / 28.2 23.5 19.2 @ east)? I could have a look.

If you can upload a 10 second mpeg-ts recording to a freely accessible web service (like dropbox) no login/registration. We could have a look.
« Last Edit: November 18, 2015, 07:33:18 AM by Jan Gruuthuse »

douche

  • Full Member
  • ***
  • Posts: 100
@mean
Did a cut with MP2, Stereo, 256kbps only: TV did not play any sound
  another with AC3, Stereo, 448kbps only: TV did play sound
I don't get it.
When I switch the tracks AC3 first, MP2 second and play the video on the TV, it has sound right away. If I switch to the MP2 track, it is played, too.

@Jan Gruuthuse
The TV does play the audio track - that is the irritating part:
I start the video - no sound - go to the audio track selection dialog - track 1 is selected - I switch to track 2 - I get sound - BUT: now I switch back to track 1 - I also hear sound

So it seems as if although track 1 is shown as selected when starting the video there is actually no default/active audio track in the mp4, so the MP2 track only gets activated if I actively select it.

- you copy MP2, stereo 256kbps track 0, and end up with (MP2, Stereo, 128kbps) in track 0, this is odd when copy is used
My assumption is that this is a consequence of the cutting: avidemux probably only reads the audio track properties at the beginning of the video. The program that has been recorded in the pre-record minutes might have a different audio track bitrate than the movie, so when I cut the pre-record away and open the output video in avidemux, the audio track properties of the movie are displayed which are different from those of the program that ran before.

Did a test to check this theory: if I only disable track 2 and 3 without cutting and load the output video in avidemux, the bitrates are unchanged (MP2 256kbps, AC3 448kbps).
« Last Edit: November 18, 2015, 06:29:52 PM by douche »