Author Topic: Kein x264/x265 in aktuellster Version  (Read 4897 times)

tribun77

  • Newbie
  • *
  • Posts: 10
Kein x264/x265 in aktuellster Version
« on: November 30, 2015, 11:04:35 AM »
Hi, ich habe ein frisch aufgesetztes Ubuntu 14.04.03
Habe dann das aktuellste Paket (64-bit Current 151128) von hier und genau nach Anleitung installiert. --> http://avidemux.org/smif/index.php/topic,16445.0.html
Ich habe nun aber unter "Video output" KEIN x264 und auch kein x265.
Unter "/usr/lib/ADM_plugins6/videoEncoders" sind aber die entsprechenden Dateien vorhanden. (libADM_ve_x264_other.so usw.)

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 6060
Re: Kein x264/x265 in aktuellster Version
« Reply #1 on: November 30, 2015, 04:46:20 PM »
Hast du x264 oder X265 installiert? Check vom Terminal:
Code: [Select]
x264 --version
Quote
x264 0.148.2638 7599210
built on Nov 18 2015, gcc: 4.8.4
x264 configuration: --bit-depth=8 --chroma-format=all
libx264 configuration: --bit-depth=8 --chroma-format=all
x264 license: GPL version 2 or later
Code: [Select]
x265 --version
Quote
x265 [info]: HEVC encoder version 1.5+1-32d72a0285e0
x265 [info]: build info [Linux][GCC 4.8.2][64 bit] 8bpp
x265 [info]: using cpu capabilities: MMX2 SSE2Fast SSSE3 SSE4.2 AVX
« Last Edit: December 01, 2015, 09:50:03 AM by Jan Gruuthuse »

tribun77

  • Newbie
  • *
  • Posts: 10
Re: Kein x264/x265 in aktuellster Version
« Reply #2 on: November 30, 2015, 05:15:53 PM »
Hi Jan,
erstmal DANKE!

Tatsächlich, x264 ist nicht installiert.  :o

ABER:
Ich hatte jetzt in der Zwichenzeit einfach mal die Version "avidemux3_2.6.8_64bit_r9052_14.04_LTS-Trusty" installiert, da besteht das Problem nicht.  ::)

tribun77

  • Newbie
  • *
  • Posts: 10
Re: Kein x264/x265 in aktuellster Version
« Reply #3 on: December 01, 2015, 05:58:31 AM »
Ich bin es nochmal.
Habe die Version "avidemux3_2.6.8_64bit_r9052_14.04_LTS-Trusty" wieder deinstalliert.
Dann x264 installiert:
Quote
x264 0.142.2389 956c8d8
built on Mar 23 2014, gcc: 4.8.2
configuration: --bit-depth=8 --chroma-format=all
x264 license: GPL version 2 or later

Dann wieder die Version "avidemux3_2.6.10-151128-64bit_14.04_LTS-Trusty-x265-1-5" installiert.
Habe aber wieder das gleiche Problem. Es ist wieder KEIN x264 zur Auswahl.  :-[

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 6060
Re: Kein x264/x265 in aktuellster Version
« Reply #4 on: December 01, 2015, 09:46:49 AM »

tribun77

  • Newbie
  • *
  • Posts: 10
Re: Kein x264/x265 in aktuellster Version
« Reply #5 on: December 01, 2015, 09:58:05 AM »
Nochmals Danke, und was soll ich jetzt mit der Datei tun?

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 6060
Re: Kein x264/x265 in aktuellster Version
« Reply #6 on: December 01, 2015, 12:33:10 PM »
- rechte Maustaste klick auf die datei (ist ein ausführbares)
- wählen Sie Eigenschaften
- wählen Sie Tab Berechtigungen
- ausführen [v] ermöglichen Datei als Programm ausführen
- Fenster schließen
- Start x264-10b-r2638-7599210 (Doppelklick)

hoffe, das x264 0.148.2638 7599210 installiert wird

tribun77

  • Newbie
  • *
  • Posts: 10
Re: Kein x264/x265 in aktuellster Version
« Reply #7 on: December 01, 2015, 12:38:21 PM »
Hab es probiert. Es passiert dann garnichts wenn ich die Datei ausführen will. :(

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 6060
Re: Kein x264/x265 in aktuellster Version
« Reply #8 on: December 01, 2015, 12:48:27 PM »
x264:
=====
Get x264:
-----------
Code: [Select]
cd ~ && git clone git://git.videolan.org/x264.git
Update x264:
------------
Code: [Select]
cd ~/x264 && git pull
Build x264:
-----------
Code: [Select]
cd ~/x264
./configure  --prefix="/usr" --bindir="/usr/local/bin" --libdir="/usr/lib/x86_64-linux-gnu/" --enable-static --enable-shared --enable-pic
make
sudo make install

Quote
install -d /usr/local/bin
install x264 /usr/local/bin
install -d /usr/include
install -d /usr/lib/x86_64-linux-gnu/
install -d /usr/lib/x86_64-linux-gnu//pkgconfig
install -m 644 ./x264.h /usr/include
install -m 644 x264_config.h /usr/include
install -m 644 x264.pc /usr/lib/x86_64-linux-gnu//pkgconfig
ln -f -s libx264.so.148 /usr/lib/x86_64-linux-gnu//libx264.so
install -m 755 libx264.so.148 /usr/lib/x86_64-linux-gnu/
install -m 644 libx264.a /usr/lib/x86_64-linux-gnu/
ranlib /usr/lib/x86_64-linux-gnu//libx264.a



tribun77

  • Newbie
  • *
  • Posts: 10
Re: Kein x264/x265 in aktuellster Version
« Reply #9 on: December 01, 2015, 04:19:14 PM »
Es hat geklappt!

VIELEN VIELEN DANK!!  ;D

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 6060
Re: Kein x264/x265 in aktuellster Version
« Reply #10 on: December 02, 2015, 07:44:08 AM »
Wunderbar  ;)
Wenn Sie x265 brauchen:

x265:
====
Ubuntu Prerequisites (Voraussetzungen:)
Code: [Select]
sudo apt-get install mercurial cmake cmake-curses-gui build-essential yasm
get x265:
-----------
Code: [Select]
cd ~ && hg clone http://hg.videolan.org/x265
update x265:
--------------
Code: [Select]
cd ~/x265 && hg update stable
build x265:
------------------
Code: [Select]
cd ~/x265/build
cmake ../source
make
sudo make install

Quote
Install the project...
-- Install configuration: "Release"
-- Up-to-date: /usr/local/lib/libx265.a
-- Up-to-date: /usr/local/include/x265.h
-- Up-to-date: /usr/local/include/x265_config.h
-- Up-to-date: /usr/local/lib/libx265.so.43
-- Up-to-date: /usr/local/lib/libx265.so
-- Up-to-date: /usr/local/lib/pkgconfig/x265.pc
-- Up-to-date: /usr/local/bin/x265

source: http://www.videolan.org/developers/x265.html
« Last Edit: December 02, 2015, 08:05:41 AM by Jan Gruuthuse »

tribun77

  • Newbie
  • *
  • Posts: 10
Re: Kein x264/x265 in aktuellster Version
« Reply #11 on: December 04, 2015, 03:58:58 AM »
Das werde ich heute oder morgen auch noch probieren. :) DANKE! :) :)