Author Topic: [BUG] Windows GUI Custom Scripts Menu  (Read 1352 times)

xpmule

  • Newbie
  • *
  • Posts: 33
[BUG] Windows GUI Custom Scripts Menu
« on: March 17, 2016, 06:22:25 PM »
Ok so i had some files in the "Custom" folder all ending with *.admjs (4 of them total)
These were some random scripts i made for Avidemux i had not used in a couple years now.
So they would be visible when running on Windows showing a drop down menu under "Custom"
Here is the weird part i wanted to report..
I wanted to setup a quick config for a pile of video i am converting (so i don't have to do each video manually etc)
So i saved a Project file as "proj.py" then i cut out the load file and marker setting lines
then i copied the *.py file i modded to the "Custom" folder.. (where my 4 .admjs files are located)
C:\Users\Account\AppData\Roaming\avidemux\custom
What happened is when i relaunched Avidemux the *.admjs vanished from showing up in the GUI.
So..
I am guessing there is a code routine to check for what extensions are found in that folder.. maybe a bug ?

I also noticed when saving Both Project types there is a lot of missing parts in the "SpiderMonkey" projects.
Save both type then compare them and you will see what i mean.. such as the Language is set in one and not the other.

But i did like how easy it was to setup that Custom option :)
It seems to be working perfect !

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 6060
Re: [BUG] Windows GUI Custom Scripts Menu
« Reply #1 on: March 18, 2016, 09:06:00 AM »
In "Custom folder" create another folder and move project in to that.
see posting here: http://avidemux.org/smif/index.php/topic,16651.msg74135.html#msg74135