Author Topic: [feedback] Universal linux64 binaries  (Read 2879 times)

mean

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 10967
[feedback] Universal linux64 binaries
« on: August 10, 2016, 06:18:32 AM »
Self contained all inclusive binaries, nothing to install.
It should be compatible with most 64 linux  that are not older than  ~ 3 years

Test :
Download the file here
http://www.avidemux.org/nightly/appImage/

then
Code: [Select]
chmod +x avidemux_appImageTest0
./avidemux_appImageTest0

It is highly experimental and i know some things do not work :
* X264/x265
* It will crash if you have a default settings file

For the moment, please just report if it starts or not and if you manage to open a video file

i.e.

debian foobar : starts, load video
fedora blah     : does not start

etc..

Thanks
« Last Edit: August 15, 2016, 11:53:11 AM by mean »

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 6060
ubuntu 14.04.5 64-bit
« Reply #1 on: August 10, 2016, 06:32:32 AM »
Code: [Select]
:~/Downloads$ ./avidemux_appImageTest0
Quote
Directory /home/jan/.avidemux6/ exists.Good.
Using /home/jan/.avidemux6/ as base directory for prefs, jobs, etc.
*************************
  Avidemux v2.6.12 (0) .
*************************
 http://www.avidemux.org
 Code      : Mean, JSC, Grant Pedersen
 GFX       : Nestor Di, nestordi@augcyl.org
 Design    : Jakub Misak
 FreeBSD   : Anish Mistry, amistry@am-productions.biz
 Audio     : Mihail Zenkov
 Mac OS X  : Kuisathaverat, Harry van der Wolf
 Win32     : Grant Pedersen

Compiler: GCC 4.7.2
Build Target: Linux (x86-64)
User Interface: Qt (5.3.2)

Large file available: 1 offset
Time: Wed Aug 10 08:30:23 2016

0: /tmp/.mount_wUrV7z/usr/bin/avidemux3_qt5

Initialising prefs
 [load]  Loading prefs from /home/jan/.avidemux6/config2
  [load]  can't read /home/jan/.avidemux6/config2
 [cpuCaps]Checking CPU capabilities
      MMX detected
      MMXEXT detected
      SSE detected
      SSE2 detected
      SSE3 detected
      SSSE3 detected
[cpuCaps]End of CPU capabilities check (cpuMask :ffffffff, cpuCaps :1e6)
 [setMask]  [CpuCaps] Setting mask to 0x7fffffff
  [UI_Init]  Starting QT4 GUI...
/tmp/.mount_wUrV7z/usr/bin/avidemux3_qt5: symbol lookup error: /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0: undefined symbol: g_type_add_instance_private
:~/Downloads$

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 6060
ubuntu 16.04.1 64-bit
« Reply #2 on: August 10, 2016, 06:43:01 AM »
ubuntu 16.04.1: starts, loads mkv.

ts muxer not found.
pop-up window: Info
Quote
Cannot find a demuxer for /home/jan/Videos/720p4audioTracks3satá´´á´°.ts
Code: [Select]
[HandleAction]  ************ OPEN_VIDEO **************
  [mxfHeader] Cannot open that (10114047)
 [avsProxy] Cannot open that
 [picHeader] Cannot open that
 [MP4] Cannot open that...
 [openDML] Cannot open that
 [flvHeader] Cannot open that
 [mkvHeader] Cannot open that
 [asfHeader] Cannot open that
« Last Edit: August 10, 2016, 06:46:41 AM by Jan Gruuthuse »

mean

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 10967
Re: [experimental] Universal linux64 binaries
« Reply #3 on: August 10, 2016, 06:45:09 AM »
Do you have a Gtk theme ?

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 6060
Re: [experimental] Universal linux64 binaries
« Reply #4 on: August 10, 2016, 06:47:11 AM »
14.04.5 no GTK

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 6060
Re: [experimental] Universal linux64 binaries
« Reply #5 on: August 10, 2016, 07:18:56 AM »
some GTK stuff is present (from other used programs perhaps?)
Code: [Select]
dpkg -l *gtk*

ajschult

  • Jr. Member
  • **
  • Posts: 98
Re: [experimental] Universal linux64 binaries
« Reply #6 on: August 10, 2016, 12:32:39 PM »
For the moment, please just report if it starts or not and if you manage to open a video file

On fedora 24, it opens but cannot open any video.  In the console, I see

Code: [Select]
[ADM_ad_plugin] Scanning directory /usr/lib/ADM_plugins6/audioDecoder/
[ADM_ad_plugin] Cannot parse plugin
 [ADM_av_loadPlugins]  [ADM_av_plugin] Scanning directory /usr/lib/ADM_plugins6/audioDevices/
  [ADM_av_loadPlugins]  [ADM_av_plugin] Cannot parse plugin
 [ADM_ae_plugin] Scanning directory /usr/lib/ADM_plugins6/audioEncoders/
[ADM_ae_plugin] Cannot parse plugin
[ADM_dm_plugin] Scanning directory /usr/lib/ADM_plugins6/demuxers/
[ADM_av_plugin] Cannot parse plugin
[ADM_mx_plugin] Scanning directory /usr/lib/ADM_plugins6/muxers/
[ADM_av_plugin] Cannot parse plugin
[ADM_vd6_plugin] Scanning directory /usr/lib/ADM_plugins6/videoDecoders/
[ADM_vd6_plugin] Cannot parse plugin
Unable to load [copyADM]: copyADM: cannot open shared object file: No such file or directory
[videoEncoder6]Symbol loading failed for copyADM
[ADM_ve6_plugin] Scanning directory /usr/lib/ADM_plugins6/videoEncoders/
[ADM_ve6_plugin] Cannot parse plugin
[ADM_ve6_plugin] Scanning directory /usr/lib/ADM_plugins6/videoEncoders//qt5
[ADM_ve6_plugin] Cannot parse plugin
[ADM_vf_plugin] Scanning directory /usr/lib/ADM_plugins6/videoFilters/
[ADM_vf_plugin] Cannot parse plugin
[ADM_vf_plugin] Cannot parse plugin

mean

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 10967
Re: [experimental] Universal linux64 binaries
« Reply #7 on: August 10, 2016, 12:36:38 PM »
normal, i'm fixing it

At least it starts, it's a good sign

mean

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 10967
Re: [experimental] Universal linux64 binaries
« Reply #8 on: August 10, 2016, 05:38:56 PM »
I've uploaded Test1, it should be mostly working

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 6060
ubuntu 14.04.5 64-bit
« Reply #9 on: August 11, 2016, 07:11:22 AM »
ubuntu 14.04.5 64-bit
 avidemux_appImageTest1 working and loading .mkv and .ts
« Last Edit: August 11, 2016, 07:20:53 AM by Jan Gruuthuse »

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 6060
ubuntu 16.04.1 64-bit
« Reply #10 on: August 11, 2016, 07:21:35 AM »
ubuntu 16.04.1 64-bit:
avidemux_appImageTest1 working and loading .mkv and .ts

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 6060
avidemuxUniversal_amd64_160811.app
« Reply #11 on: August 12, 2016, 05:34:15 AM »
ubuntu 14.04.5 64-bit: OK
ubuntu 16.04.1 64-bit: OK
« Last Edit: August 12, 2016, 06:00:52 AM by Jan Gruuthuse »

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 6060
avidemuxUniversal_amd64_160812
« Reply #12 on: August 12, 2016, 06:57:13 AM »
ubuntu 14.04.5 64-bit: OK, no issues if defaultSettings.py is present in ~/.avidemux6.

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 6060
Re: [experimental] Universal linux64 binaries
« Reply #13 on: August 15, 2016, 06:08:15 AM »
>8 >8
It is highly experimental and i know some things do not work :
* X264/x265
* It will crash if you have a default settings file

avidemuxUniversal_amd64_160814_21.app seems to be fine now on:
16.04.1 and 14.04.5, you can: "Avidemux menu => Edit => Save current settings as default" now. Avidmux no longer crashes doing so.

x264 and x265:
- 14.04.5 OK
- 16.04.1 OK
« Last Edit: August 15, 2016, 07:49:19 AM by Jan Gruuthuse »

mean

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 10967
Re: [experimental] Universal linux64 binaries
« Reply #14 on: August 15, 2016, 09:24:36 AM »
I've locally fixed nvidia-libva, just intel-libva missing and we are good to go