Author Topic: Ubuntu cross-version compatibility of Avidemux binaries  (Read 3176 times)

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 3188
Re: Ubuntu cross-version compatibility of Avidemux binaries
« Reply #15 on: August 14, 2016, 09:46:06 AM »
remark installing 14.04.5 QT4 build destroys the installed 16.04.1 build QT5

Yes, this is expected. Qt4 and Qt5 builds can coexist if the core Avidemux libs they rely upon are built with the similar gcc version which is not the case now.

Thanks a lot for your testing. I hoped that it could be possible for you to simplify your build setup for Avidemux debs, performing all builds on 16.04.1, but this didn't work out. Of course, it is possible to build everything on 14.04.5, but the outdated Qt5 version on 14.04.5 might be a valid reason not to do so.

If dealing with Debian and Ubuntu maintainers in order to integrate Avidemux into their distributions if harder than investing time and effort into creating a reliably working appImage of Avidemux, that says a lot about the maintainers.

mean

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 10971
Re: Ubuntu cross-version compatibility of Avidemux binaries
« Reply #16 on: August 14, 2016, 12:02:11 PM »
appImage is the way to go