Author Topic: VP9 - Opus, Windows 10 64-bit, Avidemux 2.7.0_r170514 - x64  (Read 3560 times)

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 6060
Anyone else having troubles with downloaded,IDM ,  YouTube videos: vp9 with opus audio in .mkv container
where you get:
Quote
Attempt to open ........... failed!
or edited video looks like this:

I can't recreate these issues (I'm not on windows), these videos behave normally on Ubuntu 16.04.2 Qt5.
This issue is been reported in Avidemux-Spanish » Problema con videos bajados de Youtube

I have no clue on what is going on.
the 1st video MKV-480p is 1 GB
« Last Edit: May 15, 2017, 09:31:42 AM by Jan Gruuthuse »

minegroasprilla

  • Newbie
  • *
  • Posts: 15
Re: VP9 - Opus, Windows 10 64-bit, Avidemux 2.7.0_r170514 - x64
« Reply #1 on: May 15, 2017, 12:23:22 PM »
People, test these videos with Internet Download Manager (mkv-480p):
- https://www.youtube.com/watch?v=pI03QOFXKpM
- https://www.youtube.com/watch?v=ve_ZpZUM6WI
« Last Edit: May 15, 2017, 12:25:16 PM by minegroasprilla »

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 2717
Re: VP9 - Opus, Windows 10 64-bit, Avidemux 2.7.0_r170514 - x64
« Reply #2 on: May 15, 2017, 02:01:50 PM »
People, test these videos with Internet Download Manager (mkv-480p)

What is the point? youtube-dl exists and works.

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 2717
Re: VP9 - Opus, Windows 10 64-bit, Avidemux 2.7.0_r170514 - x64
« Reply #3 on: May 15, 2017, 02:07:28 PM »
I see, builds for Windows don't include libvpx, required to decode VP9.

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 2717
Re: VP9 - Opus, Windows 10 64-bit, Avidemux 2.7.0_r170514 - x64
« Reply #4 on: May 15, 2017, 02:44:48 PM »
I can confirm that the vp9+opus MKV gets loaded and played fine in my private win64 Avidemux build with the libvpx plugin included. The official cross-build environment has to be updated to produce nightly and release builds which are capable of decoding vp9.

minegroasprilla

  • Newbie
  • *
  • Posts: 15
Re: VP9 - Opus, Windows 10 64-bit, Avidemux 2.7.0_r170514 - x64
« Reply #5 on: May 16, 2017, 12:09:29 PM »
So, is the problem fixed?.

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 6060
Re: VP9 - Opus, Windows 10 64-bit, Avidemux 2.7.0_r170514 - x64
« Reply #6 on: May 16, 2017, 03:00:23 PM »
Probably when next nightly build appears on line?

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 2717
Re: VP9 - Opus, Windows 10 64-bit, Avidemux 2.7.0_r170514 - x64
« Reply #7 on: May 16, 2017, 04:58:58 PM »
So, is the problem fixed?

Let's say so: the nature of the problem is identified. Once the official build environment gets updated to include libvpx, the following nightly builds will be able to decode VP9. No idea when this will happen though.

mean

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 10967
Re: VP9 - Opus, Windows 10 64-bit, Avidemux 2.7.0_r170514 - x64
« Reply #8 on: May 16, 2017, 07:01:46 PM »
The thing is, libavcodec should be able to decode these
mplayer or mpv can, and they use libavcodec

using libvpx is a workaround

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 2717
Re: VP9 - Opus, Windows 10 64-bit, Avidemux 2.7.0_r170514 - x64
« Reply #9 on: May 16, 2017, 07:30:14 PM »
Sure, this is a stop-gap measure. It would be great if you could identify the cause why the bundled ffmpeg fails to decode VP9 properly, but if this takes time from the work on DXVA2 issues with ffmpeg 3.3, I'm not confident that this is worth it ATM...

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 2717
Re: VP9 - Opus, Windows 10 64-bit, Avidemux 2.7.0_r170514 - x64
« Reply #10 on: May 17, 2017, 06:55:32 AM »
libvpx has been added to the build environment, VP9 decoding should work now.

@minegroasprilla, please test the latest win64 nightly from

Code: [Select]
http://avidemux.org/nightly/win64/avidemux_r170517_win64Qt5_417.zip

minegroasprilla

  • Newbie
  • *
  • Posts: 15
Re: VP9 - Opus, Windows 10 64-bit, Avidemux 2.7.0_r170514 - x64
« Reply #11 on: May 18, 2017, 06:33:04 PM »
libvpx has been added to the build environment, VP9 decoding should work now.

@minegroasprilla, please test the latest win64 nightly from

Code: [Select]
http://avidemux.org/nightly/win64/avidemux_r170517_win64Qt5_417.zip

I tested the last version but the problems continue.
MKV (vp9) don't open, and WEBM (vp9) open but when I edit it, the resulting video is bad.

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 2717
Re: VP9 - Opus, Windows 10 64-bit, Avidemux 2.7.0_r170514 - x64
« Reply #12 on: May 18, 2017, 07:03:37 PM »
I tested the last version but the problems continue.
MKV (vp9) don't open,

This works for me with MKV (vp9 + opus) generated by ffmpeg in copy mode from original streams. Please provide a sample video (as short as possible).

Quote
and WEBM (vp9) open but when I edit it, the resulting video is bad.

Actually, I can't save the MKV (vp9 + opus) in copy mode at all, no matter whether the target container is MKV or webm. The error is

Code: [Select]
[adm_lavLogCallback] 18:52:15-981 [lavc] Unknown bitstream filter 'vp9_superframe'
[FF]Error writing video packet

minegroasprilla

  • Newbie
  • *
  • Posts: 15
Re: VP9 - Opus, Windows 10 64-bit, Avidemux 2.7.0_r170514 - x64
« Reply #13 on: May 18, 2017, 10:56:46 PM »
I need to edit those videos to MP4.
Here a sample video in MKV-vp9: http://www.mediafire.com/file/408a3gahelne0zf/Sample-mkv.mkv
« Last Edit: May 18, 2017, 10:58:33 PM by minegroasprilla »

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 2717
Re: VP9 - Opus, Windows 10 64-bit, Avidemux 2.7.0_r170514 - x64
« Reply #14 on: May 18, 2017, 11:53:10 PM »
I need to edit those videos to MP4.

If you need MP4, why don't you download the h264/m4a version in a MP4 container in the first place? youtube-dl allows you to query available versions of a video and specify one that suits your needs best (you do need the most recent version of youtube-dl). VP9 and opus can't be saved as MP4 without reencoding.

Quote
Here a sample video in MKV-vp9: http://www.mediafire.com/file/408a3gahelne0zf/Sample-mkv.mkv

Avidemux indeed doesn't like the file:

Code: [Select]
[MKV] *** Header dump ***
EBML_VERSION:1
EBML_COMPAT:1
EBML_MAXIDLEN:4
EBML_MAXSIZELEN:8
EBML_DOCTYPE:<matroska>
EBML_DOCTYPE_VERSION:4
EBML_DOCTYPE_COMPAT:2
[MKV] *** End of Header dump ***
MKV_TIMECODE_SCALE:1000000
MKV_MUXING_APP skipped
MKV_WRITING_APP skipped
MKV_SEGMENT_UID skipped
MKV_DURATION skipped
 [open]  TimeBase found : 1000000 ns
 [open]  [MKV] found Segment at 0x3b
 [readSeekHead] Parsing SeekHead
[MKV/SeekHead] Tag 0x53ab not found (len 4)
 [goBeforeAtomAtPosition] No offset available for MKV_TRACKS
 [analyzeTracks] Cannot go to the TRACKS atom
[MKV] incorrect tracks
[MKV] Tracks analyzed
[MKV] No video

ffmpeg is more tolerant here. Remuxing the video with ffmpeg allows Avidemux to load the video successfully:

Code: [Select]
ffmpeg -i Sample-mkv.mkv -c copy Sample-mkv-remuxed-with-ffmpeg.mkv