May 20, 2022, 11:57:53 PM

News:

--


APPEND is broken in 2.6.21 (64bits)

Started by ivanhoex, June 25, 2017, 06:50:37 PM

Previous topic - Next topic

ivanhoex

June 25, 2017, 06:50:37 PM Last Edit: June 25, 2017, 07:40:13 PM by ivanhoex
hi all!

i have several h264 videos that wanted to make into a single one, and this app looked as my saviour

thing is, my videos were at 30fps, and after appending one, it was saved as 29.97, without modifying the audio (hence desynching it)
this was done using 2.6.21 (win 64bits) AND  2.6.20 (win 32bits)
also tried adding FPS filters to no output change.

i then downloaded the 2.5 (32bit) version of the app and it resulted in a 30fps video file, so, everything is good for me, but i had to come here and let you guys know, free app, powerfull app.. cant be more thankful... so trying to give a cent back as feedback

not sure what things was 2.6 doing better.. maybe audio or stuff like that.. but hopefully this file is ok now.



PROBLEM: tried to do this on the x265 files... no luck, the 2.5 version doesnt seem to work with those (reads as green/no-video)... damn.


ps. is there a newer version with this error fixed?
for now, i am re encoding the separate videos down to 29.97 and crossing my fingers that this will work (and be accepted)

eumagga0x2a

Please try the latest nightly build. If the problem persists, please provide a sample.

ivanhoex

June 26, 2017, 06:40:24 PM #2 Last Edit: June 26, 2017, 06:51:21 PM by ivanhoex
hi!

also to note, audio is 5.1 aac. this is coming from premiere as uncompressed rgb 8bits, then 4 of them are s.squeeze'd into hevc @35mbps (files are 3840*1920) and one @100mbps
attached the pics for the original videos and the resulting one

the nightly build still outputs the 30fps x265 videos as a 29.97fps merged one with desynched audio

how/where do i upload a test video? (cant with the ones i am working atm, confidentiality and so on)



/edit:  PS: i ended up forcing squeeze to drop from 30fps uncompressed to 29.97 x265, then merged all those files in avidemux and the result seems fine, but the original problem persists, ofc

eumagga0x2a

FPS issues are mostly demuxer-related. You provided exactly zero information about the container format in question. To upload samples, please use https://wetransfer.com.

ivanhoex

so very sorry about the zero information.

used the MP4 one, as MP4v2 didnt seem to even work with h265

eumagga0x2a

Not the target container but the source, please.

ivanhoex

June 26, 2017, 08:57:43 PM #6 Last Edit: June 26, 2017, 09:01:01 PM by ivanhoex
all were .mp4 from the sorenson squeeze 11  "MP4: HEVC 18000kbps" profile (x265), only changed to read size from the source and the bitrate up to 35000, and audio changed to 5.1

eumagga0x2a

Though FPS detection issues with the Mp4 demuxer are well known, it would be still very helpful to have a sample. WRT desync: are you sure it is not a pure performance issue during playback?

ivanhoex

June 26, 2017, 09:28:59 PM #8 Last Edit: June 26, 2017, 09:32:51 PM by ivanhoex
about desynching, yes, it was not performance related, as the 29.97 version didnt suffer from that problem
also, the info on the file, by avidemux, reads 30fps for the original files, and while having in memory (not yet saved out) the appended files



while making the test, the 30fps file went down to 27fps for some reason

there is one file named "test", a crop in time from the whole video, same aspect and everything otherwise, plus two versions of the result of appending itself (3 times total) in 2.6 and 2.7 versions


https://we.tl/A1lEvjlzkx

eumagga0x2a

Thanks, I can reproduce the issue when using the MP4 muxer but not when using the MKV muxer.