Compilation failed in Fedora Rawhide(F28)

Started by davidva, September 29, 2017, 01:05:43 AM

Previous topic - Next topic


Hi, my builds works perfectly in Fedora 24 to Fedora 27; but Fedora 28 failed... I am not sure if qt 5.9 is the problem, I need help for build. The complete log is the next: Please help!  :-\

Jan Gruuthuse

You did use the instruction following instruction?
If not try again. It checks/installs missing packages. Let us know how this went.


yes sure, you can see my "spec.file" ; the above log show  all... It doesn't compile in Fedora 28(rawhide); but compile fine in F24-F27; a succesfull Fedora 26 build here....

also I tested building with clang, also a old cmake and the same result...

also "bootStrap.bash --rpm" same result... check the log...

[ 11%] Linking CXX shared library
cd /builddir/build/BUILD/avidemux2-7895e9e8963c6e8245c403aa40770c39d5c15026/buildQt5/ADM_openGL/src && /usr/bin/cmake -E cmake_link_script CMakeFiles/ADM_openGLQT56.dir/link.txt --verbose=1
/usr/bin/c++ -fPIC -O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -m64 -mtune=generic -D__STDC_CONSTANT_MACROS -fno-strict-aliasing -fmessage-length=0 -O2 -DNDEBUG  -shared -Wl,-soname, -o CMakeFiles/ADM_openGLQT56.dir/ADM_openGl.cpp.o CMakeFiles/ADM_openGLQT56.dir/ADM_openGlDownloadTexture.cpp.o CMakeFiles/ADM_openGLQT56.dir/ADM_openGlDownload_asm.asm.o  -L/builddir/build/BUILD/avidemux2-7895e9e8963c6e8245c403aa40770c39d5c15026/install/usr/lib64 -Wl,-rpath,/builddir/build/BUILD/avidemux2-7895e9e8963c6e8245c403aa40770c39d5c15026/install/usr/lib64: -lGLU -lGL /usr/lib64/ /usr/lib64/ -lADM_coreUI6 -lADM_core6 -lADM_coreUtils6 -lADM_coreImage6 /usr/lib64/ /usr/lib64/
make[2]: Leaving directory '/builddir/build/BUILD/avidemux2-7895e9e8963c6e8245c403aa40770c39d5c15026/buildQt5'
[ 11%] Built target ADM_openGLQT56
make[1]: Leaving directory '/builddir/build/BUILD/avidemux2-7895e9e8963c6e8245c403aa40770c39d5c15026/buildQt5'
make: *** [Makefile:155: all] Error 2


Upon a very quick glance, glibc in F28 has dropped support of pow10f. The issue has nothing to do with qt.