Author Topic: video delayed  (Read 943 times)

aeryn.sun

  • Newbie
  • *
  • Posts: 5
video delayed
« on: March 14, 2018, 11:56:43 PM »
hi,
when i open an video file created by handbrake (mp4: h264/ac3) with avidemux (2.7.0 nightly 180314) and play it inside avidemux, the video is delayed. when played with mplayer or ffplay there is no delay. Also after editing the file and exporting (mp4 demuxer, audio: copy, video:copy) audio/video is out of sync.
- xubuntu 17.10 64bit
- avidemux 2.7.0 180314 nightly from git
- ffplay 3.3.4-2

I already tried playing with preferences/output/sanitize DTS in copy mode and preferences/audio/local playback downmixing but no success. Is it possible that this due to some failed hw acceleration? I know that mpv with vaapi acceleration causes such delays

Code: [Select]
[ADM_LIBVA_getFormat] 23:51:38-742  Found matching hw accelerator : h264_vaapi
 [ADM_LIBVA_getFormat] 23:51:38-742  Successfully setup hw accel
 [canSupportThis] 23:51:38-742  This is maybe supported by LIBVA
 [lookup] 23:51:38-742  Matching hw accel : VAAPI
 [ADM_FFgetFormat] 23:51:38-742  Reusing existing setup
 [adm_lavLogCallback] 23:51:38-742  [lavc] Using deprecated struct vaapi_context in decode.

any ideas?

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 2290
Re: video delayed
« Reply #1 on: March 15, 2018, 07:56:11 AM »
If you suspect libva video accel being related to the issue, disable hardware accelerated video decoding and try again. Otherwise please provide a sample.

aeryn.sun

  • Newbie
  • *
  • Posts: 5
Re: video delayed
« Reply #2 on: March 16, 2018, 10:12:38 AM »
Hi,

disabling hw acceleration in avidemux didn't affect the output. If you want to have a look at the files:
https://ufile.io/1ilav - tagesschau-demuxed.mp4 - this is the demuxed (audio: copy, video: copy, mp4 demuxer)
https://ufile.io/0hjs6 - tagesschau-handbraked.m4v - this is the original file encoded by handbrake (h264, ac3)

i appreciate any help
aeryn

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 6052
Re: video delayed
« Reply #3 on: March 16, 2018, 03:32:44 PM »
this is the original file encoded by handbrake (h264, ac3)
This is a modified/re-encoded video by handbrake.
Original would be the recorded stream, mpeg-ts, from STB (DVB-T(2) ,DVB-S(2))

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 6052
Re: video delayed
« Reply #4 on: March 16, 2018, 03:55:40 PM »
In the handbrake touched video there are errors at start of video.
Playing with VLC:
Screen stays black, audio is already playing.
Video appears later with blocks, would indicate errors are already present in video. see attached screenshot from VLC:
Compressing from 11 Mbps to 2 Mbps (Handbrake?) would not help or is to much of an expectation.
« Last Edit: March 16, 2018, 03:59:51 PM by Jan Gruuthuse »

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 2290
Re: video delayed
« Reply #5 on: March 16, 2018, 06:12:08 PM »
this is the original file encoded by handbrake (h264, ac3)
This is a modified/re-encoded video by handbrake.

This is exactly what I requested :-)

Yes, the start of the video is corrupted (mpv skips the broken part, Avidemux does not). I'm unsure it is a problem with Avidemux.