November 26, 2020, 06:03:36 am



BUG REPORT, v.2.7.1 - "Change FPS" filter

Started by BG Davis, January 29, 2019, 04:25:14 am

Previous topic - Next topic

BG Davis

Shot 4K video, 16:9 aspect ratio, 60p (MP4).  About 15 seconds in duration.
Edited with filters:
--Crop (retaining 16:9 aspect ratio)
--Fade to black
--Resize to 1920x1080 (sws Resizer)
--Change FPS (change speed and duration): 59.93 to 29.97 (slow motion).

The slow motion filter refused to apply in the finished clip.  In both "Preview" and "play filtered", it was slow but jerky.  When saved (MP4), it played at full normal speed (PotPlayer, FastStone, etc.). 
I tried both of the pre-selected filter settings (23.976 film, 29.97 NTSC, etc.).  I removed the filter and re-applied, to no avail.  Nothing made any difference.
To get the slow motion, I finally had to save the clip at regular speed (with the other filter edits in place), then re-open, add the "Change FPS" filter and re-save with a different name.
Running Win7, 64 bit.  Never had this problem with previous versions.


BG Davis

Unfortunately, yes - still the same issues.  There is no change from the reported experience.


January 29, 2019, 05:48:06 pm #3 Last Edit: January 29, 2019, 05:53:21 pm by eumagga0x2a
Works fine for me with the filterchain specified.

Just one note: the input frequency of the "Change FPS" filter must match the FPS after the previous filter in the chain. I.e., if the source video was not 59.93 FPS, it won't work.