August 12, 2020, 06:28:15 am

News:

--


Compilation and executing avidemux

Started by umamahesh, February 11, 2019, 01:38:32 pm

Previous topic - Next topic

umamahesh

Hi

I started following below link,

https://www.avidemux.org/admWiki/doku.php?id=build:compiling_avidemux

I took latest git repo and started compiling on ubuntu 16.04, the compilation is success.

I see binaries in install/usr/bin, it contains

avidemux3_cli
avidemux3_jobs_qt5
avidemux3_qt5


How do I run a audio or video file using this.

According to document,

avidemux <file.avi> to be executed from command line. Where can I find avidemux

Please suggest. Is there any document to understand the usage of avidemux.

Please guide me.

eumagga0x2a

First of all, you probably want to build Avidemux off the ffmpeg4x git branch instead of master (all recent fixes and improvements went into ffmpeg4x branch, not into master), i.e. execute

git checkout ffmpeg4x

in the avidemux2 folder and build Avidemux anew.

If you don't need the Jobs GUI, you could use the template script run_avidemux_template.sh to run Avidemux (avidemux3_qt5) without installation. Rename the script to "avidemux" if you like so, adjust paths in the script if necessary, copy it to a location included in $PATH (some distributions add ~/bin to PATH, this is the most suitable location IMHO) and make it executable.

avidemux

would launch the Avidemux GUI then.

You should be able to load a video either using the GUI (Ctrl+O or "File" --> "Open Video" or drag'n'drop) or running Avidemux on the command line as

avidemux --load /Path/to/Video

Actually, if /Path/to/Video is the first argument passed to avidemux as in this example, --load can be dropped, but otherwise it is required.

Please note that if ~/bin is in PATH but didn't exist until now or was empty, you will have to log out and log in again to enable it.


umamahesh

Hi

As suggested I switched to ffmpeg4x branch and tried to build, but build is not started.


Please check the attached screen shot for reference, please suggest if anything to be referenced to get out of the error.


umamahesh

February 13, 2019, 10:25:23 am #3 Last Edit: February 13, 2019, 10:32:01 am by umamahesh
Hi

I modified the script (run_avidemux_template.sh)and now the UI runs, but avidemux is missing when I run bash bootstrap.bash.

If I want to modify the avidemux code, I need to compile the code after my modifications. But when I compile bash bootstrap.bash --deb --without-qt, avidemux binary is missing. How do I get the compiled the binary.

Please suggest the exact procedure.

eumagga0x2a

February 13, 2019, 10:50:39 am #4 Last Edit: February 13, 2019, 11:27:48 am by eumagga0x2a
You explicitly disabled the build of Avidemux Qt GUI by passing the --without-qt option to bootStrap.bash. If you want to rebuild only parts of the software, you must add the --rebuild option, otherwise build directories and the install directory will be deleted.

By the way, why do you enable packaging as deb when you are not going to use it as far as I understand?

It is better to post text when what you want to communicate exists in textual form.