September 21, 2021, 02:58:25 AM



Add audio to video

Started by ray5450, February 17, 2019, 08:03:27 PM

Previous topic - Next topic


I'm trying to simply add audio to a video. 

Both the audio file and video file are the same length in time,  7 minutes.
The video file is mp4.
I found out below that the audio file must be in 16 bit wav format, so that is what I converted it to:,18279.msg83798.html#msg83798,18051.msg82362.html#msg82362
Both files do play separately.

I have tried the following setting combinations:
-video output=copy
-audio output = AAC(FDK), also tried AAC(lav)  (using Audio Tracks Configuration)
-output format = MP4 muxer, also tried MP4v2 muxer

All of the above result in the same.  The resulting file:
-has no audio or video
-my player indicates it is playing but time does not progress
-the time length is not 7 minutes, but around 3 minutes.

Is there a combination of settings to make this work?



First of all, can you reproduce the problem with the most recent nightly build? If yes, please provide for starters the output of MediaInfo for the source mp4 file and for the output.


Thank-you, for your response.

Since you did not comment on the combinations that I used, I conclude that they should all work.

"First of all, can you reproduce the problem with the most recent nightly build?"
--Okay, I installed that and tried again as above.  Immediately when finishing, this error message appears:
  Error seeking to 0 ms"
  This error did not occur before.   Since the new version produced a different result by giving this error, I did not continue
  with your step 2.


Please either provide the requested MediaInfo output for the source file or provide right away the source file as a sample. Apparently, the source file is broken (e.g. wrong frames are marked as keyframes or no frames are marked as keyframes at all, which makes seeking partially or completely impossible).


You're right.  Just by you saying that the file is damaged, helped me figure it out.  I rechecked it, and it is.  However, it is a very strange issue.  I have played the file all the way for the 7 minutes several times in the past, and including the other day, and it was fine.  Now, it goes to about 3 minutes and becomes a frozen frame.  I went to one of my machine backups from last April and recovered the file.  Again, it played for the whole 7 minutes.  I closed it.  Opened it again, and discovered it was broken.  It must be somehow self-destructing, or something.  I never heard of this happening or had it happen with any file, video or strange.  Thanks, for helping me figure it out, though.

Jan Gruuthuse

DRM with (time/date) limit is a possibility.
Or you could have troubles with (faulty/degraded/...) storage media, memory, ...


It was a public Youtube, so probably not DRM.

I had 3 copies of the file, the working copy and 2 backups.  All are the same:  play one time, and done.


There is such thing as checksums. Use them (even the old MD5 will do) to check the integrity of the copies. If they don't match, you've got a real hardware problem, which is beyond the scope of this topic.

If they match: Which player do you refer to? Is the latest Avidemux nightly build capable to play the video to the end? If not, it should be really broken (videostream-wise). You could provide a compressed (zip, gzip, 7z, no rar please) admlog.txt from an attempt to load and to play the file in order to allow more substantiated guessing. The log is located in %localappdata%\avidemux\

You may edit the log to substitute entries containing the path to your home folder with clearly identifiable placeholders.


Is it some kind of tool, or utility that you are talking about?

I tried 2 different players:  yes, the latest Avidemux, and also MPC.

As far as the files for which I started this thread, when I found that I could not do anything about the damage, I scrapped the whole project and deleted it.


Quote from: ray5450 on February 28, 2019, 06:03:14 AM
Is it some kind of tool, or utility that you are talking about?

This is a concept allowing to verify data integrity, fundamental to computer security. It uses a number of hashing algorithms, implemented in a set of utilities (md5sum, sha1sum, sha256sum, sha512sum) not present by default on Windows and as a feature of many advanced file managers (Windows Explorer not included).


Thanks, for the information.  I have never had any file go "bad" or corrupt, except once, several years ago when I had a failing hard drive.

I think more likely, the file here was damaged during when I first downloaded it.  I have had that happen many times.  What was different about this time, is that the damage did not affect the first time it was opened, but it did for any subsequent times.  I am not able to redownload the file to retry as it is no longer available.