Participate > Avidemux Wiki

avidemux 2.6.# Compiling Avidemux on Ubuntu 18.04

(1/1)

umamahesh:
I am trying to compile avidemux 2.6 on Ubuntu 18.04, I get following error when I run ./run_avidemux_template.sh
Hi

I am trying to compile avidemux 2.6 on Ubuntu 18.04, I get following error when I run ./run_avidemux_template.sh

/home/net/avidemux2/install/usr/include/avidemux/2.7/ADM_coreConfig.h not found, can't determine the relative library directory. Aborting.

any suggestions please. Also I compiling avidemux 2.6 using

bash bootStrap.bash

Compilation is success, but at the final unable to find avidemux binary.

Is there any dependency on linux version for the package.

Please suggest. I have posted multiple times but the solutions doesn't help to proceed further.

Early solutions will help me a lot.

eumagga0x2a:
How is this problem related to Avidemux Wiki instead of the Unix subforum?

Why are you mentioning 2.6? It is legacy and unsupported. Only the current git is really supported and in some sense also the last 2.7.1 release (meaning if something is wrong there, it can be fixed only in the git, so we are back to the latest git).

If the wrapper script (which is meant to be renamed and moved to a location which in included in $PATH) says that /home/net/avidemux2/install/usr/include/avidemux/2.7/ADM_coreConfig.h is not found, you should explain, why this file is not present at this location. If you try to build 2.6, then of course, this file won't be present there.

umamahesh:
The purpose of posting in this sub forum is to get compilation procedure for avidemux.

I added few print statements in avidemux2 package (using ffmpeg4x branch) When bash bootstrap.bash is executed I do not see avidemux binary (Referring to http://www.avidemux.org/admWiki/doku.php?id=using:command_line_usage)


I manually changed the HERE path point to ADM_coreConfig.h in run_avidemux_template.sh script and run the script, a player opened and able to run videos.


Now suggest me how to get updated avidemux binary, how ./run_avidemux_template.sh is executed

eumagga0x2a:
If you needed to change $HERE manually, then you ignored


--- Code: ---# TOPSRCDIR must match the location of the Avidemux source tree,
# default: ${HOME}/avidemux2
--- End code ---

comments in the template script and likely TOPSRCDIR has not been adjusted to match your environment.

The generated avidemux3_qt5 binary is stored in the "$TOPSRCDIR/install/${prefix}/bin" folder within the Avidemux source directory, i.e. with the default prefix being /usr, it amounts to "$TOPSRCDIR/install/usr/bin". The template script should be copied to a folder in your $PATH (do you understand these terms?) and made executable, i.e. in Avidemux source directory, run (assuming that /usr/local/bin already exists):


--- Code: ---sudo cp -v run_avidemux_template.sh /usr/local/bin/avidemux
sudo chmod +x /usr/local/bin/avidemux
--- End code ---

Then running


--- Code: ---avidemux
--- End code ---

should execute "$TOPSRCDIR/install/${prefix}/bin/avidemux3_qt5 --portable" with environment like LD_LIBRARY_PATH set correctly. /usr/local/bin/avidemux passes added command line parameters to avidemux3_qt5.

Please be aware that the documentation you linked to is severely outdated.

Navigation

[0] Message Index

Go to full version