Author Topic: Problem setting start of freeze frame in shortened clip  (Read 379 times)

BG Davis

  • Full Member
  • ***
  • Posts: 114
Problem setting start of freeze frame in shortened clip
« on: March 28, 2019, 07:14:34 PM »
I deleted the center portion from a clip.  The resulting clip was a total of 6.2 seconds in duration.  Wanted to have a freeze frame at the end of the resulting shortened clip, starting at 6.2 seconds (the final frame of the total clip). 
Avidemux would not allow the still frame to start any later than 3.5 seconds (the duration of the first segment of the shortened clip).

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 3295
Re: Problem setting start of freeze frame in shortened clip
« Reply #1 on: March 28, 2019, 07:41:38 PM »
Works fine for me. Please provide detailed steps to reproduce and the admlog.txt reflecting your steps.

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 3295
Re: Problem setting start of freeze frame in shortened clip
« Reply #2 on: March 28, 2019, 09:59:24 PM »
Presumably you can't seek to the end of the video after deleting the center portion, can you? There is a bug in ADM_Composer::getLastKeyFramePts when there are no more keyframes left in the last segment. This was not the case in my testing, that is why it worked for me. Looking into it...

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 3295
Re: Problem setting start of freeze frame in shortened clip
« Reply #3 on: March 28, 2019, 11:05:23 PM »