Author Topic: 2.7.3 (17 Apr) E-AC-3 audio woes  (Read 471 times)

Faiakes

  • Jr. Member
  • **
  • Posts: 83
2.7.3 (17 Apr) E-AC-3 audio woes
« on: April 18, 2019, 11:25:18 AM »
Hi

This was an issue for 2.7.2 too but I just fot frustrated today and want it sorted.


- I make 2+ clips from a source video
- Each clip has E-AC-3 audio
- When I tried to append them together, there is no audio.
- (I think this happens if I've stopped/ended the clips at non-I frames using the -> button instead of the >> button)

-- What can I do (apart from redoing the individual clips) to get the audio working?
-- I have tried converting the audio to MP3 or AAC, for the new clip, but nothing seems to work.
« Last Edit: April 18, 2019, 06:43:51 PM by Faiakes »

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 3295
Re: 2.7.3 (17 Apr) E-AC-3 audio woes
« Reply #1 on: April 18, 2019, 03:02:32 PM »
Please provide a pair of samples to append which would allow to reproduce the issue.

Faiakes

  • Jr. Member
  • **
  • Posts: 83

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 3295
Re: 2.7.3 (17 Apr) E-AC-3 audio woes
« Reply #3 on: April 18, 2019, 04:59:40 PM »
Thank you, which application has generated the samples? Avidemux?

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 3295
Re: 2.7.3 (17 Apr) E-AC-3 audio woes
« Reply #4 on: April 18, 2019, 05:20:17 PM »
I see, the mp4 demuxer in Avidemux doesn't support E-AC3 yet. Should be fixed by [demuxers/Mp4] Add support for EAC3 audio tracks, thank you for raising the topic.

Faiakes

  • Jr. Member
  • **
  • Posts: 83
Re: 2.7.3 (17 Apr) E-AC-3 audio woes
« Reply #5 on: April 18, 2019, 05:42:38 PM »
Thank you, which application has generated the samples? Avidemux?
Yes. Avidemux

Also, this happens in mkv as well.

- With everything set to Copy,  it generates a message: Muxer Cannot open
- With audio set to anything else, it creates a clip without throwing an error but the clip doesn't even start in the latest MPC-HC, and starts in VLC 4.0 but without sound.
« Last Edit: April 18, 2019, 06:43:25 PM by Faiakes »

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 3295
Re: 2.7.3 (17 Apr) E-AC-3 audio woes
« Reply #6 on: April 18, 2019, 05:51:51 PM »
As explained above, the support for E-AC3 audio tracks in mp4 has been just added to the demuxer. It will be present in the next nightly.