September 20, 2020, 06:40:55 am

News:

--


New version 2.7.2 of Avidemux does not start under Windows 10 x64

Started by King555, March 16, 2019, 02:54:07 pm

Previous topic - Next topic

narco

First, I just attempted to update by installing it over the previous version. The installer threw an error. Then I uninstalled completely, and attempted to install fresh. The installer threw an error. I could open Avidemux, but when I went to load a file, it threw errors about missing muxers, similar to reports I've seen here and elsewhere. Then I completely uninstalled again, and attempted a fresh install of nightly. The installer threw the same error.

I should've paid more attention so I could report the error exactly, but it referenced not being able to write certain files, so I figured it may be some odd privilege issue (I'm logged in as admin, and downloaded the exe through a browser on this computer with no antivirus or strict security settings). I uninstalled nightly, and tried reinstalling stable 2.7.3, but this time by right-clicking and specifically running as admin. The program installed correctly and works fine.

The installer obviously has some privilege issues on at least some computers, which didn't exist in previous Avidemux installers I've used. It's working fine for me now, I just figured I'd pass along the info.

mean


King555

Today I made another attempt (because some time has passed, newer version of Avidemux, new Windows updates etc.). Uninstalled/deleted everything and installed the latest nightly build of the VC++ version. Unfortunately no change.

I get these entries in the Windows event viewer:

CleanTalk: *** Forbidden. Please enable JavaScript. Contains contacts. Message seems to be spam. ***

and

CleanTalk: *** Forbidden. Please enable JavaScript. Contains contacts. Message seems to be spam. ***

(German version of Windows).

And I tested the latest VC++ version on my laptop. Same Windows version with almost identical settings and installed software, but (of course) a completely different hardware. Same error there, Avidemux does not start.

By the way: the file "Avidemux_2.7.3 VC++ 64bits 190408.exe" is recognized as malware by Norton Security.

EDIT: The "spam" is here: https://pastebin.com/DmNLV4DB

dgm

Using Process Monitor, I found out it crashes when trying to create the admlog.txt file. The reason is, my username is written with non-Latin Unicode characters and it seems the code that gets the home directory mangles the username contained in the path. When I tested the program with an account that has only Latin letters, it started OK.

eumagga0x2a

Shouldn't it affect MinGW-Builds as well?

Confirmed, VC++-only, thank you very much for your finding.

King555

Although the error has obviously been found, I wanted to say that my username also contains a non-latin letter (the German umlaut "ä").

eumagga0x2a

Mean has just fixed the problem, please try the latest nightly.

King555


eumagga0x2a


eumagga0x2a

Could you please retest with 190510? A wrong build (without the patch) got uploaded on 2019-05-08.


nmott

Hello, the 2.7.3 doesn´t start in my "new brand" w10 x64 only avidemuxjobs starts but unusefull.

Any hints?

eumagga0x2a