Author Topic: Font Problem (mac os mojave 2.7.3)  (Read 1040 times)

sara88

  • Newbie
  • *
  • Posts: 5
Font Problem (mac os mojave 2.7.3)
« on: June 24, 2019, 07:06:25 AM »
Hi there.

I'm using avidemux to encode my subtitles to a video but there are fonts that don't shown correctly after being encoded. All fonts (korean) that I used have been installed correctly on my mac.

Is there anyone who knows how to solve this problem?

Thank you in advance.

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 3404
Re: Font Problem (mac os mojave 2.7.3)
« Reply #1 on: June 24, 2019, 08:44:18 AM »
Upon a quick test, specifying Arial in a subtitles file with 한글 subs results in AppleSDGothicNeo being used, glyphs don't overlap or collide. To assess the situation, please...

a) ...provide the subtitle file used (or just make a minimal one allowing to reproduce the issue)

and

b) ...launch Avidemux from Terminal

Code: [Select]
/Applications/Avidemux_2.7.3.app/Contents/MacOS/Avidemux2.7 > ~/Desktop/admlog.txt
reproduce the problem (you don't need to really encode anything, just use the filter preview mode in the main window and play a small portion of video with subtitles), open "admlog.txt" created on your desktop by the above command, look for and copy into your reply lines beginning with "[ass]" like

Code: [Select]
[ass] fontselect: (Arial, 400, 0) -> /Library/Fonts/Arial.ttf, -1, ArialMT
[ass] Glyph 0xC5B4 not found, selecting one more font for (Arial, 400, 0)
[ass] fontselect: (Arial, 400, 0) -> /System/Library/Fonts/AppleSDGothicNeo.ttc, -1, AppleSDGothicNeo-Regular

In any case, the solution would probably include tweaking the styles in the subtitles file to eliminate glyphs overlap.

sara88

  • Newbie
  • *
  • Posts: 5
Re: Font Problem (mac os mojave 2.7.3)
« Reply #2 on: June 25, 2019, 12:34:42 AM »
This is the subtitle file that I used. This is the simple version of the sub file. I didn't include the one with the aegisub effects coz the size is too big to attach here.

sara88

  • Newbie
  • *
  • Posts: 5
Re: Font Problem (mac os mojave 2.7.3)
« Reply #3 on: June 25, 2019, 07:25:29 AM »
Also this is what happened when I launched avidemux using terminal. I don't understand why it says 'cannot find fonts' coz the fonts are installed in my mac and I can find it in my font book.

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 3404
Re: Font Problem (mac os mojave 2.7.3)
« Reply #4 on: June 25, 2019, 11:43:56 AM »
Oops, thanks, I missed that libass outputs its messages on stderr, not on stdout, so the command to include these in admlog.txt should have been

Code: [Select]
/Applications/Avidemux_2.7.3.app/Contents/MacOS/Avidemux2.7 > ~/Desktop/admlog.txt 2>&1
Quote
I didn't include the one with the aegisub effects coz the size is too big to attach here.

FYI: Compressing (gz, zip or 7z) text files like .ass before attaching would allow it to fit many times into the size limit.

But this doesn't matter in this case now.

Quote
I don't understand why it says 'cannot find fonts' coz the fonts are installed in my mac and I can find it in my font book.

Maybe Avidemux' fontconfig doesn't know about the location these fonts are installed. It looks for fonts in the directories listed at cmake/osx/fonts.conf:27 as well as in ~/.fonts. Are Typo_Papyrus, Chalkboard SE, drfont_daraehand and Typo_Deco installed in one of these directories? If not, you could try to symlink the *.ttf files into ~/.fonts.

sara88

  • Newbie
  • *
  • Posts: 5
Re: Font Problem (mac os mojave 2.7.3)
« Reply #5 on: June 25, 2019, 12:07:40 PM »
The problem has been resolved. Thank you very much. It is exactly as you said. Avidemux doesn't know where the fonts are installed since they're in different folder not in the mac font directory. THANK YOU VERY MUCH for your help. Really appreciate it. :)

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 3404
Re: Font Problem (mac os mojave 2.7.3)
« Reply #6 on: June 25, 2019, 12:11:23 PM »
Great, could you please specify the location? If it is not something completely unusual, we could probably add it to the list.

sara88

  • Newbie
  • *
  • Posts: 5
Re: Font Problem (mac os mojave 2.7.3)
« Reply #7 on: June 25, 2019, 02:50:37 PM »
At first, I put all the newly downloaded fonts in the new folder in desktop. That's why avidemux couldn't detect the fonts used. So I just moved the newly downloaded fonts from the new folder to mac font folder. In my case, after I cut the font files from the new folder, I clicked

OSX(or whatever your macbook name is) -> Macintosh HD -> Library -> Fonts (Just paste/move your fonts - tff files, into this folder)

and tadaaa my problem is solved.  ;)

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 3404
Re: Font Problem (mac os mojave 2.7.3)
« Reply #8 on: June 25, 2019, 03:45:26 PM »
Thank you, should be fixed by [osx] Add user font folder to the font directory list.

I assume that

Quote
All fonts (korean) that I used have been installed correctly on my mac.

means that the *.ttf files have been automatically copied into ~/Library/Fonts which was missing in our search list.

maichan116

  • Newbie
  • *
  • Posts: 1
Re: Font Problem (mac os mojave 2.7.3)
« Reply #9 on: July 02, 2019, 05:31:32 AM »
Thank you for this thread! I had a similar issue for a while now and I was finally able to fix it.

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 3404
Re: Font Problem (mac os mojave 2.7.3)
« Reply #10 on: July 02, 2019, 05:44:14 AM »
If your solution was moving or copying fonts, could you please undo it and verify that the fix, now available in the 190701 nightly https://avidemux.org/nightly/osx_mojave/ works?