July 07, 2022, 02:36:22 PM

News:

--


Missing menu bar

Started by Tux, February 12, 2022, 03:02:26 PM

Previous topic - Next topic

Tux

Hi,

apart from 4 icons on the main toolbar, I don't see any menu bar with e.g. the File or Edit menu:
You cannot see attachments on this board.

I tried the .deb binary from the Ubuntu ppa repo, avidemux_2.8.0.appImage and avidemuxLinux_GLIBC_2.28_amd64_220207_1746.app but the menu bar is missing everywhere.

Any ideas?

Ubuntu 20.04.3 LTS
Display Manager: lightdm
Desktop Environment: xfce

Thanks
Chris

eumagga0x2a

Some Ubuntu own global menu stuff installed and messing with the menu?

Tux

Not that I'm aware of, I just installed updates regularly.


Tux

 :o

Ok, I installed xfce4-appmenu-plugin (which uninstalled unity-gtk2-module), vala-panel-appmenu and vala-panel-common but I still don't see the menu bar of avidemux.

I noticed that the menu bar is displayed when I switch to the standard Ubuntu window manager.

Tux

For some unknown reason, it works now :-)

Thanks a lot for your support!

eumagga0x2a

Quote from: Tux on February 20, 2022, 04:37:41 PMOk, I installed xfce4-appmenu-plugin (which uninstalled unity-gtk2-module)

Of course, I meant that neither xfce4-appmenu-plugin nor any other global menu implementation should be present. The command would just show whether the package is installed.

Tux

Ok, I "read" too fast and assumed that it has to be available.

Anyhow, both methods work now: if xfce4-appmenu-plugin is installed, the xfce4 indicator plugin crashes as soon as I start avidemux - but this can be fixed by hiding the Application Indicators (from the list of known indicators).

The other way, removing xfce4-appmenu-plugin (and unity-gtk2-module) works too.

Thanks a lot for your help!