2.7.4/5 Nvidia Codec always reports Cannot Setup Codec. Bitrate too low?

Started by Daemon42, December 13, 2019, 02:30:07 AM

Previous topic - Next topic


I've been using 2.7.1 for ages and it it talks to my NVIDIA GTX1080Ti card just fine. 
I select Nvidia H264 or HEVC, give it settings of High/High/30000/35000, and audio codec AAC Lav (128), MP4 Muxer
hit Save and it churns through 1440p rendering about 2-3x realtime. 

Upgraded to 2.7.5.   All the steps above are the same, but any attempt to Save
results in the popup "Cannot Setup Codec.  Bitrate too low?"   
Same error for Nvidia H264 and HEVC.    Works fine for software codecs like Mpeg4 AVC (x264) but that's not why I use AVIdemux.. 
I tried 2.7.4.  Same error.
Tried 2.7.5 nightly.  Same error.
Reverted to my saved copy of 2.7.1.  Still works fine. 

What am I missing?  Hardware rendering seems like a pretty fundamental thing to be broken. 


Works fine for me at least with the latest VC++ nightly (191296) on Windows 7 for encoding to H.264 using NVENC (no HEVC support in the graphics card), NVIDIA driver version at the moment: 436.30 441.66 (updated to the most current version, Nvidia H264 encoder works fine with it too).

What is NVIDIA driver version on your system?


It's Windows 10 with NVIDIA Driver Version: 388.13.   I ignore a lot of the "game ready" driver updates because I don't have any of those games, but I'll try upgrading and see if it works. 


Apparently that's it.  Interface to the driver must have changed somewhere along the way.
Updated to latest NVIDIA driver and it works now. 



This is actually a result of Avidemux using a pretty current FFmpeg which supports only a very current NVENC API which in turn requires a very current NVIDIA driver version.