Author Topic: Videokopie doch keine Kopie  (Read 459 times)

christian_2

  • Newbie
  • *
  • Posts: 3
Videokopie doch keine Kopie
« on: February 10, 2020, 05:35:24 PM »
Hallo,

ich möchte von einem Video einfach nur den Anfang wegschneiden.
Quelle: Panasinic HC-V777
Aufgenommen in PH 1080, also höchste Qualität.

Mit AVIdemux habe ich den Anfang weggeschnitten und habe bei Ton und Video 'Kopie' eingestellt (siehe Anhang).

Nach dem Speichern habe ich das Video mit VLC-Player abgespielt: Das Video ruckelt sehr stark. Mit dem MediaPlayer ruckelt das Video kaum, aber den mag ich nicht.
Was mich verwundert ist: ich hatte doch 'Kopie' eingestellt, weshalb ich davon ausging, dass auch eine Kopie erstellt wird. Also warum ruckelt der Zusammenschnitt, das Oroginal aber nicht?

Im VLC-Player habe ich mir die Codecs (Strg-J) angesehen.
Hier gibt es Unterschiede (siehe Anhang).

AVIdemux hat also offensichtlich doch keine Kopie erstellt. Was muss ich einstellen, um eine Kopie zu erhalten?

Vielen Dank schon mal im Voraus!
Christian

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 3799
Re: Videokopie doch keine Kopie
« Reply #1 on: February 10, 2020, 07:45:10 PM »
ich möchte von einem Video einfach nur den Anfang wegschneiden.
Quelle: Panasinic HC-V777
Aufgenommen in PH 1080, also höchste Qualität.

Mit AVIdemux habe ich den Anfang weggeschnitten und habe bei Ton und Video 'Kopie' eingestellt (siehe Anhang).

Nach dem Speichern habe ich das Video mit VLC-Player abgespielt: Das Video ruckelt sehr stark.

Auf was für einer Hardware? Manch eine betagte CPU ist mit 1080p@25fps überfordert, da muss unbedingt ein Hardware-Dekoder in der Grafikkarte mithelfen, um eine flüssige (real-time) Wiedergabe zu haben. Ist Hardware-Beschleunigung in VLC aktiviert?

Quote
Was mich verwundert ist: ich hatte doch 'Kopie' eingestellt, weshalb ich davon ausging, dass auch eine Kopie erstellt wird.

Ich gehe davon aus, dass die Streams (bis auf den Zuschnitt) unverändert sind. Nur der Container ist nun wahrscheinlich anders (die Quelle war bestimmt entweder MPEG-TS oder MP4).

Quote
Also warum ruckelt der Zusammenschnitt, das Oroginal aber nicht?

Ohne ein kurzes Sample-Video brauche ich mehr Kaffeesatz für eine Antwort, als ich vorrätig habe.

Quote
Im VLC-Player habe ich mir die Codecs (Strg-J) angesehen.
Hier gibt es Unterschiede (siehe Anhang).

Es ist besser MediaInfo zu verwenden, es gibt dann viel mehr relevante Details, aber die Infos zu relevanten Tracks sind im VLC zwischen dem Original-Video und der Ausgabe von Avidemux identisch. Avidemux unterstützt eben keine Untertitel-Tracks.

Quote
AVIdemux hat also offensichtlich doch keine Kopie erstellt.

Doch, mit an Sicherheit grenzender Wahrscheinlichkeit ist es eine Stream-Kopie.

Übrigens, auf dem Screenshot ist Avidemux so eingestellt, dass die CPU so hoch wie nur möglich belastet wird (Video-Anzeige ohne jegliche Unterstützung von der GPU beim Skalieren, Video-Dekodierung ebenfalls rein durch die CPU). Es empfiehlt sich, unter Windows DXVA2 als Video-Anzeige und DXVA2 als Video-Dekoder zu benutzen. Oder hat es damit Probleme gegeben?

P.S.: Ich würde außerdem empfehlen, statt des inzwischen veralteten Releases möglichst den neuesten Nightly Build zu verwenden.

christian_2

  • Newbie
  • *
  • Posts: 3
Re: Videokopie doch keine Kopie
« Reply #2 on: February 14, 2020, 03:24:49 PM »
Hallo,

erstmal herzlichen Dank für Deine ausführliche Antwort!
Zuerst einmal will ich Deine Fragen konkret beantworten:

ich möchte von einem Video einfach nur den Anfang wegschneiden.
Quelle: Panasinic HC-V777
Aufgenommen in PH 1080, also höchste Qualität.

Mit AVIdemux habe ich den Anfang weggeschnitten und habe bei Ton und Video 'Kopie' eingestellt (siehe Anhang).

Nach dem Speichern habe ich das Video mit VLC-Player abgespielt: Das Video ruckelt sehr stark.

Auf was für einer Hardware? Manch eine betagte CPU ist mit 1080p@25fps überfordert, da muss unbedingt ein Hardware-Dekoder in der Grafikkarte mithelfen, um eine flüssige (real-time) Wiedergabe zu haben. Ist Hardware-Beschleunigung in VLC aktiviert?

Ich hatte schon darüber nachgedacht, meine Hardware mit anzugeben. Aber nachdem das ungeschnittene Original-Video absolut flüssig wiedergegeben wird, ging ich davon aus, dass es nicht an der Hardware liegen kann.
Aber um Deine Frage noch zu beantworten:

Intel(R) Core(TM) i5-4570 CPU @ 3.20GHz, Rev. 15363
NVIDIA GeForce GTX 660 
8 GB Arbeitsspeicher
SSD-Festplatten

Was die Hardwarebeschleunigung angeht:
In VLC steht diese auf 'Auto' (siehe Anhang).
Das Umstellen bringt bei der Einstellung auf 'keine' eine leichte Verschlechterung. Ansonsten ist keine Einstellung besser, als 'Auto'.

Prinzipiell glaube ich auch, dass Einstellungen beim VLC nicht passen, weiß aber nicht, welche. Schließlich wird das geschnittene Video mit dem Mediaplayer ruckelfrei wiedergegeben. Ich habe also eigentlich zwei Probleme.
Einmal mit der geschnittenen Kopie und einmal mit dem VLC. Ich wollte im ersten Schritt probieren, das Problem im AVIDEMUX zu lösen, weshalb ich in diesem Forum geschrieben habe.
Quote

Quote
Was mich verwundert ist: ich hatte doch 'Kopie' eingestellt, weshalb ich davon ausging, dass auch eine Kopie erstellt wird.

Ich gehe davon aus, dass die Streams (bis auf den Zuschnitt) unverändert sind. Nur der Container ist nun wahrscheinlich anders (die Quelle war bestimmt entweder MPEG-TS oder MP4).

Kannst Du mir sagen, wie ich herausfinden kann, was für eine Quelle ich hatte?
Quote

Quote
Also warum ruckelt der Zusammenschnitt, das Oroginal aber nicht?

Ohne ein kurzes Sample-Video brauche ich mehr Kaffeesatz für eine Antwort, als ich vorrätig habe.

Hier gibt es folgende Probleme: Das Original ist viel zu groß zum Hochladen. Deshalb habe ich jetzt erst noch einmal ein kurzes Video gemacht, das ich dann geschnitten habe.
Allerdings ist dieses Original auch schon 60 MB groß und das geschnittene Video 30 MB.
Wo kann ich die Videos hochladen? Als Anhang gehen ja maximal 192 kB.
Quote


Quote
Im VLC-Player habe ich mir die Codecs (Strg-J) angesehen.
Hier gibt es Unterschiede (siehe Anhang).

Es ist besser MediaInfo zu verwenden, es gibt dann viel mehr relevante Details, aber die Infos zu relevanten Tracks sind im VLC zwischen dem Original-Video und der Ausgabe von Avidemux identisch. Avidemux unterstützt eben keine Untertitel-Tracks.

OK. Mediainfo habe ich installiert. Die Ergebnisse findest Du im Anhang. Daraus werde ich leider nicht schlau.
Quote


Quote
AVIdemux hat also offensichtlich doch keine Kopie erstellt.

Doch, mit an Sicherheit grenzender Wahrscheinlichkeit ist es eine Stream-Kopie.

Übrigens, auf dem Screenshot ist Avidemux so eingestellt, dass die CPU so hoch wie nur möglich belastet wird (Video-Anzeige ohne jegliche Unterstützung von der GPU beim Skalieren, Video-Dekodierung ebenfalls rein durch die CPU). Es empfiehlt sich, unter Windows DXVA2 als Video-Anzeige und DXVA2 als Video-Dekoder zu benutzen. Oder hat es damit Probleme gegeben?


Als erstes frage ich mich, woran Du das erkennst, dass Avidemux so eingestellt ist?
Und die zweite Frage ist, wie ich das unter Windows umstellen kann. Ich habe davon leider keine Ahnung, dass sind meine ersten Gehversuche zum Thema Video. Google brachte auch nichts.
Und vielleicht noch eine allgemeine Frage: Gibt es irgendwo eine gute Seite, wo man sich die grundlegenden Dinge zum Thema Videoschneiden durchlesen kann? Ganz offensichtlich habe ich ja erhebliche Wissenlücken und ich möchte nicht alles nachfragen müssen, sondern mich auch etwas tiefer in die Materie einlesen. Man will ja nicht dumm sterben ;-)
Quote

P.S.: Ich würde außerdem empfehlen, statt des inzwischen veralteten Releases möglichst den neuesten Nightly Build zu verwenden.

Das habe ich probiert. Ich habe die Version
avidemux_2.7.5 r200207_win64
heruntergeladen und installiert. Leider hat diese aber nicht funktioniert. Egal, wie lange das Video war, ich bekam beim Speichern eines geschnittenen Videos die Meldung, dass das Video zu kurz wäre, weshalb ich diese Version wieder deinstalliert und dann Avidemux_2.7.5VC++64bits wieder installiert habe.

Kannst Du mir bitte noch einmal helfen?

Viele Grüße
Christian

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 3799
Re: Videokopie doch keine Kopie
« Reply #3 on: February 14, 2020, 05:33:20 PM »
Die Hardware ist sehr leistungsfähig, daran liegt es nicht.

MediaInfo bietet auch reine Textausgabe an, sodass man keine Screenshots posten muss. Laut MediaInfo ist MPEG-TS ("BDAV") der Original-Container.

Um Samples bereitzustellen, bitte WeTransfer, Mega, Dropbox oder Google Drive verwenden (oder einen vergleichbaren Service, wobei sich die o.g. gut bewährt haben). Bitte beachte, dass für WeTransfer keine E-Mail-Adresse angegeben werden muss, obgleich die Gestaltung der Webseite auf den ersten flüchtigen Blick das Gegenteil suggeriert.

Wie die Fehlermeldung des Nightly sagt, das Problem besteht wahrscheinlich in falschen oder ungültigen Zeitstempeln im Videostream oder an einem Bug in Avidemux beim Handhaben von MPEG-TS, der in falschen Zeitstempeln (DTS und PTS) von Frames im Video mündet. Dies würde auch die Probleme bei der Wiedergabe des von Avidemux gespeicherten Video erklären. Ob HW-Beschleunigung in VLC bei der Dekodierung mithilft oder nicht, ist in diesem Fall unbedeutend.

Mehr Hinweise würde das Lesen des Avidemux-Logs (admlog.txt aus %localappdata%\avidemux\) liefern.

Quote
Als erstes frage ich mich, woran Du das erkennst, dass Avidemux so eingestellt ist?

Was den Video-Dekoder und die verwendete Video-Anzeige angeht, sieht man in Deinem ersten Screenshot unter der Überschrift "Video-Decoder" links den Decoder ("Lavcodec") und rechts die Video-Anzeige ("RGB"). Mit Hardware-beschleunigten Dekodierung stünde dort links "DXVA2" und mit Hardware-beschleunigter Anzeige rechts ebenfalls "DXVA2" (einfach "DirectX" wäre als Bezeichnung zutreffender, aber egal).

Beides sind Einstellungen von Avidemux ("Bearbeiten" / "Einstellungen" / "Darstellung" sowie "HW-Beschleunigung"), nicht von Windows.

Quote
Gibt es irgendwo eine gute Seite, wo man sich die grundlegenden Dinge zum Thema Videoschneiden durchlesen kann?

Eine schwierige Frage. Ich kenne keine bestimmte, aber mit einem Mix aus Wikipedia, Avidemux Wiki (Vorsicht, extrem veraltet!) und "learning by doing" kann man, glaube ich, einiges erreichen.

christian_3

  • Newbie
  • *
  • Posts: 2
Re: Videokopie doch keine Kopie
« Reply #4 on: February 16, 2020, 08:52:28 AM »
Jetzt habe ich mich noch einmal unter einem neuen Namen angemeldet, weil es ständig Probleme beim Posten kam. Zuerst hieß es, ich solle JavaScript einschalten (ist bei mir aber eingeschaltet) und dann hieß es, den Post hätte ich schon verschickt (war aber nicht so). Dann sollte ich immer ein paar Minuten warten, so dass ich ewig hier rumsaß. Nach dem Warten habe ich es dann nochmal probiert. Dann kam wieder die Meldung, ich hätte den Post schon veröffentlicht.
Deshalb jetzt unter dem neuen Namen und erstmal ohne Anhang...

Die Hardware ist sehr leistungsfähig, daran liegt es nicht.

MediaInfo bietet auch reine Textausgabe an, sodass man keine Screenshots posten muss.

Im Anhang habe ich die zwei Dateien noch angehängt (in der gezippten Datei). Vielleicht bieten sie ja noch weitere Informationen zur Problemlösung

Quote

Laut MediaInfo ist MPEG-TS ("BDAV") der Original-Container.

Um Samples bereitzustellen, bitte WeTransfer, Mega, Dropbox oder Google Drive verwenden (oder einen vergleichbaren Service, wobei sich die o.g. gut bewährt haben). Bitte beachte, dass für WeTransfer keine E-Mail-Adresse angegeben werden muss, obgleich die Gestaltung der Webseite auf den ersten flüchtigen Blick das Gegenteil suggeriert.

Wie die Fehlermeldung des Nightly sagt, das Problem besteht wahrscheinlich in falschen oder ungültigen Zeitstempeln im Videostream oder an einem Bug in Avidemux beim Handhaben von MPEG-TS, der in falschen Zeitstempeln (DTS und PTS) von Frames im Video mündet. Dies würde auch die Probleme bei der Wiedergabe des von Avidemux gespeicherten Video erklären. Ob HW-Beschleunigung in VLC bei der Dekodierung mithilft oder nicht, ist in diesem Fall unbedeutend.

Mehr Hinweise würde das Lesen des Avidemux-Logs (admlog.txt aus %localappdata%\avidemux\) liefern.


siehe Anhang

Quote

Quote
Als erstes frage ich mich, woran Du das erkennst, dass Avidemux so eingestellt ist?

Was den Video-Dekoder und die verwendete Video-Anzeige angeht, sieht man in Deinem ersten Screenshot unter der Überschrift "Video-Decoder" links den Decoder ("Lavcodec") und rechts die Video-Anzeige ("RGB"). Mit Hardware-beschleunigten Dekodierung stünde dort links "DXVA2" und mit Hardware-beschleunigter Anzeige rechts ebenfalls "DXVA2" (einfach "DirectX" wäre als Bezeichnung zutreffender, aber egal).

Beides sind Einstellungen von Avidemux ("Bearbeiten" / "Einstellungen" / "Darstellung" sowie "HW-Beschleunigung"), nicht von Windows.


Danke, wieder was gelernt.
Ich habe mit den Einstellung ein bisschen rumgespielt. Ich hatte nicht den Eindruck, dass irgendetwas schneller geworden wäre, weshalb ich jetzt wieder die ursprünglichen Einstellungen verwende (ohne Hardwarebeschleunigung). Überhaupt, empfinde ich das Programm als äußert schnell beim Umgang.

Quote

Quote
Gibt es irgendwo eine gute Seite, wo man sich die grundlegenden Dinge zum Thema Videoschneiden durchlesen kann?

Eine schwierige Frage. Ich kenne keine bestimmte, aber mit einem Mix aus Wikipedia, Avidemux Wiki (Vorsicht, extrem veraltet!) und "learning by doing" kann man, glaube ich, einiges erreichen.


Danke für den Tipp.
Ich habe mich jetzt mal insgesamt etwas eingelesen.

Vielleicht noch einmal zu meinem eigentlichen Ziel: Ich möchte Hochzeitsvideos zusammenschneiden. Da ich keinen Qualitätsverlust haben wollte, habe ich die Einstellungen 'kopieren' gewählt. Prinzipiell hätte ich aber natürlich nichts gegen eine Kopression, allerdings waren die Ergebnisse immer sehr viel  schlechter, als das Original. Aber wie ich jetzt herausgefunden habe, hatte das andere Gründe, als ich ursprünglich dachte.
Nachdem ich jetzt aber über Videos etwas mehr weiß, habe ich verstanden, was da offensichtlich passiert. Ich glaube, meine Kamera speichert im Video Halbbilder, wobei ein Halbbild offensichtlich aus jeder zweiten Zeile besteht (ich hoffe, ich habe das richtig verstanden).
Nun ist es so, dass beim Konvertieren mit AVIDEMUX die Halbbilder bei schnellen Bewegungen vertikal verschoben sind. Ich habe viel im Internet gesucht, wie man dieses Phänomen nennt, aber leider nichts gefunden. Es ist keine 'Bewegungsunschärfe', wie ich ursprünglich dachte.

Interessant ist auch folgendes:
Diese verschobenen Halbbilder kann man bei AVIDEMUX wahrscheinlich schon beim eingelesenen Originalvideo sehen. Mir war das ursprünglich gar nicht aufgefallen, weil das Bildfenster in AVIDEMUX bei meiner Auflösung nicht so groß ist. Wie das aussieht, siehe Anhang 'Bild1 - AVIDEMUX-Original.jpg'.
Im VLC sieht das Originalvideo anders aus 'Bild2 - Wiedergabe Original im MediaPlayer.jpg' (viel besser).
Für den MediaPlayer gild das gleiche 'Bild3 - Wiedergabe Original im VLC.jpg'. Es sieht viel besser aus.

Interessant ist, dass wenn ich nun ein Video mit AVIDEMUX schneide (Einstellung Kopie) und mir ein Standbild im VLC ansehe, dann sieht das Standbild sehr gut aus: 'Bild4 - Wiedergabe im VLC geschnitten Kopie.jpg'. Allerdings ruckelt jetzt das Video sehr stark.
Im Mediaplayer ruckelt das Video nicht. Das Standbild sieht dann so aus: 'Bild5 - Wiedergabe im MediaPlayer geschnitten Kopie.jpg'. Man sieht, dass die Farbe in den bewegten Bildteilen nicht mehr stimmt, was aber kaum auffällt. Mit so einer Qualität wäre ich schon zufrieden.


Um diese Probleme zu umgehen, habe ich probiert, das Video in ein Format zu konvertieren, das eine hohe Bildqualität liefert. Weil ich von Videoformaten bisher keine Ahnung hatte, habe ich mich ein bisschen eingelesen und bin auf diese Seite gestossen: https://www.nrwision.de/mitmachen/wissen/videoformate-vergleich/. Ich kam dann zu der Erkenntnis, dass für mein Vorhaben MPEG-4 (mp4), MKV und HTML5 geeignet sind. Stimmst Du da zu?

Das Resultat bei meinen bisherigen Versuchen war immer gleich (verschobene Halbbilder). Beim Videoerstellen habe ich die Originaldatei geladen, dann geschnitten und dann z. B. in der Einstellungen Mpeg4 AVC (x264) in AVIDEMUX gespeichert.

Die Videos sehen sowohl im VLC, als auch im Mediaplayer einfach nur grausam aus, weil sich bei Bewegungen ständig die Halbbilder z. T. extrem verschieben:
Bild6 - Wiedergabe im VLC geschnitten Mpeg4.jpg
Bild7 - Wiedergabe im Mediaplayer geschnitten Mpeg4.jpg

So kann man die Videos kaum anschauen.

Zusammengefasst:
Ich habe jetzt nicht mehr das Ziel, eine geschnittene Kopie im VLC ansehen zu können. Mein Ziel ist jetzt, dass ich das Video schneide und konvertiere, weil die Videos dadurch doch deutlich kleiner werden.
Aber offensichtlich habe ich noch nicht die richtigen Einstellungen gefunden. Für Mpeg4 AVC (x264) gibt es ja sehr viele Einstellungsmöglichkeiten von denen ich bisher noch keine Ahnung habe. Hast Du eine Idee, was ich einstellen muss, um mein Problem mit den verschobenen Halbbildern zu lösen? Kennst Du den Fachbegriff für dieses Phänomen, so dass ich danach googeln kann? Und ist Mpeg4 AVC (x264) überhaupt das geeignete Format, um die beste Qualität zu erhalten?

Solltest Du doch noch ein Video benötigen, so werde ich noch eines Anfertigen und hochladen. Die Hochzeitsvideos kann ich nicht nehmen, weil da Personen drauf sind, die einer Veröffentlichung vielleicht nicht zustimmen würden. Vielleicht kann man das Problem mit den neuen Informationen lösen.

Viele Grüße
Christian


Die Hardware ist sehr leistungsfähig, daran liegt es nicht.

MediaInfo bietet auch reine Textausgabe an, sodass man keine Screenshots posten muss.

Im Anhang habe ich die zwei Dateien noch angehängt. Vielleicht bieten sie ja noch weitere Informationen zur Problemlösung

Quote




Laut MediaInfo ist MPEG-TS ("BDAV") der Original-Container.

Um Samples bereitzustellen, bitte WeTransfer, Mega, Dropbox oder Google Drive verwenden (oder einen vergleichbaren Service, wobei sich die o.g. gut bewährt haben). Bitte beachte, dass für WeTransfer keine E-Mail-Adresse angegeben werden muss, obgleich die Gestaltung der Webseite auf den ersten flüchtigen Blick das Gegenteil suggeriert.

Wie die Fehlermeldung des Nightly sagt, das Problem besteht wahrscheinlich in falschen oder ungültigen Zeitstempeln im Videostream oder an einem Bug in Avidemux beim Handhaben von MPEG-TS, der in falschen Zeitstempeln (DTS und PTS) von Frames im Video mündet. Dies würde auch die Probleme bei der Wiedergabe des von Avidemux gespeicherten Video erklären. Ob HW-Beschleunigung in VLC bei der Dekodierung mithilft oder nicht, ist in diesem Fall unbedeutend.

Mehr Hinweise würde das Lesen des Avidemux-Logs (admlog.txt aus %localappdata%\avidemux\) liefern.


siehe Anhang

Quote

Quote
Als erstes frage ich mich, woran Du das erkennst, dass Avidemux so eingestellt ist?

Was den Video-Dekoder und die verwendete Video-Anzeige angeht, sieht man in Deinem ersten Screenshot unter der Überschrift "Video-Decoder" links den Decoder ("Lavcodec") und rechts die Video-Anzeige ("RGB"). Mit Hardware-beschleunigten Dekodierung stünde dort links "DXVA2" und mit Hardware-beschleunigter Anzeige rechts ebenfalls "DXVA2" (einfach "DirectX" wäre als Bezeichnung zutreffender, aber egal).

Beides sind Einstellungen von Avidemux ("Bearbeiten" / "Einstellungen" / "Darstellung" sowie "HW-Beschleunigung"), nicht von Windows.


Danke, wieder was gelernt.
Ich habe mit den Einstellung ein bisschen rumgespielt. Ich hatte nicht den Eindruck, dass irgendetwas schneller geworden wäre, weshalb ich jetzt wieder die ursprünglichen Einstellungen verwende (ohne Hardwarebeschleunigung). Überhaupt, empfinde ich das Programm als äußert schnell beim Umgang.

Quote

Quote
Gibt es irgendwo eine gute Seite, wo man sich die grundlegenden Dinge zum Thema Videoschneiden durchlesen kann?

Eine schwierige Frage. Ich kenne keine bestimmte, aber mit einem Mix aus Wikipedia, Avidemux Wiki (Vorsicht, extrem veraltet!) und "learning by doing" kann man, glaube ich, einiges erreichen.


Danke für den Tipp.
Ich habe mich jetzt mal insgesamt etwas eingelesen.

Vielleicht noch einmal zu meinem eigentlichen Ziel: Ich möchte Hochzeitsvideos zusammenschneiden. Da ich keinen Qualitätsverlust haben wollte, habe ich die Einstellungen 'kopieren' gewählt. Prinzipiell hätte ich aber natürlich nichts gegen eine Kopression, allerdings waren die Ergebnisse immer sehr viel  schlechter, als das Original. Aber wie ich jetzt herausgefunden habe, hatte das andere Gründe, als ich ursprünglich dachte.
Nachdem ich jetzt aber über Videos etwas mehr weiß, habe ich verstanden, was da offensichtlich passiert. Ich glaube, meine Kamera speichert im Video Halbbilder, wobei ein Halbbild offensichtlich aus jeder zweiten Zeile besteht (ich hoffe, ich habe das richtig verstanden).
Nun ist es so, dass beim Konvertieren mit AVIDEMUX die Halbbilder bei schnellen Bewegungen vertikal verschoben sind. Ich habe viel im Internet gesucht, wie man dieses Phänomen nennt, aber leider nichts gefunden. Es ist keine 'Bewegungsunschärfe', wie ich ursprünglich dachte.

Interessant ist auch folgendes:
Diese verschobenen Halbbilder kann man bei AVIDEMUX wahrscheinlich schon beim eingelesenen Originalvideo sehen. Mir war das ursprünglich gar nicht aufgefallen, weil das Bildfenster in AVIDEMUX bei meiner Auflösung nicht so groß ist. Wie das aussieht, siehe Anhang 'Bild1 - AVIDEMUX-Original.jpg'.
Im VLC sieht das Originalvideo anders aus 'Bild2 - Wiedergabe Original im MediaPlayer.jpg' (viel besser).
Für den MediaPlayer gild das gleiche 'Bild3 - Wiedergabe Original im VLC.jpg'. Es sieht viel besser aus.

Interessant ist, dass wenn ich nun ein Video mit AVIDEMUX schneide (Einstellung Kopie) und mir ein Standbild im VLC ansehe, dann sieht das Standbild sehr gut aus: 'Bild4 - Wiedergabe im VLC geschnitten Kopie.jpg'. Allerdings ruckelt jetzt das Video sehr stark.
Im Mediaplayer ruckelt das Video nicht. Das Standbild sieht dann so aus: 'Bild5 - Wiedergabe im MediaPlayer geschnitten Kopie.jpg'. Man sieht, dass die Farbe in den bewegten Bildteilen nicht mehr stimmt, was aber kaum auffällt. Mit so einer Qualität wäre ich schon zufrieden.


Um diese Probleme zu umgehen, habe ich probiert, das Video in ein Format zu konvertieren, das eine hohe Bildqualität liefert. Weil ich von Videoformaten bisher keine Ahnung hatte, habe ich mich ein bisschen eingelesen und bin auf diese Seite gestossen: https://www.nrwision.de/mitmachen/wissen/videoformate-vergleich/. Ich kam dann zu der Erkenntnis, dass für mein Vorhaben MPEG-4 (mp4), MKV und HTML5 geeignet sind. Stimmst Du da zu?

Das Resultat bei meinen bisherigen Versuchen war immer gleich (verschobene Halbbilder). Beim Videoerstellen habe ich die Originaldatei geladen, dann geschnitten und dann z. B. in der Einstellungen Mpeg4 AVC (x264) in AVIDEMUX gespeichert.

Die Videos sehen sowohl im VLC, als auch im Mediaplayer einfach nur grausam aus, weil sich bei Bewegungen ständig die Halbbilder z. T. extrem verschieben:
Bild6 - Wiedergabe im VLC geschnitten Mpeg4.jpg
Bild7 - Wiedergabe im Mediaplayer geschnitten Mpeg4.jpg

So kann man die Videos kaum anschauen.

Zusammengefasst:
Ich habe jetzt nicht mehr das Ziel, eine geschnittene Kopie im VLC ansehen zu können. Mein Ziel ist jetzt, dass ich das Video schneide und konvertiere, weil die Videos dadurch doch deutlich kleiner werden.
Aber offensichtlich habe ich noch nicht die richtigen Einstellungen gefunden. Für Mpeg4 AVC (x264) gibt es ja sehr viele Einstellungsmöglichkeiten von denen ich bisher noch keine Ahnung habe. Hast Du eine Idee, was ich einstellen muss, um mein Problem mit den verschobenen Halbbildern zu lösen? Kennst Du den Fachbegriff für dieses Phänomen, so dass ich danach googeln kann? Und ist Mpeg4 AVC (x264) überhaupt das geeignete Format, um die beste Qualität zu erhalten?

Solltest Du doch noch ein Video benötigen, so werde ich noch eines Anfertigen und hochladen. Die Hochzeitsvideos kann ich nicht nehmen, weil da Personen drauf sind, die einer Veröffentlichung vielleicht nicht zustimmen würden. Vielleicht kann man das Problem mit den neuen Informationen lösen.

Viele Grüße
Christian

PS: ich hatte Probleme beim Senden. Ich sollte JavaScript einschalten (war aber eingeschaltet). Ich habe die Dateianhänge mal weggelassen. Die hänge ich im nächsten Post an.



christian_3

  • Newbie
  • *
  • Posts: 2
Re: Videokopie doch keine Kopie
« Reply #5 on: February 16, 2020, 08:53:15 AM »
jetzt der Anhang als zip-Datei

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 3799
Re: Videokopie doch keine Kopie
« Reply #6 on: February 16, 2020, 11:02:04 AM »
Quote
Jetzt habe ich mich noch einmal unter einem neuen Namen angemeldet, weil es ständig Probleme beim Posten kam.

Der Antispam-Dienst CleanTalk produziert leider massig falsche Treffer, die Infos mit einer privaten Nachricht zu schicken wäre die richtige Ausweichlösung gewesen (manchmal hilft es, den Browser-Cache zu leeren und die IP-Adresse zu wechseln). Ich habe zwar keinen Einfluss auf CleanTalk, aber wir wären schon längst weitergekommen.

Das Original-Video ist interlaced und muss daher beim Neukodieren durch das Hinzufügen eines Deinterlacing-Filters (Yadif) in progressive umgewandelt werden, entweder bei 25 fps oder mit der doppelten Rate von 50 fps (also mit der frequenz von Fields, von Halbbildern), was die Größe des neu kodierten Videos entsprechend erhöht, dafür aber für flussigere Bewegungen im Bild sorgt.

Laut admlog.txt fehlen im Original-Video bei sehr vielen Frames (die in Wirklichkeit Fields, also Halbbilder sind) Zeitstempel, aber das Hauptproblem ist, dass wir für field-encoded Video (in einem interlaced Video können Halbbilder entweder zusammen in einem einzigen Paket / Frame zusammengefasst oder getrennt in zwei Paketen / Frames vorkommen, Avidemux macht da keinen Unterschied, für das Programm zählen nur Frames) die Bildwiederholrate für erfoglreiches Kopieren des Video-Streams verdoppeln müssen. Das kann Avidemux in der Art von einem Hack für MPEG-2, nicht aber für andere Codecs. Das Ergebnis sind kollidierende Zeitstempel, die die ältere Version von Avidemux (der 2.7.5 Release) noch im Muxer zu entschärfen versucht, was für ein heilloses Durcheinander sorgt. Diese wenig hilfreiche Logik wurde später entfernt, weswegen der Nightly gleich ehrlich das Speichern abbricht.

Damit ich schauen kann, ob dies leicht genug zu korrigieren ist, wäre ein Sample unerlässlich (wenige Minuten lang reicht völlig aus), danke.

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 3799
Re: Videokopie doch keine Kopie
« Reply #7 on: February 16, 2020, 11:44:29 AM »
Nachtrag:

Quote
Ich habe mit den Einstellung ein bisschen rumgespielt. Ich hatte nicht den Eindruck, dass irgendetwas schneller geworden wäre, weshalb ich jetzt wieder die ursprünglichen Einstellungen verwende (ohne Hardwarebeschleunigung).

Es geht nicht um die Schnelligkeit (die CPU ist bärenstark und schafft das dekodieren von H.264 1080i sowie das Skalieren der Ausgabe in Echtzeit) sondern um das Vermeiden von sinnloser Energieverschwendung. Denk an die Umwelt  :)

Quote
Um diese Probleme zu umgehen, habe ich probiert, das Video in ein Format zu konvertieren, das eine hohe Bildqualität liefert. Weil ich von Videoformaten bisher keine Ahnung hatte, habe ich mich ein bisschen eingelesen und bin auf diese Seite gestossen: https://www.nrwision.de/mitmachen/wissen/videoformate-vergleich/. Ich kam dann zu der Erkenntnis, dass für mein Vorhaben MPEG-4 (mp4), MKV und HTML5 geeignet sind. Stimmst Du da zu?

Format (der Container) hat mit Bildqualität nichts zu tun. Jedoch sind manche Formate (namentlich AVI) mit modernen Codecs (H.264, HEVC, VP9, AV1), die man verwendet, um hohe Bildqualität trotz geringer Datenrate zu erreichen, nicht kompatibel. Mit MP4 bei Verwendung eines aktuellen Nightly machst Du nichts falsch. Die Wahl des Codecs hängt vom Verwendungszweck ab, sprich, welche Ausrüstung (Hardware und Software) das Ergebnis abspielen soll.

Kopiermodus für das Video vermeidet Qualitätsverluste, aber dafür müsste wohl Avidemux seinen Umgang mit interlaced H.264 verbessern. Außerdem kann man dann nur an Keyframes schneiden.

Übrigens, was Kopiermodus angeht, steht in der zum Video gehörenden Index-Datei (.idx2) "Fps=25000"? Ändere das bitte bei geschlossenem Video in

Code: [Select]
Fps=50000
mit einem Texteditor, der Unix-Zeilenenden unterstützt. Vielleicht reicht das, um Kopiermodus für dieses Video zu ermöglichen.

christian_2

  • Newbie
  • *
  • Posts: 3
Re: Videokopie doch keine Kopie
« Reply #8 on: February 17, 2020, 03:55:42 PM »

Jetzt habe ich mal eine Videodatei erstellt, bei der man das Verschieben einer jeden zweiten Zeile gut sehen kann:
https://www.transfernow.net/ddl/christian_2

Die Zipdatei enthält zwei Videos. 00023.mts ist das Originalvideo.
00023-1.mts ist das gleiche Video komprimiert.
Bei dieser Datei sieht man sehr schön, dass es wieder zu einer Verschiebung kommt.


Das mit
Code: [Select]
Fps=50000
probiere ich heute Abend auch noch aus und berichte dann.

Viele Grüße
Christian

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 3799
Re: Videokopie doch keine Kopie
« Reply #9 on: February 17, 2020, 05:30:41 PM »
Danke für das Sample. Die MKV-Datei wurde ohne Yadif erstellt – klar, dass das Video Kammartefakte zeigt.

Fps in .idx2 auf 50000 zu verdoppeln braucht noch einen kleinen Avidemux-Patch zum Erfolg (wir dürfen "early B-frames", die Halbbilder sind, niemals einzeln auslassen, selbst dann wenn kein anderes Halbbild es zur eigenen Dekodierung braucht).

Yadif bitte bei der Ausgabe von Frames belassen, die Ausgabe von Fields benötigt zumindest im aktuellen Avidemux (aktuell = Nightly) einen Patch, um time base für das Video entsprechend anzupassen.

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 3799
Re: Videokopie doch keine Kopie
« Reply #10 on: February 17, 2020, 05:43:43 PM »
Noch ein wichtiger Hinweis: selbst mit gepatchtem Yadif muss im Moment die Reihenfolge der Fields auf "Bottom field first" gestellt werden, sonst ist die Abfolge der Bilder falsch.

Ein Hinweis zum Hinweis: wenn das Video (deinterlaced von Yadif) neu kodiert werden soll, bitte Fps in .idx2 bei 25000 belassen.
« Last Edit: February 17, 2020, 05:47:12 PM by eumagga0x2a »

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 3799
Re: Videokopie doch keine Kopie
« Reply #11 on: March 13, 2020, 11:13:56 AM »
Neue Avidemux-Nightlies sind nun verfügbar, die besser mit solchen field-encoded Streams in MPEG-TS (und für MPEG-2 in MPEG-PS) umgehen können (sollen), gleichermaßen ob die Videos im Kopiermodus geschnitten oder gefiltert neu kodiert werden.

Eine Einschränkung vorweg: für die Erkennung ob das Video frame- oder field-encoded ist, ist der jeweilige Demuxer zuständig. Dies ist bislang nur im MpegTS und MpegPS Demuxer implementiert worden, d. h. MPEG-TS kann im Kopiermodus als MP4 oder MKV gespeichert werden, aber die so erstellte Datei, anderweitig einwandfrei zum Abspielen geeignet, wird von Avidemux noch nicht korrekt weiterverarbeitet.

Ebenso wurde an der anscheinend verkehrten Auswertung der Einstellung zur Reihenfolge der Halbbilder im Yadif-Filter noch nichts verändert (dafür funktioniert endlich die Navigation im Filter-Vorschau, wenn Yadif für jedes Halbbild ein volles Bild ausgibt).

Windows 64-Bit MinGW (r200312, beide Builds mit diesem Datum sind von demselben Code-Stand erstellt worden)
Linux 64-Bit appImage
macOS (sollte nun bis hin zu High Sierra abwärtskompatibel sein)

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 3799
Re: Videokopie doch keine Kopie
« Reply #12 on: March 13, 2020, 11:31:35 PM »
Eine Einschränkung vorweg: für die Erkennung ob das Video frame- oder field-encoded ist, ist der jeweilige Demuxer zuständig. Dies ist bislang nur im MpegTS und MpegPS Demuxer implementiert worden, d. h. MPEG-TS kann im Kopiermodus als MP4 oder MKV gespeichert werden, aber die so erstellte Datei, anderweitig einwandfrei zum Abspielen geeignet, wird von Avidemux noch nicht korrekt weiterverarbeitet.

Die Abhilfe ist denkbar einfach: den Filter "Resample" auf die erste Stelle setzen und als "Modus" die echte Framerate auswählen (bei 50 Halbbildern pro Sekunde also "25 (PAL)").

Im Kopiermodus muss gar nichts extra gemacht werden, da es beim Kopiermodus keine Rolle spielt, ob es nun Fields oder Frames sind.

Quote
Ebenso wurde an der anscheinend verkehrten Auswertung der Einstellung zur Reihenfolge der Halbbilder im Yadif-Filter noch nichts verändert [...]

Die Konfiguration von Yadif wurde im Zuge des Umstiegs auf die dem FFmpeg entnommene Variante im April 2019 verändert ohne ihre Interpretation in der wichtigsten Funktion getNextFrame() anzupassen. Dies ist nun im Code korrigiert.