Author Topic: Help for script & Debian 9 Compile.  (Read 787 times)

liberodark

  • Newbie
  • *
  • Posts: 10
Re: Help for script & Debian 9 Compile.
« Reply #15 on: May 30, 2020, 02:25:51 PM »
Have see error the new version of avidemux-cli have change audio codec name.
You have list of new codec name ?
im not sure probably need more tests now have error in convertion files
« Last Edit: May 30, 2020, 02:34:57 PM by liberodark »

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 4081
Re: Help for script & Debian 9 Compile.
« Reply #16 on: May 30, 2020, 02:50:41 PM »
You haven't posted the error.

Encoder names haven't changed. If a particular encoder is not found, the plugin is likely missing completely, e.g. because it hasn't been built in the first place due to headers not installed.
« Last Edit: May 30, 2020, 02:53:15 PM by eumagga0x2a »

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 4081
Re: Help for script & Debian 9 Compile.
« Reply #17 on: May 30, 2020, 02:56:45 PM »
For fdk_aac encoder plugin being available you need libfdk-aac-dev to be installed in the build environment and libfdk-aac1 package installed in the system where Avidemux is run.

liberodark

  • Newbie
  • *
  • Posts: 10
Re: Help for script & Debian 9 Compile.
« Reply #18 on: May 30, 2020, 03:50:05 PM »
This is my error log.

And im retry to rebuild packages with lib of fdk_aac
have what is lib for encoders ?
Have run first : createDebFromSourceUbuntu.bash but im not sure have install all libs.

My goal is to make same as :

Code: [Select]
ffmpeg -nostdin -i "$file" -vcodec h264 -acodec aac -strict -2 "${file%.*}.mp4
But more faster ffmpeg is too long for convert files in mp4 with aac

Have rebuild with aac libs but and reinstall all deb.
But is same is not converting correctly.
« Last Edit: May 30, 2020, 04:06:44 PM by liberodark »

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 4081
Re: Help for script & Debian 9 Compile.
« Reply #19 on: May 30, 2020, 06:04:54 PM »
Quote
Code: [Select]
[ADM_ae_plugin] Scanning directory /usr/lib/ADM_plugins6/audioEncoders
[AudioEncoder] Loaded PCM version 01.00.00 wavTag :0x1
[AudioEncoder] Registered filter /usr/lib/ADM_plugins6/audioEncoders/libADM_ae_pcm.so as  PCM encoder plugin Mean 2008
[AudioEncoder] Loaded Opus version 01.00.00 wavTag :0x26ae
[AudioEncoder] Registered filter /usr/lib/ADM_plugins6/audioEncoders/libADM_ae_opus.so as  Opus encoder plugin Mean 2017
[AudioEncoder] Loaded LavAC3 version 01.00.00 wavTag :0x2000
[AudioEncoder] Registered filter /usr/lib/ADM_plugins6/audioEncoders/libADM_ae_lav_ac3.so as  AC3 LavCodec encoder plugin Mean 2008/2009
[AudioEncoder] Loaded LavAAC version 01.00.00 wavTag :0xff
[AudioEncoder] Registered filter /usr/lib/ADM_plugins6/audioEncoders/libADM_ae_lav_aac.so as  AAC LavCodec encoder plugin Mean 2008/2016
[AudioEncoder] Loaded Vorbis version 01.00.00 wavTag :0x676f
[AudioEncoder] Registered filter /usr/lib/ADM_plugins6/audioEncoders/libADM_ae_vorbis.so as  Vorbis encoder plugin Mean 2008
Unable to load [/usr/lib/ADM_plugins6/audioEncoders/libADM_ae_aften.so]: libaften.so.0: cannot open shared object file: No such file or directory
Symbol loading failed for /usr/lib/ADM_plugins6/audioEncoders/libADM_ae_aften.so
/usr/lib/ADM_plugins6/audioEncoders/libADM_ae_aften.so:CannotLoad
[AudioEncoder] Loaded Lame version 01.00.00 wavTag :0x55
[AudioEncoder] Registered filter /usr/lib/ADM_plugins6/audioEncoders/libADM_ae_lame.so as  Lame MP3 encoder plugin Mean 2009
[AudioEncoder] Loaded Faac version 01.00.00 wavTag :0xff
[AudioEncoder] Registered filter /usr/lib/ADM_plugins6/audioEncoders/libADM_ae_faac.so as  Faac AAC encoder plugin Mean 2008
[AudioEncoder] Loaded LavMP2 version 01.00.00 wavTag :0x50
[AudioEncoder] Registered filter /usr/lib/ADM_plugins6/audioEncoders/libADM_ae_lav_mp2.so as  MP2 LavCodec encoder plugin Mean 2008/2009
[ADM_ae_plugin] Scanning done

No plugin fdk_aac plugin built, you should check the build log from a full build why fdk_aac was not found despite headers and lib installed.

Aften plugin has been built, but library is not installed.

My goal is to make same as :

Code: [Select]
ffmpeg -nostdin -i "$file" -vcodec h264 -acodec aac -strict -2 "${file%.*}.mp4
But more faster ffmpeg is too long for convert files in mp4 with aac

"h264" in ffmpeg would invoke the same x264 encoder as in Avidemux. If you need a higher speed, you should either use a x264 preset favoring encoding speed at cost of quality, e.g.

Code: [Select]
ffmpeg -i "$file" -c:v libx264 -preset veryfast -crf 22 -c:a aac -b:a 128k out.mp4
or use a hardware accelerated encoder, which would top x264 by an order of magnitude at cost of low compression rate and poor keyframe placement. If I am not mistaken, you have to use a project script to request a non-default configuration for x264 in Avidemux.