Author Topic: Subtitle characters appears rotated 90 degrees  (Read 440 times)

Richie

  • Newbie
  • *
  • Posts: 3
Subtitle characters appears rotated 90 degrees
« on: June 04, 2020, 11:24:49 AM »
Hello, while hardsubbing my subtitle into my video, some "special" characters ended up rotated 90° to the left. So far, I see it always happens to left quotation mark (“), right quotation mark (”), single right quotation mark (’) and a music note (♪). Does anyone know to to fix it? I have included an attachment to visualize it.

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 4081
Re: Subtitle characters appears rotated 90 degrees
« Reply #1 on: June 04, 2020, 11:57:51 AM »
Works for me with the current git master and external (provided by the system = provided by Homebrew) libass. Which Avidemux version do you refer to?

Richie

  • Newbie
  • *
  • Posts: 3
Re: Subtitle characters appears rotated 90 degrees
« Reply #2 on: June 04, 2020, 11:50:45 PM »
I used Avidemux 2.7.5 version. Not sure if this has anything to do with it, but my subtitle format is .ass and I used FOT-Humming Std M for my subtitle font.

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 4081
Re: Subtitle characters appears rotated 90 degrees
« Reply #3 on: June 05, 2020, 10:17:15 AM »
Not sure if this has anything to do with it, but my subtitle format is .ass and I used FOT-Humming Std M for my subtitle font.

Definitely not related to subtitle format, but this can easily be a libass / fontconfig font handling issue, specific to the said font, in this case my testing performed with Arial would never reveal it. A fix would need to happen in one (or in both) of these upstream projects, beyond the scope of Avidemux.

Does VLC show these characters in external subtitles correctly when this font is requested by a style in the .ass file?

As a workaround, please use a different font, preferably a TTF instead of OTF one.

Richie

  • Newbie
  • *
  • Posts: 3
Re: Subtitle characters appears rotated 90 degrees
« Reply #4 on: June 09, 2020, 03:55:55 AM »
It shows incorrectly in VLC media player too, although a little differently (see attachment). I will use the quotation mark (") and apostrophe mark (') for now. I will try to bring this up in libass bug tracker, although I don't speak their jargon. Thanks for the help.

Sorry for the long reply. The forum kept notifying me to enable JavaScript although Firefox should have it enabled by default.

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 4081
Re: Subtitle characters appears rotated 90 degrees
« Reply #5 on: June 09, 2020, 01:18:42 PM »
I will try to bring this up in libass bug tracker, although I don't speak their jargon.

I would expect the issue to be located either even more upstream in the freetype library or even in the font itself.
Quote
The forum kept notifying me to enable JavaScript although Firefox should have it enabled by default.

The external antispam service CleanTalk produces a huge number of false positives. I have no bearing on it, unfortunately. The error regarding JavaScript is completely misleading. It helps sometimes to try to post from a private browser window and/or from a different IP address. The worst case is when the email provider used to register the account here lands on a blacklist, no remedy known ATM.

Please just send what you wanted to post per PM when CleanTalks has gone mad again. I'm sorry for inconvenience.