February 27, 2021, 09:38:52 PM

News:

--


[solved] Job que - run in Linux

Started by Grobe, January 09, 2021, 02:26:56 PM

Previous topic - Next topic

Grobe

January 09, 2021, 02:26:56 PM Last Edit: January 10, 2021, 12:56:10 PM by Grobe Reason: Putting back 'solved' tag in subject - once again . . .
Hi.

Have a bounch of home videos that I'm going to cut scenes to individual files to x265, and it takes time.

To cut down some time of this process, I do this:
  • Use 3 different computers, each take about a third of the raw video files
  • I don't split up the files now (due to not having access to job capabilities of this version of Avidemux) so when the encoding job starts, I try to feed it with as long video stream (big file + joined input files) as possible
  • After all encoding are done - no more encoding are needed, I'll use Avidemux to split up every scenes to single files

That's the plan, and I'm about in the middle of the process by now.

However - in future I hope to be able to do both the splitting and encoding in one operation.

On a regular windows installatin, there is the other exe file to run in order to start the job que. However on Linux - I have one computer I run the flatpak version of Avidemux and on another I run the appimage of Avidemux. On neither of those I've figured a way of starting the job que process.

That makes it two questions:

Are there possible to start a job que when using flatpak or appimage variant of Avidemux ?

If not, What does it take to being able to run a job que in Avidemux on Linux ?


Thanks in advance

eumagga0x2a

You need to use the new-style appImage from https://avidemux.org/nightly/appImage4Buster/ to be able to launch Jobs GUI from the appImage. To do so, create a symlink with "_jobs" in its name, e.g. "avidemux_jobs" and run appImage by executing this symlink.

There are no official Flatpak-packaged Avidemux builds, please ask whoever provides them.

Grobe


Grobe

Not working. The appimage returned an error when I tried to load and did not launch:
kaffelars@HP-Z400:/home/appimages
$ ./avidemuxUniversal_amd64_200408_12.AppImage
Freetype version 2.9.1
Fontconfig version 21301 :2.13
Using system freetype, fontconfig and fribidi.
/tmp/.mount_avidemI0OqGw/AppRun: line 19: 19518 Segmentation fault      "${HERE}/usr/bin/avidemux3_portable" "$@"
/home/appimages


inxi -Fxmz
System:    Host: HP-Z400 Kernel: 4.19.0-13-amd64 x86_64 bits: 64 compiler: gcc v: 8.3.0
           Desktop: Xfce 4.14.2 Distro: MX-19.3_x64 patito feo November 11  2020
           base: Debian GNU/Linux 10 (buster)
Machine:   Type: Desktop System: Hewlett-Packard product: HP Z400 Workstation v: N/A
           serial: <filter>
           Mobo: Hewlett-Packard model: 0B4Ch v: D serial: <filter> BIOS: Hewlett-Packard
           v: 786G3 v03.57 date: 07/15/2013
Memory:    RAM: total: 3.84 GiB used: 516.6 MiB (13.2%)
           Array-1: capacity: 24 GiB slots: 6 EC: Multi-bit ECC max module size: 4 GiB
           note: est.
           Device-1: CPU0 DIMM1 size: 2 GiB speed: 1333 MT/s type: DDR3
           Device-2: CPU0 DIMM2 size: No Module Installed
           Device-3: CPU0 DIMM3 size: 2 GiB speed: 1333 MT/s type: DDR3
           Device-4: CPU0 DIMM4 size: No Module Installed
           Device-5: CPU0 DIMM5 size: No Module Installed
           Device-6: CPU0 DIMM6 size: No Module Installed
           Array-2: capacity: 24 GiB note: check use: Flash Memory slots: 1 EC: None
           max module size: 24 GiB note: est.
           Device-1: SYSTEM ROM size: 2 MiB speed: Unknown type: Flash
CPU:       Topology: Dual Core model: Intel Xeon W3503 bits: 64 type: MCP arch: Nehalem rev: 5
           L2 cache: 4096 KiB
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 9599
           Speed: 1600 MHz min/max: 1596/2394 MHz Core speeds (MHz): 1: 1600 2: 1600
Graphics:  Device-1: NVIDIA G98 [Quadro NVS 450] driver: nouveau v: kernel bus ID: 11:00.0
           Device-2: NVIDIA G98 [Quadro NVS 450] driver: nouveau v: kernel bus ID: 12:00.0
           Display: server: X.Org 1.20.4 driver: modesetting unloaded: fbdev,vesa
           resolution: 1920x1080~60Hz
           OpenGL: renderer: NV98 v: 3.3 Mesa 18.3.6 direct render: Yes
Audio:     Device-1: Intel 82801JI HD Audio vendor: Hewlett-Packard driver: snd_hda_intel
           v: kernel bus ID: 00:1b.0
           Sound Server: ALSA v: k4.19.0-13-amd64
Network:   Device-1: Broadcom Limited NetXtreme BCM5764M Gigabit Ethernet PCIe
           vendor: Hewlett-Packard driver: tg3 v: 3.137 port: b0c0 bus ID: 01:00.0
           IF: eth1 state: up speed: 1000 Mbps duplex: full mac: <filter>
           Device-2: D-Link System DGE-528T Gigabit Ethernet Adapter driver: r8169 v: kernel
           port: e000 bus ID: 37:09.0
           IF: eth0 state: down mac: <filter>
Drives:    Local Storage: total: 469.51 GiB used: 7.91 GiB (1.7%)
           ID-1: /dev/sda vendor: HGST (Hitachi) model: HCC545050A7E630 size: 465.76 GiB
           temp: 28 C
           ID-2: /dev/sdg type: USB vendor: Corsair model: Flash Voyager size: 3.75 GiB
RAID:      Hardware-1: Intel SATA Controller [RAID mode] driver: ahci v: 3.0 bus ID: 00:1f.2
Partition: ID-1: / size: 22.80 GiB used: 6.07 GiB (26.6%) fs: ext4 dev: /dev/sda1
           ID-2: /home size: 400.55 GiB used: 221.2 MiB (0.1%) fs: ext4 dev: /dev/sda8
           ID-3: swap-1 size: 6.63 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda7
Sensors:   System Temperatures: cpu: 38.0 C mobo: N/A
           Fan Speeds (RPM): N/A
           GPU: device: nouveau temp: 77 C device: nouveau temp: 80 C
Info:      Processes: 211 Uptime: 27m Init: SysVinit runlevel: 5 Compilers: gcc: 8.3.0
           Shell: bash v: 5.0.3 inxi: 3.0.36

eumagga0x2a

Quote from: Grobe on January 10, 2021, 01:42:50 AMNot working. The appimage returned an error when I tried to load and did not launch:
kaffelars@HP-Z400:/home/appimages
$ ./avidemuxUniversal_amd64_200408_12.AppImage

I was unclear. You need the new-style appImage, with currently the newest one being avidemuxLinux_GLIBC_2.28_amd64_210104_0704.app

There are a few wrong (old) files in the directory.

Grobe

Ok - thanks again, I now realize that I downloaded an old file - my fault.