May 21, 2022, 03:20:39 PM

News:

--


Serious appImage problem

Started by szlldm, March 13, 2021, 09:52:31 PM

Previous topic - Next topic

szlldm

Hi!

Just downloaded the latest appImage (avidemuxLinux_2.7.8_GLIBC_2.28_amd64.appImage),
and can not run it :(
avidemux3_qt5: error while loading shared libraries: libpcre2-16.so.0: cannot open shared object file: No such file or directory
/lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.28' not found (required by .../libADM6avutil.so.56)
/lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.28' not found (required by .../libQt5Core.so.5)

I believed, that an appImage contains every necessary stuff for execution.
I have Ubuntu 18.04 LTS, which has 2 more year til EOL...


eumagga0x2a

This rather a communication / documentation issue. The new-style appImages require glibc 2.28 or later = Ubuntu 20.04 or later. For old distributions, please use builds from https://avidemux.org/nightly/appImage4/

Quote from: szlldm on March 13, 2021, 09:52:31 PMI believed, that an appImage contains every necessary stuff for execution.

Theoretically, yes. Practically, no. This would require to leave out pretty all HW accel stuff (libva is closely tied to kernel version) as well as OpenGL and resort to Debian oldstable as build system which would make it very hard to integrate features like AV1 decoding, VP9 encoding and a halfway recent Qt.

Therefore we have a feature-reduced appImage for old distributions and a feature-complete appImage for everything halfway current. The latter has to use more resources of the host system.

szlldm

Thanks! I did just that, and downloaded the nightly for one of my remote machine.
It would be wise to indicate this circumstance on the project page.

eumagga0x2a

I must admit that I didn't test the old-style appImage release build, maybe contributing this way to it being not included. Additionally, I thought that "GLIBC_2.28" in filename is sufficient to keep people from trying to run it on systems with an older version.

Who

Quote from: eumagga0x2a on March 14, 2021, 01:33:04 AM... I thought that "GLIBC_2.28" in filename is sufficient to keep people from trying to run it on systems with an older version.

Not sure why you would think that, unless for some reason you believe all Avidemux users are also programmers or something.  Anyway, I ran into the same issue on a system running Ubuntu 18.04, and if I hadn't found this thread I would have had no idea what the problem was.  Therefore I would agree that you should probably put a note on the download page about this.