November 27, 2021, 06:05:56 PM

News:

--


Avidemux v 2.6 problems

Started by h4ever, August 20, 2021, 08:59:47 AM

Previous topic - Next topic

h4ever

Hello, I would like to describe problems which I have with v. 2.6. I am Windows XP user x32. Till now I use the version 2.5.6.

Let me describe how I use v 2.5.6 with no problem:
1) I open video
2) I locate some part in speach, which I want to delete.
This means, that I can use left or right arrow to navigate to certain frame. I place a mark of the begin.
3) Then I play. Stop, and add mark of the end to be deleted.
4) I delete
5) I rewind back and control by listening to the sound if it is OK. And it is OK.

The problem in 2.6 is the same problem which I have with virtualdub 1.10.4.

Here is problem somewere in the step 2 and 3.
When I use stop. It exactly stops on some frame. OK. But when I press play again, it does not play on the same location where it stop. It just skips about 500ms or 1 s. IDK. And this is huge problem ... iratating. I just cannot do the audio check. I need to play again rewind 10-15 times, just to locate the exact location where to place the marks to delete.

So if the sound that I want to delete is very short, like 200ms,  it's impossible to locate the exact end by listening. When I add the end mark I would expect, that I can check the correct location by pressing play. But it skipped sound... So cannot check.

Another problem which I had... was with the Cut/Paste action. The paste did not worked for me. So I still use the older version.

Yet one thing I miss at both versions. When I open video I want to use left, right arrow and shift+right, shift+left immediately. I can press space to play, but I cannot use the mentioned keys.

eumagga0x2a

Quote from: h4ever on August 20, 2021, 08:59:47 AMWhen I use stop. It exactly stops on some frame. OK. But when I press play again, it does not play on the same location where it stop. It just skips about 500ms or 1 s. IDK. And this is huge problem ... iratating.

This was fixed 4 years ago by [gui_play] Resume playback from the same frame where it was stopped during the 2.7.1 release cycle.

Any version older than the latest release 2.7.8 is completely unsupported and problems reported with the release must be verified with the latest nightly builds.

Here we arrive at the problem that there are no current 32-bit builds. Even if I build a private 32-bit version from the current git master, the resulting binaries AFAIK won't run on Windows XP (if you are very interested, we could try, but I don't expect that it will work).

I fear there is no way forward for a 32-bit Windows XP.

h4ever

Quote from: eumagga0x2a on August 20, 2021, 09:51:14 AM
Quote from: h4ever on August 20, 2021, 08:59:47 AMWhen I use stop. It exactly stops on some frame. OK. But when I press play again, it does not play on the same location where it stop. It just skips about 500ms or 1 s. IDK. And this is huge problem ... iratating.

This was fixed 4 years ago by [gui_play] Resume playback from the same frame where it was stopped during the 2.7.1 release cycle.

Here we arrive at the problem that there are no current 32-bit builds. Even if I build a private 32-bit version from the current git master, the resulting binaries AFAIK won't run on Windows XP (if you are very interested, we could try, but I don't expect that it will work).

I fear there is no way forward for a 32-bit Windows XP.

I installed the version 2.7.7 when I try to open video error is displayed The Application has encountered a fatal problem...
I have Visual C++ 2010 Express installed ...

eumagga0x2a

Quote from: h4ever on August 20, 2021, 11:34:25 AMI installed the version 2.7.7 when I try to open video error is displayed The Application has encountered a fatal problem...

Did you install the 2.7.7 build from February 28, 2021? (Don't be fooled by the relatively recent build date, the codebase was last updated on July 21, 2020.)

https://avidemux.org/nightly/win32/

Could you please provide %localappdata%\avidemux\admlog.txt from the failed attempt to run it? I could imagine that our attempt to probe the availability of hardware accelerated display (via DirectX) and decoding (via DXVA2) could trigger a crash on systems with broken graphics drivers or bad hardware.

Quote from: h4ever on August 20, 2021, 11:34:25 AMI have Visual C++ 2010 Express installed ...

Not related and not needed.

h4ever

Yes Feb 28 2:43
I use old graphic card NVidia GT640. I am not player of PC games.
https://pastebin.com/tBvV5nFj

eumagga0x2a

I assumed that the crash occured during startup, not from initiating video display after loading a video. For now, please choose the unaccelerated "Qt" video display instead of the default "DXVA2" (really DirectX) one in Avidemux Preferences (and of course, don't enable DXVA2 decoding).

h4ever

This time the program does not crash when opening file. First test - I tried to copy portion of the video from end to begin of the video... And this works with no problem.

eumagga0x2a

You could now try to enable OpenGL in Avidemux Preferences and to choose "QtGl" video display instead of "Qt". If it works, this will reduce CPU load relative to unaccelerated "Qt" display. If it triggers a crash, go back to "Qt". When switching OpenGL on and off, don't forget to restart Avidemux.

eumagga0x2a

By the way, if you are interested to try a current, officially incompatible but presumably never tested on Windows XP 32-bit build off the git master, I could build you one and upload it to WeTransfer.

h4ever

Ok. I can test it. But I have question. I have problem with the hotkeys ctrl+pgUp and ctrl+pgDwn. I used to use [ . ] with left hand and arrows with the right hand to move the "pointer". It is harder. It would be nice if there would be possibility to configure it as needed, e.g. from ini file or as you wish.

BTW: Is it possible to add a delay to audio track? In the current location in the file, where the "pointer" is pointing. I spend hours and days trying to edit video, then convert it with FormatFactory to add the edited sound into the video. It's lots of files and I'm getting annoyed with this because with so many files man can do lots of errors, mistakes and overwrite or delete wrong files.

eumagga0x2a

Quote from: h4ever on August 20, 2021, 02:52:48 PMOk. I can test it.

Trying to build.

Quote from: h4ever on August 20, 2021, 02:52:48 PMI have problem with the hotkeys ctrl+pgUp and ctrl+pgDwn. I used to use [ . ] with left hand and arrows with the right hand to move the "pointer". It is harder. It would be nice if there would be possibility to configure it as needed, e.g. from ini file or as you wish.

Enable alternative keyboard shortcuts in Avidemux Preferences. They are freely configurable, but require manual editing of config3 XML file. The default is "I" (like in "in") to set marker A, "O" (like in "out") to set marker B, "A" to go to marker A, "B" to go to marker B, "S" (like in "start") to seek to the beginning of video, "E" (like in "end") to seek to the end.

Current builds offer also Shift+Up and Shift+Down to seek to cut points.

eumagga0x2a

Quote from: h4ever on August 20, 2021, 02:52:48 PMIs it possible to add a delay to audio track?

Check the "Shift" checkbox and enter a positive value into the combobox.

eumagga0x2a

Here we go: https://we.tl/t-ZUCIkhyzRH, file size: 45670401 bytes, checksums:

md5sum avidemux_r210820-172726_win32Qt5.zip
878dab93388428b82e330217ebb0251d  avidemux_r210820-172726_win32Qt5.zip

sha256sum avidemux_r210820-172726_win32Qt5.zip
de43d4992bdcf172c00ca48178a13bed7373275455637ae46f7d278db3580048  avidemux_r210820-172726_win32Qt5.zip

Please either backup the profile directory %appdata%\avidemux prior to trying to run this build or rename avidemux.exe to avidemux_portable.exe to make Avidemux store configuration in the program directory rather than in the profile. Never run both versions simultaneously.

I would expect this binary to fail completely to run, and the FFmpeg libraries at the core of Avidemux are officially incompatible with Windows XP, but to be absolutely sure, one has to try it. However, if it manages to start, don't forget to switch from "DXVA2" (actually DirectX) to a different video display prior to trying to load a video.

h4ever

The folder
C:\Documents and Settings\Administrator\Local Settings\Data aplikací\avidemux ...
is empty... except the log admlog.txt So no need to backup.

eumagga0x2a

Not that one, press Windows key + R and run %appdata%\avidemux