V2.8.1 does not work. V 2.8.1legacy and *GLIBC_2.28_amd64_220103_0612 work

Started by andreas1, January 13, 2023, 02:11:26 PM

Previous topic - Next topic


Hello All
first thank you for your tremendous work.
I use avidemux with arch linux and it worked pretty good until V2.8.1
This version gives Errors like:
"[displayXError] 13:59:33-045  LibVA Error : <vaCreateConfig( ADM_coreLibVA::display, profile, VAEntrypointVLD,&attrib, 1,cid):the requested VAEntryPoint is not supported:13>"
among a lot of other errors.
The same happens with the appImage. But the Version 2.8.1 legacy appImage works and so does the Version: "nightly/appImage4Buster/avidemuxLinux_GLIBC_2.28_amd64_220103_0612.app (03.January 2023)".

The question therefore is :"What is the difference between 2.8.1, the legacy version and/or the nightly build


Legacy appImage has no support for VA-API via libva, thus the console output doesn't contain messages related to probing VA-API features available on your system and hardware. The pure presence of such messages alone is expected and doesn't indicate that anything is amiss.

Please try the currently latest available official 2.8.2 nightly (avidemuxLinux_GLIBC_2.28_amd64_230111_0739.app) and provide the full log if it either crashes or is uncapable to decode video files old version can: run Avidemux with stdout and stderr redirected to a file, close Avidemux if still running, sanitize the content of the created text file if you wish (e.g. consistently replace paths containing your user name with a placeholder), zip the file and attach it to your reply.

If Avidemux fails to decode (some) videos with HW accelerated decoding enabled, please retry with decoding via libva and VDPAU in Avidemux preferences / HW Accel disabled.

Problems with libva hw decoder on non-Intel systems (on those with AMD GPUs) are a known unsolved issue. On other systems, please always use the native hw accel solution: VDPAU on system with NVIDIA graphics cards using the closed-source NVIDIA driver, libva on Intel.


Hi eumagga0x2a,
thx for your quick answer. 1st, my problem has been  solved, right before i read your reply.  While testing by try and error, i enabled (or disabled,i can't remeber)  in the "preferences/HW Accel" both, Decode video using VDPAU and Decode video using LIBVA.
And it worked. Funny thing is, from that moment on it worked also whether the decode options were enabled or disabled. For my arch linux system with an AMD Radeon grafic card the VDPAU driver seems to work. Whatever, it seems that my configuration were not right after the last update.
And you are right, all those errors i mentioned come from the probing and finally the right libs or drivers are found and the program works as it is supposed to.

Thx again


Quote from: andreas1 on January 14, 2023, 02:16:31 PMFor my arch linux system with an AMD Radeon grafic card the VDPAU driver seems to work.
This is merely a wrapper around VA-API with AFAIK a rather poor performance. If both VDPAU and libva in Avidemux are enabled and probing for VDPAU succeeds, VDPAU wins. Depending on your CPU (especially the number of cores), you might get better decoding performance by enabling multi-threaded decoding and disabling hw decoders.

By all means, I recommend recent 2.8.2 nightlies over the 2.8.1 release for stability reasons. This may change soon once the ffmpeg5x branch gets merged, but until now the nightlies are effectively the release with a number of important bugs sorted out and some video filters added (I'd especially highlight the "iaEnhance" upscaler, courtesy of szlldm).