Avidemux problems on Linux Mint

Started by user1530, March 09, 2024, 03:38:58 PM

Previous topic - Next topic


A few problems have suddenly appeared with Avidemux Version 2.8.1 on Linux Mint 18.3

Was working as expected on Wednesday 6th March
Broken on Friday 8th March

Summary of problems

- Drag and drop no longer works.

- Does not remember last directory used for saving.  Always opens a randomly named folder under [/run/user/1000/doc/] even with or without checking [Preferences -> Output -> Default to the directory of the last read file for saving]
- Does not remember last directory used for opening file.  Always opens computer's root directory.

- Saves a copy of working file in a randomly named folder under [/run/user/1000/doc/] even though the file was opened from a different directory. Copied files persist even after closing Avidemux.

- Settings had been overwritten.
I had unchecked [Preferences -> User Interface -> Check for new release]
but when I looked after the problems happened, it had been checked. And [Revert to saved default output settings on video load] had been unchecked, whereas before it had been checked.

Tried uninstalling and installing.  Same problems.

- Linux Mint 18.3
- Avidemux installed through Software Manager - Flathub version

Anybody with same problems?
Any suggestions on how to repair?

Thanks in advance


Quote from: user1530 on March 09, 2024, 03:38:58 PM- Avidemux installed through Software Manager - Flathub version

Unsupported third-party build. Please build yourself from the latest git (recommended) or use the latest official appImage. If you absolutely need 2.8.1 for compatibility with existing project script library, use the release 2.8.1 appImage (better: build yourself from support_2.8.1 branch, it has at least the worst regressions discovered in 2.8.1 fixed).


FYI: Linux Mint 18.3 support ended in 2021


Quote from: eumagga0x2a on March 09, 2024, 09:00:46 PMuse the latest official appImage

Downloaded latest appImage
Made it executable
Did not run
Error message was: libpng16.so.16 cannot open shared object file: No such file or directory

So I installed it

Still didn't run
Error message now was: libc.so.6: version GLIBC_2.28 (and 25 and 27) not found

I've now downloaded an old appImage from FOSS Hub and happy to report Avidemux is working again

Thanks again

I tried including all the output of the error messages wrapped in code blocks, but the forum software kept rejecting the post as spam
Also, the software seems to convert text containing periods, like the filenames, into web links


My fault, I didn't realize how ancient Linux Mint 18.3 was, so I pointed to appImage suitable for less outdated distributions, e. g. for Ubuntu 20.04 or newer.

Please upgrade the distribution.



I have the same 4 problems as User1530 but my Linux Mint version is 21.1 Cinnamon (5.6.8 ).

Can you help us, please?

Thanks in advance


Please do not use Flatpaks (or don't ask here).