Author Topic: .avi files are now saved with a lock on it! Help.  (Read 21221 times)

Agent_007

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3163
Re: .avi files are now saved with a lock on it! Help.
« Reply #15 on: October 07, 2011, 05:59:49 PM »
It must be some sort of bug since Windows should always show owner for files that are on system drive.
I am away between 15th of May - 15th of June. (yes, I am playing D3)

billybudd

  • Newbie
  • *
  • Posts: 1
Re: .avi files are now saved with a lock on it! Help.
« Reply #16 on: October 31, 2011, 01:54:11 PM »
Found my way here via Google with the same problem. Since this thread seems to be dying without a solution, I'll post this in case others are also finding their way here:

Window 7, in their amazing improvements to system security, has made it so that files saved inside the "Program Files" section are both locked and invisible or something.

Simple solution: Save your files somewhere else.
Complex solution: Search the following phrase in Microsoft related forums for more information:
Quote
"Unable to set new owner on <file name>.
The system cannot find the file specified."

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 6051
Re: .avi files are now saved with a lock on it! Help.
« Reply #17 on: October 31, 2011, 04:57:19 PM »
Quote
Save your files somewhere else.
Glad I dropped Micro$oft Window$ for linux :)
Do you know how to open the dos box in windows 7? Previous versions had an icon like this on black background: [c:\]? Run this as an administrator? Select that icon with a right mouse click and select run as administrator. Once your in there use:
Code: [Select]
cd pathto go to that folder where locked files are, path is something like \My folder. In that folder give this command:
Code: [Select]
attrib -s -h -r filename.ext where filename.ext is the name of the file you want access to.
« Last Edit: October 31, 2011, 05:01:40 PM by Jan Gruuthuse »

parker

  • Newbie
  • *
  • Posts: 5
Re: .avi files are now saved with a lock on it! Help.
« Reply #18 on: November 02, 2011, 08:34:55 PM »
I’m not sure I understand this thread, but is this all about misplaced “compatibility files”???  Keep in mind that post-ATA XP, Vista and Win 7 come with UAC which is set to disallow any improperly coded files (which includes all AVIs) to be kept in “protected areas”, meaning those areas in which the O.S. registry resides. If the O.S. has a “merge all files” or equivalent setting enabled, you can see the files, which are actually kept in a virtual folder, but they will be displayed with a special icon, and not be available for search, etc. The easy solutions are to partition the physical drive and keep data folders away from the registry, or disable UAC, or disable the merge all files feature, which will leave you with a “compatibility files” link at the top of each (protected) folder where a compatibility file is stored.

The criticisms of Windows in this thread are certainly not deserved. This is a security feature not even available with the other O.S. mentioned, and one which can be disabled, if not desired, in Windows.

just_once

  • Newbie
  • *
  • Posts: 1
Re: .avi files are now saved with a lock on it! Help.
« Reply #19 on: April 08, 2012, 09:07:40 AM »
Hi,

I just experienced the same problem described at the top of this thread. Then the thread moves to other topics and the actual problem described at the beginning is no longer discussed.
For sake of clarity, let me describe the problem once more

PROBLEM
=======
After saving some video files ok with the "save as" function, suddenly the function no longer works. What happens is that:
- the files seem to be saved ok, no error messages are displayed
- however, the files do not show up in Windows Explorer in the folder where they should appear
- on the other hand, the files show up when opening the same folder with the "save as" function of Avidemux
- but the icons appear with a small lock icon on them, and don't open when you try to within Avidemux
I couldn't find any other discussions about this problem anywhere on the internet, but I found a simple solution myself, so I'm posting it here hoping it helps someone else who might stumble upon the same problem and get stuck with it.

SOLUTION
========
Uninstall Avidemux and reinstall it. The "save as" function will work again as expected.

Cheers,

Mike

PS: Please note I have registered here only to post this solution in hope it helps other people experiencing the same problem. I won't be logging in again unless I find another problem and/or solution.