Author Topic: Sync problem when importing WMV files  (Read 5316 times)

Muya

  • Newbie
  • *
  • Posts: 2
Sync problem when importing WMV files
« on: August 12, 2011, 04:18:23 PM »
Hi all

Newbie here, and I would very much appreciate some help.  I'm trying to re-encode some files from WMV to H.264, but the audio is always out of sync.

I've had some audio problems like that in the past with WMV files, and I was able to solve them by opening the file through Avisynth, converting from Variable Frame Rate (which seemed to be the problem) to Constant Frame Rate and encoding with Avidemux.  However, this doesn't work in the case of these files.

I haven't found anything useful online, and I was wondering if anybody had any similar experiences and solutions.

Details:
The files that have this problem seem to be at 30 fps, but I can't know if the problem is restricted to that.  The details below are for a specific file with this problem, which is similar to the other problematic files.

When I open the WMV file directly with Avidemux and look at the properties, I see
Codec 4CC: WMV2
Frame Rate: 30.000 fps
Frame Count: 73443 frames
Total Duration: 00:40:48.100

I then open it through Avisynth Proxy.  I convert from VFR to CFR and force frame rate to 30.000 (if I don't do that, I get an error saying that DirectShowSource cannot determine the frame rate).  When I connect with Avidemux and look at the properties, I see
Codec 4CC: YV12
Frame Rate: 30.001 fps
Frame Count: 73519 frames
Total Duration: 00:40:50.551

The difference in frame count and duration is about how much the audio is out of sync in the final file.  Note that if I play the raw data from Avisynth in Avidemux, it's synced throughout.  It's only in the encoded file that it goes out of sync.

I've been trying to encode in H.264 + AAC in MP4, and just to confirm that it wasn't related to that, I tried AC3, Xvid, MP3, AVI container etc., and I always get the same problem.  I also tried the process on a different PC to eliminate any other possible factors.  I even tried Avidemux 2.6 (the main version I'm using is 2.5.4).  I can't fix the output file with an audio shift, either, because it really needs a stretch rather than a shift.

Any useful thoughts?

Thanks

Muya

Agent_007

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3163
Re: Sync problem when importing WMV files
« Reply #1 on: August 12, 2011, 06:03:12 PM »
Have you tried to remux those WMV files with Asfbin?
I am away between 15th of May - 15th of June. (yes, I am playing D3)

Muya

  • Newbie
  • *
  • Posts: 2
Re: Sync problem when importing WMV files
« Reply #2 on: August 30, 2011, 11:20:36 PM »
Yes! Thank you.

I finally got around to downloading and testing AsfBin.  I'm not sure what it did exactly, but after I saved the file with AsfBin, I was able to encode it in Avidemux without problems.  I don't know if this would solve all problems of this type, but it's definitely worth trying.


turbine

  • Newbie
  • *
  • Posts: 5
Re: Sync problem when importing WMV files
« Reply #3 on: March 26, 2012, 10:30:50 PM »
This is the only thread I found dealing with variable frame rate (VFR).  Has the ability to deal with VFR source been incorporated into Avidemux 2.6?

mean

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 10974
Re: Sync problem when importing WMV files
« Reply #4 on: March 27, 2012, 07:51:21 AM »
normally yes