March 02, 2021, 01:29:25 AM



.avi files are now saved with a lock on it! Help.

Started by isavegas, September 26, 2011, 09:31:55 AM

Previous topic - Next topic


Im a total newbie Im using avidemux 2.5.4 with windows 7 and 32 bits.

First two days of marking what I need with a and b, saving as file.avi and reopening in WLMM worked perfect. Today however, every clip I save is locked. If I try to open it, it cannot find it.

I don't know what happened. I have not change a single setting and am in fact using the same movie to save little clips from. No, I didnt save it as a project. I simply reopened the original video, did the blackframes.txt and muted audio then marked A and B where I needed and saved as file.avi.

Everything is set at default. The only thing that has changed on my computer is I downloaded VLC eariler today. Don't see how avidemux shld be effected however if I open a folder to look at any .avi listings I have, everything now has an orange and white cone but still saying . avi.

Thanks in advance.


QuoteToday however, every clip I save is locked. If I try to open it, it cannot find it.
What are the exact error messages?
I am away between 15th of May - 15th of June. (yes, I am playing D3)


September 26, 2011, 10:34:03 PM #2 Last Edit: September 26, 2011, 11:40:24 PM by isavegas
Actually there is no error msg. It saves and says its sucessful. But when I try to open it anywhere else, its either not there or I see a lock on it. Yes, I tried opening w WMM, WLMM, Wax, Windows Media and VLC.

Finally I searched for them within my computer and tried to take ownership by clicking on properties and blab blab but then all it would say is, its not there.

Now that I think of it, the saving of clips in avidemux has suddendly became much faster so it seems as if its not saving I guess.

I love how avidemux quickly moves thru a movie to save clips for other project and am looking fowards to trying some effects there but if everything I save is locked, whats the point?

Oh, this might help. I am doing nothing but simply saving certain points of a movie in avidemux. Yes, I put the A on an I frame. Im not adding extras or anything as of yet.


This may help... Im working on another project like my 17 Again music vid here -

Got tired of how badly WLMM uses memories (bigger the movie to split up, longer everything takes in it) that I downloaded Avidemux to speed things along. It took me only minutes to scan, find, and copy sections within a movie (in Avidemux) so that I can place smaller chucks to edit within WLMM.

With smaller chucks, wlmm no longer drags. WLMM may have a buncha stupid flaws but its all I know as of now. I also have Debugs Wax but only use that for chroma key. Too buggy and glitchy and not as user friendly enuff for me to mess w it now. Im hoping avidemux would be a more user friendly.


AVIdemux shouldn't lock any files permanently. And if you have closed AVIdemux, and the file still doesn't open, it sounds more like bug of some other component (like problem of thumbnail generation in Windows Explorer).
I am away between 15th of May - 15th of June. (yes, I am playing D3)


September 27, 2011, 09:59:20 PM #5 Last Edit: September 27, 2011, 10:02:27 PM by isavegas
Umm, if its a bug problem then I honestly don't know what to do. I tried opening the locked files with avidemux closed but it won't even show up anywhere.

So, I open windows explorer to show the folder where Im keeping the avidemux clippings in and then I reopened avidemux to look at the locked files and then used printscreen.  Maybe this wld help

Uploaded with

Oh, as for thumbnail thingy, Im not using it. I do know avidemux allows u to create ur own since it doesn't do it but I havent used that feature since Im pretty much savng clips and immed transfering over to wlmm so no need for generating thumbnails.

If this image is too small let me know and Ill reupload and make bigger. Basically the one on the left which is what seen in avidemux when I save is showing extra files but with a lock on it.

The window on the right is the window explorer and shows only unlocked clips.


Oh by the way its not important that I unlock those files.... they are easy to remake and save again.

The problem is any other clips I save is all now locked. It doesnt matter what movies I put in to clip.... all are now locked.

Jan Gruuthuse

If you select all the locked files, can you right click on those and change the properties from read only? De-select [v] to [ ] box for read only, I guess? Never had windows after XP. Could be you need administrator rights, perhaps booting as administrator? Could be an anti-virus thing locking these avi's, as not recognised?


Nope cannot right click and do anything including set to read or obtain ownership. Yes I am the adminstator of my own computer but not even then. Nah doubtful its my antivirus bec i havent changed anything with it and besides avidemux did save a nbr of clips wo locks until shortly after dl and installing VLC>

It seems its simply not there (the file). Thats happening w everything im saving as a clip in avidemux now.

What if I uninstalled avidemux and reinstall since it may just be a bug problem? I just hate to do something like that without being sure.

And again, what about the VLC... like I said, it started happening after I download and installed VLC. Now everything is in an orange and white cone which isnt a problem opening though. Just wondered if theres a connection.


VLC doesn't add any explorer extensions that would add lock icons. Neither do AVIdemux. So it is some other program doing something.
I am away between 15th of May - 15th of June. (yes, I am playing D3)


Ah, then Im at a total lost because I haven't downloaded any other softwares. What about uninstalling Avidemux and reinstalling? Is it worth a try?

What else can I look at or try? I really want to learn and use this cool program.

Thanks in meantime.


QuoteWhat about uninstalling Avidemux and reinstalling? Is it worth a try?
I won't help.

Do these locked files have different user permissions than the rest of files?
I am away between 15th of May - 15th of June. (yes, I am playing D3)


No, they are all the same except for simply being locked. I mean yes its same user permission as rest of files.
Im wondering if i accidentally turned on or off a feature in avidemux that cld lead to that.


AVIdemux doesn't have any feature to change file permissions, user groups or apply locks.

What does the Windows Explorer properties show for permissions of those locked files?
I am away between 15th of May - 15th of June. (yes, I am playing D3)


October 07, 2011, 12:56:02 AM #14 Last Edit: October 07, 2011, 01:40:07 AM by isavegas
Oddly enough I cannot find those locked files in windows explorer, however if I open Avidemux and use the open tab from there, I can see the locked files and look at permission.

Here's a screenshot of what permissions show. As you can see, even as an administrator of my own computer it won't let me take ownership.

Uploaded with

And when I try to take ownership - this is what I get

Uploaded with

BTW, again, those locked clips are all coming from the same movie and settings as the unlocked files. I'm beginning to agree that it sounds like a Windows 7 problem.

Umm, found a ownership app from this help site but unsure if good idea to use it -