May 17, 2021, 11:36:30 PM

News:

--


fail build in 32bits machine

Started by sl1pkn07, October 18, 2014, 08:04:44 PM

Previous topic - Next topic

sl1pkn07


Jan Gruuthuse

October 19, 2014, 05:38:04 AM #1 Last Edit: October 19, 2014, 07:22:12 AM by Jan Gruuthuse
Check 1st this reply: compiler specific issue

You don't provide enough information. Too many possibilities. Please provide more info: used OS, cpu, gpu, .... :
QuoteAvidemux v2.6.8 (#hash)
_____________________________________________
Compiler: GCC 4.8.2
cmake: 2.8.12.2
Build Target: Linux (x86-64)
User Interface: Qt (4.8.6)
_____________________________________________
Kernel: Linux 3.13.0-37-generic (x86_64) (linux-image-3.13.0-35-generic 3.13.0-35.62)
Distribution: Linux Ubuntu 14.04.1 LTS (Trusty)

Intel Core i7-3770K @ 3.50GHz (4 Cores/8 Threads) with 16 GB ram

Desktop: Unity 7.2.2
Display Server: X Server 1.15.1
Display Driver: nouveau  1.0.11
OpenGL: 4.3.0

OpenGL Vendor: NVIDIA Corporation
OpenGL Renderer: GeForce GT 520/PCIe/SSE2 1024MB (810/535MHz)
OpenGL Version: 4.4.0 NVIDIA 304.123

NVIDIA VDPAU Driver Shared Library  304.123
_____________________________________________

- build log found in normal conditions in /tmp/logbuildXXX(packed) XXX would represent name of build module.
- used source to build
- could you search on your File System  for the location of libc_nonshared.a and pass on this information?
these would give developer(s) more insight of what is going on, thank you.

Jan Gruuthuse

October 19, 2014, 05:48:48 AM #2 Last Edit: October 19, 2014, 06:06:20 AM by Jan Gruuthuse
Using the latest source:
sudo apt-get install git
cd ~
git clone https://github.com/mean00/avidemux2.git
cd ~/avidemux2 && git pull
cd ~/avidemux2 && bash bootStrap.bash --deb --with-qt4 --without-gtk --with-cli

Jan Gruuthuse

October 19, 2014, 06:02:08 AM #3 Last Edit: October 19, 2014, 06:46:34 AM by Jan Gruuthuse
check if these are installed and install the missing ones:
dpkg -l gettext cmake-dbg libasound2-dbg libass-dev libdts-dev libfribidi-dev libftgl-dev libftgl2 libglib2.0-0-dbg libiconv-hook-dev libopencore-amrnb0-dbg libopencore-amrwb0-dbg libqt4-dbg libqt4-script-dbg libsdl-sound1.2-dev libsqlite3-0-dbg libtwolame-dev libva-dev libvdpau-dev libvpx1-dbg libwxsqlite3-2.8-0 libxml2-dbg libxslt1-dbg libxv1-dbg libxvmc1-dbg libzip-dev sqlite3 libxml2-dev gcc g++ make cmake pkg-config libpng12-dev fakeroot yasm libsqlite3-dev libaften-dev libmp3lame-dev libx264-dev libfaad-dev libfaac-dev libqt4-dev

If you have vdpau supported card (nvidia)
dpkg -l vdpauinfo mesa-vdpau-drivers mesa-vdpau-drivers-dbg mesa-common-dev

mean

it a compiler specific issue
Need to add -lrt to LDFLAGS for this compiler version

export LDFLAGS="-lrt"
bash bootStrap.bash

should do it


sl1pkn07

Hi.

this is not my issue, I am the maintainer of the AUR (Archlinux User Repository) package (https://aur.archlinux.org/packages/avidemux-git/)

the error is from a user of the package (@Brottweiler)

I asked him to tell more information in this thread. but you have not yet done

in 64bits (my system) works ok without a @mean suggestion

if nothing has changed. the compiler is gcc 4.9.1


@mean. thanks for the suggestion

greetings

mean

The bottom line problem  is that some static libs are used whereas they should be the dynamic ones


sl1pkn07

@Brottweiler can not post comments because logging is disabled

Jan Gruuthuse

October 25, 2014, 05:01:42 AM #8 Last Edit: October 25, 2014, 05:06:23 AM by Jan Gruuthuse
If you try to register and you get this message:
An Error Has Occurred!
Sorry, registration is currently disabled.

@Admin
Either registering service is offline or some Info is missing:
Too much spam -> some changes/blacklisting