Can't use "Open with…" to use latest version of Avidemux

Started by BG Davis, January 16, 2018, 06:13:48 pm

Previous topic - Next topic

BG Davis

Running Win7
I can't use "Open with..." to use latest version of Avidemux.
I have the most recent version 2.7 saved in "C:\Program Files\Avidemux 2.7 - 64 bits"
But ever since installing the first iteration of v.2.7, if I try to use "Open with..." to open a video clip, the version that appears is 2.6.1.  No matter what I try, I can't make v2.7 appear in the list of "Open with..." programs on my computer.
So I have to open v2.7, then find the clip and open it.  This is time-consuming and inefficient.
Is there a fix for this?  (I hesitate to delete previous versions since I don't want to delete any files that might be needed to run later versions.  And some previous versions have convenient features that have disappeared in later versions.)


BG Davis

Thanks but I am aware of the procedure described in the link you provided.  It does not make any difference.  I can assign any other program I want (older versions of Avidemux, etc.) but v2.7 does not appear.

Jan Gruuthuse

I'm not on windows, is there not a way where you can browse to avidemux 2.7, in these procedures.

BG Davis

Yes, there is, but for whatever reason the program refuses to open v2.7 from it.
See attached images.
Even more strange, now that I have v2.7 180123, a previous version of v2.7 now appears in the list of options (image attached).  It's as if the latest iteration won't appear but previous ones will.

Image 1: selected v2.7 from browse list in Program files.
Image 2: v.2.6 appears not v.2.7.
Image 3: Options list now includes older build of v.2.7

AQUAR

If you installed these V2.6 and V2.7, then probably the application data/configuration settings are getting mixed up.
Should not run these together on the same PC (V2.5 plus V2.6orV2.7 is okay).

Else run all these avidemuxes as a portable in their own private folder (not in the special "program files" folder)

BG Davis

Thanks for the information!  I didn't realize that would be a problem.

overburner

I've installed today the last avidemux 2.7 version, unisstalled 2.6 version but v2.7 doesn't appear in the list of "Open with..." programs on my computer.
Of course I've tried to choose the program from the list with right click/open with/default programs but after choosen avidemux it is ignored!!

eumagga0x2a


eumagga0x2a

The background: Avidemux requires --load as option between the exe name and the file name of the video.


BG Davis

Sorry for the delay - I've been busy with other things.
I followed the instructions on the link you provided.
The only program listed under .7z/Open with List was firefox - which of course is not an "Open with" option for image or video files.
I did as suggested.  It did not help.

BG Davis

Quote from: eumagga0x2a on July 01, 2018, 10:52:06 am
The background: Avidemux requires --load as option between the exe name and the file name of the video.

Is this new?  No previous version (before 2.7) required it.

eumagga0x2a

January 22, 2019, 04:30:09 pm #13 Last Edit: January 22, 2019, 06:46:06 pm by eumagga0x2a
This was plainly my error. The first argument passed to application is interpreted as video to load even without the --load option. "Open with..." with Avidemux works fine for me on Windows 10 once I fought all the way for the right to point to the exact location of avidemux.exe.

I'll recheck on Windows 7 later.

eumagga0x2a

Same for Windows 7, works fine once I've pointed to avidemux.exe.