March 01, 2021, 10:27:42 AM

News:

--


Avidemux keeps crashing in the middle of editing

Started by Ronstang, January 13, 2021, 01:11:52 AM

Previous topic - Next topic

Ronstang

Lately when I try to edit certain files I keep getting an "ExceptionFiler" error which leads to a failure and Avidemux completely shutting down. This happens while scrolling through the video wit the mouse trying to determine the cut points but also happens if you use the buttons.  If I use the crash file to load the job it crashes in exactly the same spot once again but if I delete the index file and re-index I usually get a successful edit, even it it takes a couple tries.

For some reason I have only noticed this problem with one TV series recorded from the History Channel.  I just installed the latest nightly build from Jan 4 and the issue continues.

Thanks for any help.

eumagga0x2a

Please reproduce the crash and provide resulting admlog.txt. Please don't delete the file which triggers it, thanks.

Ronstang

OK, but I don't remember where to find the log files

eumagga0x2a

%localappdata%\avidemux\admlog.txt

The log gets overwritten each time you start Avidemux, so please don't restart the application after a crash, copy the log first.


eumagga0x2a

January 13, 2021, 02:18:48 AM #5 Last Edit: January 13, 2021, 02:20:21 AM by eumagga0x2a
Have you zipped it?

edit: if it is too large even when ZIP-compressed, please upload it to WeTransfer, Mega, Dropbox or Google Drive.

eumagga0x2a

In case of difficulties with CleanTalk please send info as PM.

Ronstang

Here is the log you asked for


You cannot see attachments on this board.

eumagga0x2a

Thank you.

[HandleAction] 02:13:39-296 ************ Scale **************
[HandleAction_Navigate] 02:13:39-297 Scale :6401
[HandleAction_Navigate] 02:13:39-297 Scale Time:2012185 ms (total=3143540 ms)
[HandleAction_Navigate] 02:13:39-298 Scale Time:00:33:32,185 ms
[getFrameNumFromPtsOrBefore] 02:13:39-298 Best candidate for time 00:47:08,000 in reference is frame 88239
[HandleAction_Navigate] 02:13:39-299 Seeking to  Time:00:33:32,001 ms
[DecodePictureUpToIntra] 02:13:39-302 Decoding up to intra frame 88227, ref: 0
[edCache] Flush
[canSupportThis] 02:13:39-305 DXVA2 not enabled
[lookup] 02:13:39-305 No Matching Hw accel
[ADM_FFgetFormat] 02:13:39-305 No Hw Accel for that
Saving crash file to C:\Users\Ronstang\AppData\Roaming\avidemux\crash.py
Scripting video streams
Scripting segments
Scripting markers
Scripting post-processing
Scripting video encoder
Scripting video filters
Scripting audio tracks
Scripting muxer
RAX: 00002D77  RBX: 08454E20  RCX: 00000000  RDX: 129D2000  RSI: 03AC1040  RDI: 08555440  RSP: 0023AE30  RBP: 08568D40
R8: 129D3143  R9: 00001FE0  R10: 00001FDF  R11: 00000000  R12: 00000001  R13: 0023AEF0  R14: 08568D40  R15: 08555440
RIP: 00421B80  EFlags: 00010297

EXCEPTION_ACCESS_VIOLATION
ADM_Composer::decompressImage(ADMImage*, ADMCompressedImage*, unsigned int)  [avidemux.exe]

The crash happens at frame 88227 counting from zero, time 00:47:08 for "Rise of Empires  Ottoman S01E03 Into The Golden Horn.ts".

Could you please check whether the crash at this particular frame is reproducible? Please load the file, then do Ctrl+T and seek to time a few seconds before (e.g. to 00:47:00), then advance keyframe by keyframe until you reach 00:47:08,000.

If the crash is reproducible, it would be great if you could provide the last ~1 GiB of the file, cut with a tool equivalent to dd or tail on Linux, as a sample.

Independently from reproducibility, please disable post-processing in Avidemux preferences completely and report back whether it makes any difference (post-processing defaults to disabled in recent nightlies, but they don't change settings inherited from older versions).