Video Output is blank, or green

Started by JP, July 08, 2013, 09:45:15 PM

Previous topic - Next topic


I installed avidemux from an rpm file with no errors.  I loaded an AVI file with raw pixels RGB or YUV pixels as input.  Avidemux correctty figures out the number of frames, but the video window is black.  It's all green.  Any ideas what causes this to happen?

Jan Gruuthuse

Most likely codec or set codec parameters not recognized. Could also be a video card driver <> codec thing. Does it stays black/green while playing to? Have you tried other setting in avidemux: Preferences for Video display: X11, Xvideo, Vdpau, OpenGL, ... ?


It stays green while playing.  I don't know how to set preferences for Video display: X11, Xvideo, Vdpau, OpenGL, ... ?  How do I change them?

Jan Gruuthuse

Main Menu: Edit: Preferences: [Video]: Video display: choose something else
De-select: [ ] decode video using VDPAU, XVBA & LIBVA  and [ ]Enable openGl support.
close avidemux and start again.


Thanks for showing me how to change the display: I tried GTK+, XVideo, and SDL, and none of them worked.  The Video display window stays green.

Here is more info.  When I tried to play an old MPEG file: I get hundreds of these error messages:
[lavc] too many threads
[lavc] Error 2672, size 2672 NOTE: that number is different every time
[lavc] error in FFMP43/mpe4l got picture

When I try a raw YUV 422 format file. I get this error message
Quoteusing invalid coded for 422p (50323234)
    No B- frame wit hthat codec
Also, for both I get errors about no being avble to initialize the audio device, but let's ignore this at.

Jan Gruuthuse

Don't you have a avidemux 2.6.4 QT version? GTK version is on ice currently.


I definitely don't have the QT version.  I only have the cli and gtk version.  I'm not sure right now (at work) what version of avidemux I have, but I'll try to get the latest version later today, if I can find one for CentOS 6.


You can use my build, if you want.

All dependencies are available in repositires, but if you have problems with instalation, ask me!


I tried install from the download links that mit posted (in the thread How to install Avidemux on CentOS 6 ).  That didn't work.  It required about 20 dependencies.

I tried following this link but appears to have no avidemux at all.  It's designed to fool you into downloading other things.  No idea what kind of malware that installs on your system.

I looked at the post by Ares Drake, but that isn't a link to an avidemux rpm file.  It adds a new RPM repository to you system.  From Russia!

What's going on?  What's the easiest way to get a working avidemux 2.6.4?  Currently, my only working version is Avidemux 2.4.4.


So many dependecies, probably gets from ââ,¬Å¾avidemux-addons-poorââ,¬Å" and its installation is not mandatory.
Ares Drake link has refered to 2.6.3 version, which also my build.

Jan Gruuthuse

This is how the page should look like if you followed that link:
click to Enlarge

If not showing similar: different possibilities: your company, provider, government or N S A have done something to your used dns (rerouted).
P R I S M is everywhere :(


I'm very sorry.  I didn't mean to offend.  I clicked around this link ( ) for 10 minutes and every download link I clicked downloaded something other than avidemux.  So I was in a suspicious frame of mind.  That's why I was thinking malware.

Then when I clicked on the link that mit posted and downloaded it, and it wasn't avidemux either but another RPM repository, I was already in a suspicious frame of mind, so I had thought maybe that wasn't legitimate either.

Please don't be offended, though you have a right to be considering my remarks..  My comments reflect more my suspicious nature then anything else.  Thanks for building avidemux for everyone and thanks for all the help.  Again I'm sorry if I offended you.

Jan Gruuthuse

I'm not offended. Can't speak for mit. And now missing out on all this cash ;) Who knows  :P

Enjoy avidemux.


Quote from: JPI'm very sorry.  I didn't mean to offend. ...
Ok. Еverything's fine. Actually my English is very bad (probably you already noticed that), and that's a big part by reason of this misunderstanding.


Hi there,

how many cpu cores do you have on your system? I do have problems on a system with more than 8 cores. Semms that 8 is the maximum.

I've opened another thread here:,13306.0.html

Greets from Munich