14.10: how to remove files? and how to build debs

Started by bbruecker, March 20, 2015, 12:49:06 AM

Previous topic - Next topic



I was using avidemux for long time on LinuxMint and Ubuntu. But after updating one or years ago, avidemux didn't work any more. I'm now looking for a solution to cut DVB-T streams in copy Modus to MPEG-PS files. The issue with the  version which ubuntu is shipping is about audio: the avidemux-ubuntu verion does not cut audio at all.

I found the websit I downloaded the source from sourceforge and tryed to follow the instructions for installiong ( First, there is no file "bootStrap.bash" like it is described there; the file was renamed to "". So the instructions seems to be a bit outdated. Readme is empty, and I cannot find any other instructions in the package from sourceforge.

I'd decided to build debs, so I used the --deb flag. (From the instruction: "If you use --rpm, --deb or --tgz, bootStrap will automatically create the packages."). But as a result of my command: "bash --deb --with-qt4 --without-gtk --with-plugins", the script asks for sudo-password and is not creating debs. Instead it is installing lot of files, but it seems there is no avidemux3-qt. If I try to execute avidemux-qt, the shell tells me I have to install it or avidemux3-qut.  So something went wrong.

Now I need help:
1. Is there a way to remove the files safely?
2. As described I need a solution for fastly cutting dvb-t streams and creating MPEG-PS files from them. How can I compile the debs for that?


Jan Gruuthuse

You can delete the folder where you put the files for avidemux and tried to build these.
Then start all over. This instructions would install in your home directory:
1st time installation:
sudo apt-get update
sudo apt-get install git
git clone

following times:
cd ~/avidemux2 && git pull
build avidemux:
cd ~/avidemux2 && bash bootStrap.bash --deb --with-qt4 --without-gtk --with-cli
You would find  in this location~/avidemux2/debs these:
- avidemux3-core-2.6.8-150318-Linux.deb
- avidemux3-plugins-COMMON-2.6.8-150318-Linux.deb
- avidemux3-qt4-2.6.8-150318-Linux.deb
- avidemux3-plugins-QT4-2.6.8-150318-Linux.deb
- avidemux3-cli-2.6.8-150318-Linux.deb
- avidemux3-plugins-CLI-2.6.8-150318-Linux.deb
- avidemux3-plugins-SETTINGS-2.6.8-150318-Linux.deb
each one need to be installed (double click on them)

avidemux icon download:
you might edit avidemux.desktop to reflect where you did put the avidemux icon. Then right click on avidemux.desktop and copy to desktop.
desktop shortcut download: avidemux desktop links


Hi Jan,

Thank you for the replay. I think it is necessary to remove first the installed files, to have a clean base to follow your instructions. The case is, from the sourceforge-package is installing files to the system.

There are two lines with "sudo make install".

        echo "*** fail $1 ***"
        exit 1
        cd $TOP
export PREFIX=/usr
export TOP=$PWD
echo "* Avidemux simple build script *"
echo "* Need sudo to install libs *"
sudo -v
echo "* Building Main *"
rm -Rf buildMain
mkdir -p buildMain
cd buildMain
make -j 3 || fail make_main
sudo make install || fail install_main
sudo ldconfig
echo "*  Main Ok*"
cd $TOP
echo "* Making plugins *"
rm -Rf buildPlugins
mkdir -p buildPlugins
cd buildPlugins
make -j 3  || fail make_plugins
sudo make install
echo "*  All Done  *"

As I can can follow some output on the screen, the script copies fils to "/usr/lib/ADM_plugins/videoEncoder/". Probably there are more places.

I cannot find any uninstall rule in buildMain or buildPlugins. Is there any chance to get the files safely out of my system? Does someone know the auothors of the script which is placed in the sourceforge-package?


Jan Gruuthuse

If installed.Most likely nothing installed?
Use (Ubuntu) Software Center, in search field top right hand (looking glass) enter search parameter: avidemux3
This would show eventualy installed avidemux packages. click on each and click [Remove]


Thank you for replay,

As I described in my first statement from the sourceforge package is not creating the debs, but installing. It seems to me the script is ignoring the --deb-flag.

Or is there something wrong with the command, I usesd:

bash --deb --with-qt4 --without-gtk --with-plugins

From the I expected a folder "debs", not that the script is installing files.

Anyway I tried Ubuntu software center searching for avidemux, avidemux2 or avidemux3 with no result in section "installed".

Here are some of the output from the script:

-- Installing: /usr/lib/ADM_plugins/videoFilter/
-- Up-to-date: /usr/lib/ADM_plugins/videoFilter/
-- Installing: /usr/lib/ADM_plugins/videoFilter/
-- Up-to-date: /usr/lib/ADM_plugins/videoFilter/
-- Installing: /usr/lib/ADM_plugins/videoFilter/
-- Up-to-date: /usr/lib/ADM_plugins/videoFilter/
-- Installing: /usr/lib/ADM_plugins/videoFilter/
-- Up-to-date: /usr/lib/ADM_plugins/videoFilter/
-- Installing: /usr/lib/ADM_plugins/videoFilter/
-- Installing: /usr/lib/ADM_plugins/videoFilter/
-- Installing: /usr/lib/ADM_plugins/videoFilter/
-- Up-to-date: /usr/lib/ADM_plugins/videoFilter/
-- Installing: /usr/lib/ADM_plugins/videoFilter/
-- Installing: /usr/lib/ADM_plugins/videoFilter/
-- Installing: /usr/lib/ADM_plugins/audioEncoders/
-- Installing: /usr/lib/ADM_plugins/audioEncoders/
-- Installing: /usr/lib/ADM_plugins/audioEncoders/
-- Installing: /usr/lib/ADM_plugins/audioEncoders/
-- Installing: /usr/lib/ADM_plugins/audioEncoders/
-- Installing: /usr/lib/ADM_plugins/audioEncoders/
-- Installing: /usr/lib/ADM_plugins/audioEncoders/
*  All Done  *

And much more of that! I'm afraid it could affect other software if I manually would try to delete  those files.

Any Idea how to safely remove those files?

Jan Gruuthuse

ADM_plugins = avidemux 2.5.# branch
ADM_plugins6 = avidemux 2.6.# branch
Both are used exclusively by avidemux.
I would leave those alone. The content  (w/sh)ould be overwritten upon next install by avidemux 2.6 or 2.5 branches.

the build is:
bash bootStrap.bash --deb --with-qt4 --without-gtk --with-cli
and not

Jan Gruuthuse

Did look somewhat further in to this.
You did install avidemux 2.5.#
open a terminal and issue this command:/usr/bin/avidemux2_qt4
Avidemux should start
you could uninstall as before with software center: search parameter: avidemux