August 13, 2020, 11:30:41 am

News:

--


Unable to load jpegs created in gimp.

Started by 3d420, November 21, 2016, 08:07:14 pm

Previous topic - Next topic

3d420

 I chose this software because all the reviews said how easy it would be.  ::) Four days later, I have nothing.  ???

eumagga0x2a

Quote from: 3d420 on November 24, 2016, 03:05:15 am
Ok, I ran it. Now what?


If the command finished with a success, you should be able to run Avidemux by executing

avidemux3_qt5

If the command finished with a failure, you should have posted the error message.

Jan Gruuthuse

Probably you still need to install the newly create debs:
Go into folder with debs:
cd ~/avidemux2/debs
Remove developer debs:
rm --interactive=never *-dev.deb
Install remaining debs
sudo dpkg -i *.deb

now you should either find:
/usr/bin/avidemux3_qt5 or /usr/bin/avidemux3_qt4
open terminal and try one of above, this should start avidemux.

eumagga0x2a

Quote from: Jan Gruuthuse on November 24, 2016, 07:36:21 am
Probably you still need to install the newly create debs: [...]


No, no, no! If compilation was successful, the installation will be performed by the same script at line 13: https://github.com/mean00/avidemux2/blob/master/createDebFromSourceUbuntu.bash#L13 (unfortunately, the script will proceed with the installation even if the build returned an error, which should be fixed).

Quotenow you should either find:
/usr/bin/avidemux3_qt5 or /usr/bin/avidemux3_qt4


Presumably only the first one (qt4 build requires the --enable-qt4 option passed to bootStrap.bash which is not the case here).

Jan Gruuthuse

November 24, 2016, 08:20:53 am #34 Last Edit: November 24, 2016, 08:42:42 am by Jan Gruuthuse
If QT5 is not on the system? Or does the script install this one to?
If no QT5 then:
cd ~/avidemux2 && bash bootStrap.bash --deb --enable-qt4 --without-gtk --with-cli

eumagga0x2a

November 24, 2016, 08:43:51 am #35 Last Edit: November 24, 2016, 08:46:14 am by eumagga0x2a
The script installs Qt5, which amounts to an outdated version 5.2 on Mint Rebecca.

It looks for me like 3d420 were uncapable of handling any complexity, so please let us keep everything simple.

3d420

November 24, 2016, 03:51:17 pm #36 Last Edit: November 24, 2016, 03:59:48 pm by 3d420
Quote from: eumagga0x2a on November 24, 2016, 08:43:51 am
It looks for me like 3d420 were uncapable of handling any complexity, so please let us keep everything simple.
Yes please!
I don't understand any of this, and your disagreement above tells me I am not alone.
Please give me complete instructions. If you don't tell me how to do it exactly, I will do it wrong. I have absolutely no experience in any of this.
After I ran the commands you gave me last night, I can't find any folder for avidemux anywhere, and my software manager does not list it. I finally went to sleep.

3d420

I hope you see this as an opportunity to create a clear set of instructions. This kind of frustration is why people go back to windows.  :(

Jan Gruuthuse

Check If your CPU supports 64-bit, you could install a 64-bit OS Ubuntu LTS or Mint. 32-bit is a little dated these days.

3d420

My computer is older than dated. It is definitely not 64 bit.
And now an avidemux folder has mysteriously appeared. How should I proceed?

eumagga0x2a

Quote from: 3d420 on November 24, 2016, 04:42:28 pm
And now an avidemux folder has mysteriously appeared. How should I proceed?


I have not a slightest idea, which "avidemux folder" you mean, but the question how to proceed has been answered in http://avidemux.org/smif/index.php/topic,17287.msg78103.html#msg78103. In doubt try to run

avidemux3_qt5

in the terminal and in case no Avidemux window appears, post the error message shown in the terminal.



3d420


eumagga0x2a

This means, either the build of Avidemux (or just the part of Avidemux which provides the graphical interface) failed or we've got a Qt4-flavour of Avidemux (unlikely, but who knows) as Jan has suggested.

If

avidemux3_qt4

returns "avidemux3_qt4: command not found" as well, we have no other option as to track the failure and to see if anything can be done to avoid it (please note that I have very little time to guide you unless you get used to read what commands run in terminal tell you yourself).

If you have an "avidemux2" folder in your home directory, please look with a file manager into it if there are "deb" and "install" subfolders and if the former is empty, which of the "build*" folders exist.

If you don't have any of the "build*" (buildCli, buildPluginsCLI, buildPluginsQt5, buildQt5, buildCore, buildPluginsCommon, buildPluginsSettings) folders, you didn't even try to start building Avidemux. In this case you failed to follow step 5 (or even 4) of the instructions given in http://avidemux.org/smif/index.php/topic,17287.msg78085.html#msg78085. Only in this case resume with

cd ~/avidemux2 && bash createDebFromSourceUbuntu.bash

If there are some "build*" folders but not the others, please post what

ls -d ~/avidemux2/build*

returns. This would allow to understand roughly which phase of the build failed. In this case, the next step would be to run

cd ~/avidemux2 && bash bootStrap.bash --deb 2>&1 | tee ~/adm-build.log

and once the build fails, compress and attach the "adm-build.log" text file (it may be too big to attach even if compressed). If it is impossible to attach the log, you'll have the choice either to open it (not compressed, of couse) in a text editor, find the place which describes the failure and post just that part, or upload it to some file hoster or the content to http://pastebin.com/.

Please note that the command above only tries to build Avidemux, not to install the generated .deb packages on success yet.

Jan Gruuthuse

November 25, 2016, 07:27:30 am #43 Last Edit: November 25, 2016, 07:49:56 am by Jan Gruuthuse
a successful build ends like this:
Quote** Preparing debs **
Preparing packages
** debs directory ready **
total 10800
-rw-rw-r-- 1 jan jan    2460 nov 25 08:45 avidemux3-cli-2.6.15-161125-dev.deb
-rw-rw-r-- 1 jan jan 1594508 nov 25 08:45 avidemux3-cli-2.6.15-161125-runtime.deb
-rw-rw-r-- 1 jan jan  320956 nov 25 08:45 avidemux3-core-2.6.15-161125-dev.deb
-rw-rw-r-- 1 jan jan 3990972 nov 25 08:45 avidemux3-core-2.6.15-161125-runtime.deb
-rw-rw-r-- 1 jan jan   46998 nov 25 08:45 avidemux3-plugins-CLI-2.6.15-161125-plugins.deb
-rw-rw-r-- 1 jan jan 1520376 nov 25 08:45 avidemux3-plugins-COMMON-2.6.15-161125-plugins.deb
-rw-rw-r-- 1 jan jan  362862 nov 25 08:45 avidemux3-plugins-qt5-2.6.15-161125-plugins.deb
-rw-rw-r-- 1 jan jan    4810 nov 25 08:45 avidemux3-qt5-2.6.15-161125-dev.deb
-rw-rw-r-- 1 jan jan 3187314 nov 25 08:45 avidemux3-qt5-2.6.15-161125-runtime.deb
-rw-rw-r-- 1 jan jan    1946 nov 25 08:45 avidemux3-settings-2.6.15-161125-settings.deb
** ALL DONE **
** The installable packages are in the debs folder **
Installing avidemux...
Selecting previously unselected package avidemux3-cli-dev.
(Reading database ... 248023 files and directories currently installed.)
Preparing to unpack avidemux3-cli-2.6.15-161125-dev.deb ...
Unpacking avidemux3-cli-dev (2.6.15-161125) ...
Preparing to unpack avidemux3-cli-2.6.15-161125-runtime.deb ...
Unpacking avidemux3-cli-runtime (2.6.15-161125) over (2.6.15-161124) ...
Selecting previously unselected package avidemux3-core-dev.
Preparing to unpack avidemux3-core-2.6.15-161125-dev.deb ...
Unpacking avidemux3-core-dev (2.6.15-161125) ...
Preparing to unpack avidemux3-core-2.6.15-161125-runtime.deb ...
Unpacking avidemux3-core-runtime (2.6.15-161125) over (2.6.15-161124) ...
Preparing to unpack avidemux3-plugins-CLI-2.6.15-161125-plugins.deb ...
Unpacking avidemux3-plugins-cli-plugins (2.6.15-161125) over (2.6.15-161124) ...
Preparing to unpack avidemux3-plugins-COMMON-2.6.15-161125-plugins.deb ...
Unpacking avidemux3-plugins-common-plugins (2.6.15-161125) over (2.6.15-161124) ...
Preparing to unpack avidemux3-plugins-qt5-2.6.15-161125-plugins.deb ...
Unpacking avidemux3-plugins-qt5-plugins (2.6.15-161125) over (2.6.15-161124) ...
Selecting previously unselected package avidemux3-qt5-dev.
Preparing to unpack avidemux3-qt5-2.6.15-161125-dev.deb ...
Unpacking avidemux3-qt5-dev (2.6.15-161125) ...
Preparing to unpack avidemux3-qt5-2.6.15-161125-runtime.deb ...
Unpacking avidemux3-qt5-runtime (2.6.15-161125) over (2.6.15-161124) ...
Preparing to unpack avidemux3-settings-2.6.15-161125-settings.deb ...
Unpacking avidemux3-settings-settings (2.6.15-161125) over (2.6.15-161124) ...
Setting up avidemux3-core-dev (2.6.15-161125) ...
Setting up avidemux3-core-runtime (2.6.15-161125) ...
Setting up avidemux3-plugins-cli-plugins (2.6.15-161125) ...
Setting up avidemux3-plugins-common-plugins (2.6.15-161125) ...
Setting up avidemux3-plugins-qt5-plugins (2.6.15-161125) ...
Setting up avidemux3-qt5-dev (2.6.15-161125) ...
Setting up avidemux3-qt5-runtime (2.6.15-161125) ...
Setting up avidemux3-settings-settings (2.6.15-161125) ...
Setting up avidemux3-cli-dev (2.6.15-161125) ...
Setting up avidemux3-cli-runtime (2.6.15-161125) ...

3d420

 avidemux3_qt4
No command 'avidemux3_qt4' found, did you mean:
Command 'avidemux2_qt4' from package 'avidemux-qt' (multiverse)
avidemux3_qt4: command not found