2.7.0 appImage missing DRM library, can't start

Started by dandv, October 01, 2017, 12:47:37 AM

Previous topic - Next topic


I've just downloaded the latest appimage and it won't start on Ubuntu 16.04:

Quote$ ./avidemux_2.7.0.appImage
/tmp/.mount_966niI/usr/bin/avidemux3_portable: error while loading shared libraries: libva-drm.so.1: cannot open shared object file: No such file or directory

The appImage for 2.6.14 works fine.


Sorry for being late:

the AppImage needs the libva-drm.so.1. the simple way is as follows:
Open a terminal. Enter sudo apt-get install libva.drm
Of course you can use synaptic paket manager to install libva-drm.

For a 64bit system
The libva-drm.so.xxx will be installed in /user/lib/x86_64-linux-gnu/. Additionaly a symlink libva-drm.so.1 will be in this directory. Check that the symlink is there.
Now avidemux.AppImage should start

The better way would be if this lib would be in the appimage.
( AppDir/usr/lib ).
I tried it and it solves the problem. The appimage can run then in older and/or newer Ubuntu/Debian versions as well as in archlinux


I've just install Xubuntu 18.04 and I got the same error.
In the repos I can only find libva-drm2 but installing it didn't resolve the issue.
If anyone else has resolved this issue could they please share their solution here.
Thank you.


Do you refer to the latest nightly (currently r180417)?

Please note that it is trivial to build Avidemux from source on Ubuntu. However, it has not been tested with Ubuntu 18.04 yet. If you encounter problems compiling Avidemux, please report them.

Jan Gruuthuse


I tried the latest nightly as suggested. After a couple of crashes, it eventfully did open and seemed to be OK. The missing dependency was not reported so it looks like I only need to be patient and the next stable release will address the problem. Thanks


If anyone is having trouble with the universal app for avidemux 2.7.0, try the PPA from UbuntuHandbook. I was able to get avidemux up and running without any problems using it.
Just Google "install-latest-avidemux-2-7-0-ubuntu-17-10-18-04" and you should find it.


The build from the UbuntuHandbook PPA has broken maximize. Please update the AppImage for Ubuntu 18.04.


UbuntuHandbook offers builds from the code of the last release, which has become severely outdated meanwhile. It is trivial to build from git master on Ubuntu, please do it and don't waste your time looking for PPAs somewhere.